Skip navigation

E-mail so slow to send after Lion upgrade

7183 Views 17 Replies Latest reply: Jul 28, 2012 7:28 AM by Anthony Sergi RSS
1 2 Previous Next
Jamie Wood Level 1 Level 1 (5 points)
Currently Being Moderated
Jul 24, 2011 7:09 AM

Taking 5 minutes to send any e-mails using any SMTP server. tried 3 different networks and both laptop and quad core iMac. Mobile Me support wont help.

iBook G4, Mac OS X (10.3.9)
  • abross86 Level 1 Level 1 (15 points)
    Currently Being Moderated
    Aug 2, 2011 6:48 AM (in response to Jamie Wood)

    I'm having a similar problem. After upgrading to lion, sending an email in mail.app takes forever. I'm using a gmail smtp account, and often after hitting the send button, the progress bar in the "Activity" section will hang for 2-3 minutes before sending. Never had this problem on snow leopard.

  • jperks Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 2, 2011 4:44 PM (in response to Jamie Wood)

    Mail is painfully slow for me, too. Uploading at ~3 KB/s

  • JoseLuiss Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 16, 2011 12:11 PM (in response to Jamie Wood)

    any luck guys with the fix ?????   

  • Glenn Carter Level 4 Level 4 (3,360 points)
    Currently Being Moderated
    Aug 16, 2011 12:38 PM (in response to Jamie Wood)

    It appears that Apple is aware of this problem and is working on a fix for a future update. In the meantime you'll need to do the following to resolve the issue:

     

    1. Quit Mail

    2. Hold down OPT and select LIBRARY from the GO menu

    3. Open Mail --> V2 --> MailData

    4. First, DUPLICATE the "Accounts.plist" so you have a copy that says "Accounts Copy.plist" (Do not edit this one in the event you need to go back to it).

    5. Open the original "Accounts.plist" with TextEdit

    6. Scroll down until you see the following:

     

    Screen Shot 2011-08-16 at 12.27.23 PM.png

     

    7. WITHOUT changing any other text, change the "25" to "587" so that it looks like this:

     

    Screen Shot 2011-08-16 at 12.27.47 PM.png

     

     

    8. Close the Accounts.plist and relaunch Mail.

     

    Now try sending an email.

  • JoseLuiss Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 16, 2011 1:16 PM (in response to Jamie Wood)

    I followed your instructions but no change for me, still takes 40 sec  to a minute to send a blank page

  • Glenn Carter Level 4 Level 4 (3,360 points)
    Currently Being Moderated
    Aug 16, 2011 2:10 PM (in response to JoseLuiss)

    Jose, is it a MobileMe email address you are using? The fix above should only work for MM accounts that are having trouble sending messages.

     

    When you compose a message what smtp server are you using? Is it "MobileMe (MobileMe)"? Or some other smtp setting?

     

    Go to Mail --> Preferences --> Accounts --> Outgoing Mail Server (SMTP) --> "Edit SMTP server list".

     

    How many to do you have lsited there?

  • JoseLuiss Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 17, 2011 5:12 AM (in response to Glenn Carter)

    Well, I do have more than one account,  one mobileme and two godaddy but if the fix its only for mobileme what I'm going to do with my godaddy accounts because these accounts I used for work and if I have to send a large file like I always do its going to take forever ,  and this is coming before lion but still no fix, I don't know why in my windows machine takes half a second to send an email from any account even with mobileme, anyway I hope apple will fix this some day

  • slawomirfromtilburg Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 27, 2011 1:25 AM (in response to Jamie Wood)

    I will shortly describe my situation. have a MacbooAir 2011 i5 Lion. have a Gmail account configured in the Mail app. it took like forever sending a message, with or without attachment. now I've played with mail settings and the problem seems to be gone. I mean sending an email now takes up to 10 seconds and I really see the rpogress bar moving. so here is what I did (simple but might help):

     

    Mail ==> Preferences ==> Composing ==> Send new messages from:

     

    at default this setting is set to "Account of selected mailbox"

    try and change that to the actual account address you're using.

     

    underneath there is another setting which I've changed aswell - "Create notes in", also set it to your actual account

     

    it seems to help to some extend but it true, the mail app is sooooooo slow and it takes waaaay to much of the resources (CPU).

     

    cheers

  • JoseLuiss Level 1 Level 1 (0 points)

    That's it OMG was so easy really I just select mobileme instead of defaul and now is instant sending 0 second wait  even my godaddy accounts  thanks slawomirfromtilburg  u rock dude

  • kanyfilm Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 30, 2011 6:04 PM (in response to Glenn Carter)

    Glenn Carter's fix worked for me and this has been bugging me for days!  thanks!  hopefully it stay working, it's so erratic...  please fix this apple.

  • Erich Zinser Level 1 Level 1 (5 points)
    Currently Being Moderated
    Sep 3, 2011 8:40 AM (in response to Glenn Carter)

    Hi Glenn:

     

    Tried your solution but my port was already set to 587, when I see the activity window there is almost always an endeless Checking account connections and it says connecting to server smtp.me.com,

     

    Mails do go out but painfully slow.

     

    Did a clean install, that did not work, chatted with mobile three full days with no luck.

     

    I have reported a bug

     

    my isp is not blocking port 587, and it is a high bandwith connection, I can connect using the 587 port in terminal no problem

     

    I have noted that when instead of using the wifi connection I use a personal HotSpot created by my iphone mail works fast and predictable, this is when instead of the arches in the toolbar there is a chain, so I assume the bug lies somewhere in the networking infrastructure of Lion.

     

    There is another thread called "Mobileme SMTP timeout since Lion" you might read into the growing list of discontent in that thread.

     

    Can you help?

     

    EZ

  • Glenn Carter Level 4 Level 4 (3,360 points)
    Currently Being Moderated
    Sep 3, 2011 10:51 PM (in response to Erich Zinser)

    Erich, here is what I would suggest trying. Repeat the steps outlined above once more. When you get to the line that contains "587", delete the numbers and reenter 587 again. Then save the file. Reboot, and see if things improve.

     

    Again, perform this modification on the original file, not on the copy you made at the outset. The system will not use the copy at all. It's just there as a fallback position in the event the file you modify is corrupted. Cheers!

  • tpf1952 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 11, 2011 5:24 AM (in response to Glenn Carter)

    Thanks, Glenn! Your fix fixed mine issue.

     

    Tom

  • kanyfilm Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 11, 2011 9:12 AM (in response to Jamie Wood)

    an update:  although this fix does work, this issue still persists for me.  i don't get it.  some days emails go out fine and quick, others they don't go out at all!  then i have to use gmail, through macmail which works.  what is this all about? 

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.