Skip navigation

Photos disappear in iPhoto after import - They just vanish.

15380 Views 19 Replies Latest reply: Mar 29, 2014 7:54 AM by LarryHN RSS
1 2 Previous Next
Ninschinwii Level 1 Level 1 (0 points)
Currently Being Moderated
Aug 31, 2011 9:09 PM

I hoping someone can help me retrieve my pictures.  I have imported many, many photos from my camera into iPhoto.  Once they were imported and I've looked at them in iPhoto, they disappear when I close and reopen iPhoto.  I just noticed this problem and observed that it seems I've lost all my pictures since I upgraded to Lion.  It may be coincidence - I don't know whether the gap is because I did no imports since June 11 and July 21 or I lost some pictures even before I upgraded.  Tonight I uploaded more photos to see if I could tell what was happening.  The photos were there, I saw them, I looked at all of them, I shut iPhoto, restarted it, and the pictures were gone again.  I also noticed that a picture came back into the print folder I deleted before closing iPhoto.  I've looked everywhere on the computer I can think of with no luck.  This is a big deal, because they were some important photos on there.  I have a late 2009 27" iMac running Lion OS.  Thanks in advance.

iPhoto '11, Mac OS X (10.7.1)
  • LarryHN Level 9 Level 9 (54,895 points)
    I also noticed that a picture came back into the print folder I deleted before closing iPhoto.

    Exactly what are you talking about here? Where is the "print folder" and how did you delete it? Have you looked in the iPhoto trash?

     

    LN

  • Terence Devlin Level 10 Level 10 (121,745 points)

    Option 1

    Back Up and try rebuild the library: hold down the command and option (or alt) keys while launching iPhoto. Use the resulting dialogue to rebuild. Choose to Rebuild iPhoto Library Database from automatic backup.

     

    If that fails:

     

    Option 2

    Download iPhoto Library Manager and use its rebuild function. This will create a new library based on data in the albumdata.xml file. Not everything will be brought over - no slideshows, books or calendars, for instance - but it should get all your albums and keywords back.

     

    Because this process creates an entirely new library and leaves your old one untouched, it is non-destructive, and if you're not happy with the results you can simply return to your old one. .

     

    Regards

     

    TD

  • Craig Jones3 Level 1 Level 1 (5 points)

    I'm seeing much the same thing but under 10.6.  There were other curious symptoms: thumbnails of the missing photos would briefly flash on the screen when scrolling through "Photos" before being replaced by images of other photos.  Attempting to rebuild the iPhoto database using the command-option options failed (after 2 days I gave up).  Rebuilding the iPhoto library from iPhoto Library Manager also failed to recover the photos.  But if I go into Package Contents of the iPhoto Library and drill down through the Masters>2011>08 directory, lo and behold there they all are.

     

    So why does every recovery effort fail??? (Well, I didn't try Picassa).  Photos are clearly there and seem to be in the right place, so at minimum one would have thought the "find orphaned photos" option might have worked, but it did not (I did run iPhoto with only that option from the command-option screen and it did complete and failed to find the photos).  You might also expect iPhoto Library Manager's rebuild to find these.  Is there something magic about 2011>08 directories??

  • Terence Devlin Level 10 Level 10 (121,745 points)

    No, it just means that the database is too corrupt to be rescued.

     

    NOw your options are two:

     

    1. Restore from your back up

     

    2. Recover the photos and strt over from scratch.

     

    Obviously the first is preferred.

     

    Regards

     

     

    TD

  • Craig Jones3 Level 1 Level 1 (5 points)

    I wish a recover from backup was possible, but because of the overhead generated by trying to rebuild with iPhoto Library Manager, the backup disk filled and TimeMachine killed the pre-corrupt stuff (*sigh*).  My last copy is an iPhoto '09 backup from April, so to go all the way back, I'd have to reimport that and then import the raw Master files that I can find in the current iPhoto library, losing the metadata entered since then (quite a bit).

     

    I've posted a more thorough description of what I've gone through elsewhere <https://discussions.apple.com/message/16097174#16097174>.  I am now wondering how much of my troubles came with 9.1.5 of iPhoto...

     

    Would be nice if there was an integrity checker for the database.  Has anybody felt comfortable looking directly at the database?

  • jusa Level 1 Level 1 (0 points)

    I have almost the same problem but with calendars in iphoto 11.

    1.) create a new calender (all works fine)

    2.) import photos from aperture first time into the calender project --> works fine

    3.) import additional photos from aperture again --> calendar is buggy! I can´t see any cal sheets.

     

    Regards jusa

  • GMarinosyan Level 1 Level 1 (5 points)

    I had exactly the same issue and have finally found a way to fix it. The problem is that you probably do not have writing abilities in your iPhoto library. Here are the steps to changing this:

     

    1. Find your iPhoto Library file (it is probably in your Pictures folder)
    2. Right click on it and press "Get Info"
    3. Look at the "Sharing and Permissions" tab
    4. Click the little lock icon at the bottom and type in your username and password (make sure you are the administrator on the computer)
    5. Now, if you name is on the list in the Sharing and Permissions box, change the other column to Read & Write
    6. If your name is not, then click the plus icon at the bottom, locate your username and press elect. Now select Read & Write in the dropdown menu beside your name.

     

    Now go and try to import something into iPhoto! It should now work!

     

    Hope this helps,

    George

  • Terence Devlin Level 10 Level 10 (121,745 points)

    To correct permissions in the  iPhoto Library:

     

    Hold down the command and option (or alt) keys while launching iPhoto. Note the permissions option in the sunsequent dialogue.

     

     

    Regards

     

     

    TD

  • mirceainlondon Level 1 Level 1 (0 points)

    Thanks, George, your response was really helpful and it seems to have solved my similar problem!

     

    Regards,

    Mircea

  • HawkXPII Level 1 Level 1 (0 points)

    This is somewhat related to the initial question in that photos that my wife imported were seemingly disappearing. When I clicked on hide photos already imported they would still hide. I discovered that her new camera was off by one year and they were all there.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.