Skip navigation

Why is autofill suddenly acting weird?

1109 Views 6 Replies Latest reply: Jul 3, 2012 8:20 AM by Jason_1848 RSS
alansky1 Level 1 Level 1 (35 points)
Currently Being Moderated
Jul 25, 2011 3:45 PM

For years I have relied on Safari's autofill feature to fill in my name and address on web forms. Now this feature has suddenly started behaving strangely. When I start typing my name into a web form, this is what pops up:


This is a pain in the neck because, like many people, I have more than one address and more than one email address. Furthermore, I often do not enter my main address and email when filling out forms on the web. Safari used to do the right thing most of the time based on my past entries. Now it wants to use my main Address Book entry and will do nothing else. I end up having to type everything by hand. The autocomplete function seems to be totally disabled. In other words, if I start typing P.O. Box..., Safari won't even autocomplete that one entry. What a drag!


It seems as though the only possible workaround is to create two entirely separate Address Book entries for myself, and even that is problematic because I'd have to use two slightly different names. What gives!? Is this a "feature" or a bug?!

20" iMac 2.16GHz Core 2 Duo, Mac OS X (10.6), 13" 2.53GHz MacBook Pro
  • DeaconMac Calculating status...
    Currently Being Moderated
    Jul 27, 2011 2:43 PM (in response to alansky1)

    There is a fix, but you won't like it (I don't). Grab Safari 5.0.5 from your backup and install it over the 5.1 version. That will return your familiar AutoFill.


    This "upgrade" is a disaster. AutoFill worked pretty well up through 5.0.5. Now it doesn't really work at all. The new version would add about 3 hours to my workday every day -- it is that cumbersome and slow. It's a total fail.

  • Brainwurks Calculating status...
    Currently Being Moderated
    Sep 6, 2011 1:35 PM (in response to alansky1)

    I too am having issues with autocomplete. I would start typing my home address (exactly as it is entered in my contact in Address Book). When I click on the AutoFill popup or press enter after it appears, it replaces my home phone, city and zip with those from my work address. I went into Preferences>AutoFill and clicked on "Edit" next to the "Using info from my Address Book card" option. It opens my card in Address Book and there are checkboxes to the right of each field entry. I deduced that by unchecking the boxes next to my work address, AutoFill would just give me my home address. I thought wrong. It had no effect and the issue persisted.


    Either ignore the AutoFill popup and continue to type or bypass the feature by unchecking the AutoFill options that are problematic until Apple decides to fix it. I unchecked the option to AutoFill "using my card in Address Book" and left the other two checked. Now Safari auto-completes based on the info I have typed in the web form rather than from my Address Book and life is simpler.

  • Brainwurks Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 6, 2011 3:46 PM (in response to alansky1)

    Hadn't thought of that one. Glad you have a work around.

  • Jason_1848 Calculating status...
    Currently Being Moderated
    Jul 3, 2012 8:20 AM (in response to Brainwurks)

    Same problem, why doesn't unchecking the work address suppress that address in autofill?


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.