Skip navigation

kernel_task running wild!

48287 Views 124 Replies Latest reply: Jan 26, 2014 2:19 PM by moonmen RSS
1 2 3 ... 9 Previous Next
snow_bunny Calculating status...
Currently Being Moderated
Aug 14, 2011 9:22 AM

Hi All,


I am currently running Lion on the new MacBook Air 2011 refresh (11", i7, 256 GB SD).


A problem started when I would plug my external hard disk into my Air to do a Time Machine backup.  The kernel_task process shoots up to 100% cpu usage, and as far as I can tell, the external drive is never properly mounted by Lion and the Time Machine backup never begins.  Even after unplugging the external drive, the kernel_task process still sits at over 100% cpu usage.  Only a hard reboot (holding down the power button) allows me to reboot, and upon reboot the kernel_task process is no longer misbehaving (I'm only left with mds and other similar processes trying to fix my spotlight index for many hours).  I had successfully backed up onto this external drive using Time Machine quite a few times already, and the problem doesn't always happen when I plug my external drive in.  But when the problem happens, it's immediately right after I plug my external drive in.  Nothing else is really happening on the laptop.  All I have to do is plug my external drive in.  Any ideas on what's causing this?  Is this a Lion issue?  Is this an Air issue?  Is this simply my external hard disk? 


Thanks to the community for any help.  I've googled and read so many things regarding kernel_task cpu usage and none of them seem to apply to me.  I don't seem to have the temperature issue everyone talks about. 

MacBook Air, Mac OS X (10.7)
  • leroydouglas Level 6 Level 6 (13,320 points)
    Currently Being Moderated
    Aug 14, 2011 9:38 AM (in response to snow_bunny)

    You can kill the process in Activity Monitor click the runaway process, by clicking on it.




    pic 1.png


    If there are other partitions on the external HD make sure they are in the list to EXCLUDE.  See TM>preferences>options

    MacBook Pro, Mac OS X (10.7), 2.4GHz IntelCore i5 320 HD 8GB RAM
  • woodmeister50 Level 4 Level 4 (3,690 points)
    Currently Being Moderated
    Aug 14, 2011 10:20 AM (in response to snow_bunny)

    Disable indexing of your external drive by spotlight

    and see what happens.  Do this in Preferences->Spotlight

    and select the privacy button and and add the external

    drive to the list to prevent searching reboot and

    see what happens.


    Also, do you have another drive or a USB stick to plug

    in and see if the same thing happens.  Forgot to ask,

    is it a Firewire or USB drive and what Make/Model.

  • npunhani Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 22, 2011 2:34 AM (in response to woodmeister50)

    Same issue after OS X Lion upgrade. I am running 10.7.1...


    Other applications

    1. Preview in full screen. This is the first app that hung itself when i tried zoom in then zoom out using double finger tap; and then the kernel_task showed 100%.
    2. Safari in full screen (it was the next one to hang)
    3. Microsoft Word in another desktop


    I am running 2.4 GHz Intel Core i5. 4 GB Ram.

    No external devices.


    Offlate, I've started encountering this issue almost once every 2 days.

  • npunhani Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 22, 2011 2:35 AM (in response to npunhani)

    (sorry for the duplicate post)


    Message was edited by: npunhani

  • Damitri Calculating status...
    Currently Being Moderated
    Sep 4, 2011 4:56 PM (in response to snow_bunny)

    I have had this problem with Lion on my old Mini lately. Don't know what causes it but the system gets VERY laggy to the point of being unuseable. I discovered today that it was the kernel_task going wild. Never ever happened in Snow Leopard for me at least. Anyway, the fix for me was to select the kernel_task in the Activity Monitor and click 'Inspect'. When I did that it immediately went down to <1% CPU activity. I don't know if this is reproducible since I only just discovered it. Much better than having to restart which takes forever anyway with the kernel_task using up 99% of the CPU!

  • colin N Calculating status...
    Currently Being Moderated
    Sep 8, 2011 7:05 AM (in response to snow_bunny)



    I have a new MBA (that came out with OS X Lion) and I've been having this problem too.

    I have narrowed down the cause to the "Power Throttle State"


    If you open up Console (search for it using spotlight) and view the logs, you'd notice that when the Power Throttle State is 1, the CPU usage is close to 0. When it's 0, then the CPU usage shoots up to 300% or so (for me).


    I suppose it changes the Power Throttle State in response to CPU temperature.

    Mine's around 50 degrees celsius.


    The OS can change the Power Throttle State many times in a minute, as the temperature fluctuates.


    I haven't however found a solution except to cool the MBA (even this is inconsistent: I get slow performance even in a cold room)

  • paediater Calculating status...
    Currently Being Moderated
    Sep 13, 2011 11:29 AM (in response to snow_bunny)

    snow_bunny, this isn't an MBA issue as I am having exactly the same sh-t on my MC374. Trying to get rid of this, I erased my backup disk and had made a new backup, but the same problem emerged when I tried to make next backup, and MBP started to behave weird — applications didn't start, system preferences didn't open. When I tried to stop backing up, system partly freezed (SBOD appeared, TM icon in the system tray freezed, and programs refused to start).

  • paediater Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 13, 2011 11:44 AM (in response to snow_bunny)

    This is the next thing I planned to check — I am pretty sure I had noticed this right after I encrypted my backup a few days ago. I'll let you know if it helps.


    And, did your Spotlight reindex disk after reboot?

  • paediater Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 13, 2011 12:06 PM (in response to snow_bunny)

    It seems like the cause is backup encryption; as far as I see, Lion doesn't work right with encrypted volumes — I just rebooted, turned automatic backup off and plugged in my hard drive. Disk Utility  failed to unmount it when I tried to erase the volume, name of the partition turned to disk2s2 when I restarted Disk Utility.


    Look, was the backup volume the only on your hard drive? I encounter Disk Utility's strange behavior — I erased both partitions on my HDD (400 Gb used for TM and 240 Gb used for data storage), and when I tried to create one partition of 640 Gb named, for example, "Time Machine", it made 400 Gb partition called "disk2s2". What a...

  • paediater Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 14, 2011 1:14 AM (in response to snow_bunny)

    Eventually, everything works fine after I made unencrypted backup.


  • pedrosp2 Calculating status...
    Currently Being Moderated
    Oct 15, 2011 5:41 AM (in response to snow_bunny)

    DROPBOX is guilty

    just disabling the launch after restart has slow down to almost zero the kernel process.

1 2 3 ... 9 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (6)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.