1 2 Previous Next 15 Replies Latest reply: Sep 9, 2011 1:30 PM by XRayLarry
XRayLarry Level 1 Level 1 (10 points)

[Formerly discussion https://discussions.apple.com/message/15646754 ]

 

We are one of the old iTunes U stores where Apple hosts our content. We had private content that was under credential access, and publically-accessible content. We moved our public content into the Public Site Manager, and soon after that the direct links to the private content stopped working. I've asked for help here in "Using iTunes U", without a solution. I've recently found a failure mode that I feel deserves a new discussion.

 

Here is a direct link to some of our private content:

 

https://deimos.apple.com/WebObjects/Core.woa/BrowsePrivately/deanza.edu.20336305 98

 

When used in a browser, deimos.apple.com sends back HTML with a body tag like this:

 

<body onload="return open('itmss://deimos.apple.com/WebObjects/Core.woa/Browse/deanza.edu.2033630598 ?ignore.mscache=5947157');">

 

... and then iTunes opens, but instead of calling my browser to show our login page, iTunes shows our public iTunes U storefront.

 

Putting this URI into the browser's address area gives the same behavior:

 

itmss://deimos.apple.com/WebObjects/Core.woa/Browse/deanza.edu.2033630598

 

but using this URI results in the correct behavior - the browser opens iTunes, which in turn correctly opens a browser window to our login page:

 

itmss://deimos.apple.com/WebObjects/Core.woa/BrowsePrivately/deanza.edu.20336305 98

 

Why is deimos.apple.com sending me an incorrect itmss URI with /Browse/ instead of /BrowsePrivately/ ?

  • 1. Re: /Browse/ versus /BrowsePrivately/
    XRayLarry Level 1 Level 1 (10 points)

    On the other hand, these institutions don't seem to need /BrowsePrivately/ in their itmss: string - iTunes correctly displays their login pages:

     

    (found via Google search on "BrowsePrivately")

     

    https://deimos.apple.com/WebObjects/Core.woa/BrowsePrivately/indiana.edu.2945205 213

    itmss://deimos.apple.com/WebObjects/Core.woa/Browse/indiana.edu.2945205213?ignor e.mscache=2845041

     

    https://deimos.apple.com/WebObjects/Core.woa/BrowsePrivately/adc.apple.com.14799 53497

    itmss://deimos.apple.com/WebObjects/Core.woa/Browse/adc.apple.com.1479953497?ign ore.mscache=8604460

     

    So - is it something wrong in the metadata that Apple has for our private site?

  • 2. Re: /Browse/ versus /BrowsePrivately/
    richwolf Level 3 Level 3 (725 points)

    Larry,

     

    I think Duncan's got this about right.  I suspect the problem is that you may have granted the "All" and "Authenticated/Unauthenticated" credentials no access (i.e. "NONE") -and- there are no other permissions set for the iTunes U course/album involved.  I haven't tested it (but I will), but I'm almost positive what happens in such cases is that iTunes U redirects to the root page of your site as apposed to putting up a 403-style error. You are not redirected to your portal server because no purpose would be served by doing so -- there would be no credential(s) it could assign that would grant you access to the iTunes U resource.

     

    Can you do me/us a favor and post a picture of the permissions settings for the problem course if at all possible?

  • 3. Re: /Browse/ versus /BrowsePrivately/
    XRayLarry Level 1 Level 1 (10 points)

    In replying to your comment, I tried the direct link again. It now works.

    https://deimos.apple.com/WebObjects/Core.woa/BrowsePrivately/deanza.edu.20336305 98

     

    I have tried at least one other old direct link, and it now works as well. Huh.

     

    BUT - now whenI am logged into the private site as an admin, I can't do "Copy link". The option is grayed out.

     

    I will go home now, and tomorrow I will do more testing with the old links.

     

    Were there any changes made on Apple's side to our private iTunes U store over the last week or two? Absolutely no settings were changed on my end.

  • 4. Re: /Browse/ versus /BrowsePrivately/
    richwolf Level 3 Level 3 (725 points)

    The link you posted behaves the same way as the others for me (i.e., it redirects to your root page). It may be that you had an iTunes U session active already and it worked for you just now for that very reason. To test things "beyond a shadow of a doubt" you should log out of iTunes U first, then try the link. In fact, if I am right (and that the reason it worked was because you had an iTunes U session active when you clicked the link), then that's very very strong evidence that you have a permissions problem for the course/ablum involved. If this is the case, the most helpful diagnostic tool would be to see what permissions you've assigned for the course.

  • 5. Re: /Browse/ versus /BrowsePrivately/
    XRayLarry Level 1 Level 1 (10 points)

    I've repeatedly tried it after logging out of iTunes U and completely closing the iTunes application - I was able to use that direct link.

     

    Now I'm at home, and the direct link doesn't work again. I was able to replicate the case you're talking about, but you've warned me about that situation before, and I've been careful to test by logging completely out and turning off iTunes.

     

    I still can't do "Copy Link", if that means anything.

     

    Anyway, here's the access permissions for the test case

     

    access-settings.jpg

  • 6. Re: /Browse/ versus /BrowsePrivately/
    richwolf Level 3 Level 3 (725 points)

    Larry,

     

    Hmm…that looks okay to me. I confes I didn't look at it really closely tonight, but it looks okay just glancing over it. I'd like to explore it more deeply if you don't mind, but I can't tomorrow. Can this hold until Thursday?

  • 7. Re: /Browse/ versus /BrowsePrivately/
    XRayLarry Level 1 Level 1 (10 points)

    Thursday is OK. I am going to a workshop for most of today.

    I deeply appreciate the recent attention you've given to this issue.

  • 8. Re: /Browse/ versus /BrowsePrivately/
    XRayLarry Level 1 Level 1 (10 points)

    It is now two weeks since the last message in this discussion. I was hoping that this week's iTunes U system maintenance would solve the problems with our private iTunes U store, but all the access problems remain, unchanged.

  • 9. Re: /Browse/ versus /BrowsePrivately/
    XRayLarry Level 1 Level 1 (10 points)

    It's been over three weeks since I last heard from anyone about this issue.

     

    We've been trying to sell faculty and staff on the benefits of using iTunes U. The amount of time it is taking to address this problem is embarrassing.

  • 10. Re: /Browse/ versus /BrowsePrivately/
    AcadTech Level 1 Level 1 (0 points)

    We're seeing the same issue. Using current iTunes software. The previous version still allows to "copy link" from a tab. It sure would be good to have a resolution.

  • 11. Re: /Browse/ versus /BrowsePrivately/
    Duncan Bernhardt Level 3 Level 3 (870 points)

    Larry-

     

    When linking to private courses/collections you should indeed use the "BrowsePrivately" url

     

    BUT - now whenI am logged into the private site as an admin, I can't do "Copy link". The option is grayed out.

     

    The work-around is drag copying the URL from the iTunes client

    DrapCopy.png

    -Thanks

  • 12. Re: /Browse/ versus /BrowsePrivately/
    XRayLarry Level 1 Level 1 (10 points)

    This technique may work for you, but it does not work for me when logged into our iTunes U store with my Apple ID. Dragging selects nothing, and therefore I can't copy anything.

     

    I just checked and my Apple ID is the one listed in Site Settings as the Primary Administrator.

  • 13. Re: /Browse/ versus /BrowsePrivately/
    XRayLarry Level 1 Level 1 (10 points)

    Hey, direct links work now! I've been busy getting ready for the Fall quarter and haven't had a chance to test direct links until today, so I have no idea when Apple fixed the problem.

     

    Can anyone at Apple clue us in on what was fixed to return the direct linking functionality to our site?

     

    OTOH - I still can't "Copy Link" . I can probably get the id from a report, but that would take a lot more time compared to just right-clicking/control-clicking and "Copy Link".

  • 14. Re: /Browse/ versus /BrowsePrivately/
    Duncan Bernhardt Level 3 Level 3 (870 points)

    A click/drag of the title from the breadcrumb should allow you to grab the URL regardless of if you are logged in by Apple ID or not. Let us know if this is not the case for you and grab a screen shot if possible.

     

    -Thanks

1 2 Previous Next