Skip navigation

Upgrade to Lion Broke Superdrive

17482 Views 46 Replies Latest reply: Feb 23, 2014 8:54 PM by Bulldoggie RSS
1 2 3 4 Previous Next
cjwallac Calculating status...
Currently Being Moderated
Jul 22, 2011 7:25 AM

Community,

 

I have upgraded from Snow Leapord to Lion on my MacBook Pro, but once I finished the upgrade I went to burn in Toast, iTunes and Wave Burner they all indicate my SuperDrive is busy. I also get the same indication from Disk Utility... Any thoughts on this or has anyone else ran into this issue!?

 

Take Care,

Chris

MacBook Pro, Mac OS X (10.7)
  • HogDogMike Calculating status...
    Currently Being Moderated
    Aug 7, 2011 9:51 AM (in response to cjwallac)

    Also looking for solution - my MBPro just spits CD's/DVD's back out after at 10 seconds.  Post Lion... no issues before Lion.

     

    Tx.  HDMike

  • HogDogMike Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 10, 2011 5:49 PM (in response to HogDogMike)

    Called Apple Care last night, went through the eprom reset - made appointment for Apple Store, Went by store, they are replacing under warranty.  Lion upgrade was coincidental.

  • luigi.viggiano Calculating status...
    Currently Being Moderated
    Aug 22, 2011 5:37 AM (in response to HogDogMike)

    Not sure that it is coincidential. I have problem with superdrive after updating to lion. If you search on google "superdrive lion" you find a lot of people having problems. I think it is some hardware issue related to some old superdrive, of course if you go to a shop they tell you that is an hardware problem and replace it, since they can't tell you to wait for weeks or months, until apple fixes the OS and your computer works again.

  • foureyeshumanlike Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 6, 2011 7:41 AM (in response to cjwallac)

    Greetings!

     

    I noticed that my two MacBook Pros don't read any discs properly after updating Snow Leopard -> Lion. They mount the disc image to the desktop but I am not able to open the folders or files in them. I can not even copy them to another media, because the process is interrrupted by an error message.

     

    The older Pro is mid -09 and the other mid -10, neither one had any problems with their drives before Lion and both met the criteria for update.

     

     

    I have to say that this is just unimaginable. There are a few other bugs still in Lion, but this is the worst.

    Wait for a fix or downgrade to Snow Leopard, that's the question to ask..?

  • HogDogMike Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 6, 2011 7:34 AM (in response to foureyeshumanlike)

    It appears what I thought was cooincidence might really be just an early opinion.  I haven't made it back to the Apple store for the replacement yet, was kind of hoping an update would appear to fix the issue.  I really don't want to downgrade as I love some of the new features. 

  • baltwo Level 9 Level 9 (59,150 points)
    Currently Being Moderated
    Sep 6, 2011 9:13 AM (in response to cjwallac)

    Zap the PRAM and Reset the SMC, then try again.

    27" i7 iMac 10.6 , Mac OS X (10.7.1), G4 450 MP 1.5 GB RAM w/(10.5.8/10.4.11/9.2.2)
  • jivid321 Calculating status...
    Currently Being Moderated
    Sep 8, 2011 9:59 PM (in response to cjwallac)

    To fix this problem,

    1. Open Terminal.

    2. Copy and paste this code:

    sudo rm /private/var/db/mds/system/mds.install.lock

    3. Reboot computer. (If hangs reboot again)

    4. Fixed! Enjoy!

     

    Its an easy fix that Apple should include in their next update

  • luigi.viggiano Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 9, 2011 9:41 PM (in response to jivid321)

    Hi jivid.

     

    Thanks for posting this. Can you please explain what the mds.install.lock file is, and why removing this file helps?

     

    I googled around and it seems that this file causes some problems sometime. But I'd like to know how this file is related to the superdrive problem and know more about this issue.

     

    Thank you!

    Luigi.

  • HogDogMike Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 10, 2011 5:04 AM (in response to jivid321)

    No luck for me -- I had already tried baltwo's suggestion:   Zap the PRAM and Reset the SMC, then try again.  Followed jivid321 recommendation re:  mds.install.lock -- still broke.  


    Mac OS X (10.6.3)
  • luigi.viggiano Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 11, 2011 9:33 AM (in response to jivid321)

    Hi jivid321.

     

    I tried to delete the file you indicated, but it didn't fix the problem for me.

     

    very disappointed by Apple.

     

    http://en.newinstance.it/2011/08/25/superdrive-not-working-anymore/

  • eserpa Calculating status...
    Currently Being Moderated
    Sep 12, 2011 3:08 PM (in response to cjwallac)

    Im having the same problem, my macbook is the 3,1 model, from late 2007. My superdrive was working perfectly with snow leopard but after the update it stoped working. I tried everything, fixing the disk permitions, reinstaling lion, apple should resolve this! it is a major problem for most of the people that work with dvd projects and in the music production industry.

     

    If I found anything that works I will post it right away.

     

    Feels good that Im not the only one with this issue.

  • rjrich2010a Calculating status...
    Currently Being Moderated
    Sep 15, 2011 9:41 AM (in response to cjwallac)

    I am having a similar problem. After upgrading my two mac mini computers (mid 2010), the superdrive on each machine stopped accepting discs. It feels as if there is a physical obstruction. I can force the disc to be accepted by applying a lot of force, but something is clearly wrong. I called AppleCare and they said to bring the machines to the Apple Store for diagnostics and repair. They said it is a hardware problem not a software or firmware problem. However, this seems too coincidental. I am hoping to find a solution other than taking the machines to the shop, as I need operational machines for my work. Thanks.

  • moon79 Calculating status...
    Currently Being Moderated
    Oct 1, 2011 11:20 AM (in response to rjrich2010a)

    yes, I am having exactly the same problem.There is no cd in the superdrive of course but it seems there is one so it does not allow me to insert one.I do not want to put force.I do not think it's software problem but hardware and the thing is how do we run hardware test now?

  • rjrich2010a Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 3, 2011 12:33 PM (in response to cjwallac)

    Today, the SuperDrives on both my Mac minis (mid 2010 vintage) started working again. The clue to this was that upon rebooting the machines, the start-up disk drive sound (zzz, zzz) was back. This sound, in addition to the Apple start-up chime, was present when the machines were new and when the SuperDrives worked. Then, when the drives stopped working, the minis would no longer make the disk drive sound on startup. Now this sound is back, and so are the SuperDrives. I have no idea why they stropped working or why they started again. However, in the interim, I was able to run the Apple Hardware Test (using a remote disk drive) and both machines passed the test. It seems strange that two machines in two different locations would experience the same failure and then the same recovery from this failure, but I am glad that the machines are working again without a trip to the Apple Store.

1 2 3 4 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.