Skip navigation

Stuck DVD, drive not turning

532 Views 4 Replies Latest reply: Sep 13, 2011 2:20 PM by Ted Stampfer RSS
Ted Stampfer Calculating status...
Currently Being Moderated
Sep 5, 2011 2:55 PM


Is there a foolproof method of ejecting a DVD from a G4 Powerbook running OS 10.4.11? A Garmin topo map DVD became stuck when trying to load the information into the GPS. The DVD appears in my laptop as a volume along with the computer and external HDs. When I try the eject button the arrow shows for a second and disappears. When I try ejecting directly at the icon the following message appears; "The disk "GARMIN" is in use and could not be ejected. Try quitting applications and try again." Unfortunately, the only way I have found to quit Garmin is to disconnect the GPS, truly a "catch 22". I have tried a number of other ways found on recent and older help queries including using terminal command /usr/bin/drutil eject in both verbose and single user modes.

In case it is diagnostic, I think the DVD is not turning; I think what I hear is the HD, not the DVD drive.

I think the basic trouble is that the computer thinks I have a volume instead of a DVD. Is there no mechanical way to forcibly eject it as with earlier Macs?

Thank you

Ted


<div class="mcePaste" id="_mcePaste" style="position: absolute; left: -10000px; top: 0px; width: 1px; height: 1px; overflow-x: hidden; overflow-y: hidden;" mcestyle="position: absolute; left: -10000px; top: 0px; width: 1px; height: 1px; overflow-x: hidden; overflow-y: hidden;"></div>

1.5 GHz G4 Powerbook, Mac OS X (10.4.11)
  • old comm guy Level 4 Level 4 (2,230 points)
    Currently Being Moderated
    Sep 5, 2011 3:25 PM (in response to Ted Stampfer)

    OK, first, make sure nothing is connected to the computer other than the power adapter, reboot the computer.  Does the disc show up as a mounted volume?  If so, then you should be able to eject it using the eject key or by dragging its icon to the trash.  If you get the same error message, then you have a Garmin process running, which you should be able to kill either with "Force Quit" or by bringing up Activity Monitor in Utilities, finding the process or application there and quitting it.

     

    Are you saying that the disc shows up on the desktop with a "HD Volume" icon like this:

     

    Picture 1.png?

     

    Or is it the usual DVD volume icon like this:

     

    Picture 2.png?

     

     

    TiBook G4 1GHz/ G5 2 GHz DP GF Ultra 6800, Mac OS X (10.4.11)
  • old comm guy Level 4 Level 4 (2,230 points)
    Currently Being Moderated
    Sep 5, 2011 10:34 PM (in response to Ted Stampfer)

    Ted Stampfer wrote:

     

    I think the drive may be dead; Is there a way of checking this? Might doing a clean install of OS 5 solve the problems?

     

     

    OK, if we get right down to the lowest level we can, you can boot into Open Firmware by holding down the cmd-option-O-F key combination at power up until you get to the white screen.  In open firmware, the OS is completely out of the picture; you are using essentially the firmware that gets things started before the OS starts loading.  While there, type the following command:

     

    eject cd  <return>

     

    which should cause the CD to be ejected if the optical is responding at all.  If that works, then you need to hold onto the Garmin disc for a moment and enter the following command  (actually, in either case, do the command):

     

    mac-boot   <enter>

     

    which will start the OS booting process.

     

    Now, if the disc did not come out, you should shut down the computer.  You should be able to use a credit card to trip the release lever on the drive by inserting a corner of the card about 1/8 inch roughly one inch from the right end of the slot and using the end of the card to press down gently.  Typically, this lever looks like the illustration below, right at the yellow arrow.

     

    DiscReleaseOptical.jpg

     

    It may be a little tricky, be ginger, but the disc should pop out.  Otherwise, the only other way is to remove the drive from the PowerBook and trip it that way.

    TiBook G4 1GHz/ G5 2 GHz DP GF Ultra 6800, Mac OS X (10.4.11)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.