Skip navigation

How to VPN windows 7 to osx lion server

31221 Views 22 Replies Latest reply: Dec 23, 2012 8:51 AM by SnakeDog RSS
1 2 Previous Next
beejster Calculating status...
Currently Being Moderated
Aug 18, 2011 12:12 AM

I have been strugling the last couple days on this issue!


I have established a MAC OSX VPN connection to OSX Lion Server without any problems but also need to connect Windows 7 machines also.


The Settings on the server side are correct (hence the MAC connection) but still cant get the Windows 7 machine to make the connection!


Any help will be apreciated!

Toshiba Laptop, Windows 7
  • Roger W Maki Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 28, 2011 6:34 PM (in response to beejster)

    I have my vpn up and working

    connecting with my mac equipment works great

    Have been trying to get a windows machine to connect

    I am unclear as to how to edit the registry

    when I am in the registry at the location noted above, where do I entry the new line

    Iam not a regular windows user and want to make sure i enter it properly

    I Have edited the secpol.msc file

  • CajunTech Calculating status...
    Currently Being Moderated
    Sep 5, 2011 5:52 PM (in response to beejster)

    Great info with details.

    Do you know if the same steps would work with Vista or XP?

    Also, is there a VPN client that could be used to avoid all of the Microsoft workarounds?

  • beetlejelly Calculating status...
    Currently Being Moderated
    Sep 7, 2011 1:16 PM (in response to beejster)

    This is great, thanks!

    I notice that once connected, all internet traffic now go through the vpn server. This is a problem because the vpn server lives on a slow network. Is there a work around for this?

  • beetlejelly Level 1 Level 1 (5 points)
    Currently Being Moderated
    Sep 7, 2011 2:45 PM (in response to beetlejelly)

    I'm wondering if anyone has figured out how to implement this fix for windows 7 home edition (doesn't have secpol.msc).


    I was able to add,




    and I even changed a registry setting that I believe corresponds to "Send LM & NTLM - use NTLMv2 session security if negotiated"

    "[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\]"lmcompatibilitylevel "=dword:00000001"


    I am unable however to find where I can change the "Require 128-bit encryption" settings in the registry.


    Any help would be greatly appriciated.


  • heatsea Calculating status...
    Currently Being Moderated
    Sep 12, 2011 5:19 AM (in response to beetlejelly)



    with your home edition, change registry below.







  • CajunTech Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 12, 2011 11:03 AM (in response to beejster)

    These steps worked great for establishing a Win 7 to Lion Server VPN.  But, once a drive is mapped and I try to access any Office files (Word, Excel, etc.) I get an error that the file is locked for editing by 'another user'. 


    I can download a copy, edit, the push it back up.  But I don't get the locked error from my mac clients.


    Any ideas?  workarounds?

  • CajunTech Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 14, 2011 5:00 PM (in response to heatsea)

    Thanks for the home machine settings.  But my win 7 home premium didn't respond successfully to your last regedit changes.  It still won't connect to Lion VPN.  Any other regedit ideas?

  • CajunTech Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 14, 2011 7:50 PM (in response to beejster)

    I totally agree about MS.  Their limited OS's may save money for the customers but end up frustrating them in the end.  I like the apple approach better of course, flat rate and all the features.  Thanks for your help!!

  • the.right.idea Calculating status...
    Currently Being Moderated
    Sep 29, 2011 4:47 AM (in response to beejster)

    Don't work by me. I did all things in the tutorial - but I get this message:

    "Fehler 789: Der L2TP-Verbindungsversuch ist fehlgeschlagen, da ein Verarbeitungsfehler während der ersten Sicherheitsaushandlung mit dem Remotecomputer aufgetreten ist."


    Error 789: The L2TP connection attempt failed because a processing error occurred during the initial security negotiation with the remote computer.

  • Pierre Froelicher1 Level 1 Level 1 (85 points)
    Currently Being Moderated
    Nov 21, 2011 5:09 PM (in response to beejster)

    i have also tried for two day to connect win7 home  pcs to lioserver with no success.

    i have however not yet accepted that i have to fumble aroud with some win registry..heck i do not even know HOW to edit these settings.

    anyway in my opinion this should work out of the we not all miss something?

    perhaps with win7 pptp would be the easier protocol.

    doesanyone see an easier way?


1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (6)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.