Skip navigation

10.7.1 Login Loop

1600 Views 6 Replies Latest reply: Sep 22, 2011 8:43 PM by cormacfrelf RSS
cormacfrelf Level 1 Level 1 (0 points)
Currently Being Moderated
Sep 22, 2011 7:29 PM

I've restored my MacBook2,1 (White) from Late 2007 from Time Machine, and my system got back to 1 hour before changing my short name. It was fine, worked perfectly. I've now upgraded to 10.7.1, and there have been issues since then.


It started with hangs on startup. Chime ->  ->  + Spinner. Fans rev to maximum, base heats up, I let it go for 3 minutes and give up, power button for 5 seconds and try again. This results in a normal startup. Happened once every time I wanted to start up.


Now it's much worse.


This issue persists; however, now I can't log in any more. The login screen appears 2nd time round, and I type in my password -> login screen disappears, mouse cursor stays with gray screen for a second or two -> login screen reappears as if I hadn't touched it in the first place.


I've worked on this for a couple of hours, running Disk Utility's Repair Permissions, Repair Disk. The only permissions needing repair have been on Apple's to-be-safely-ignored list, bar a few which were to do with device management.


Thanks to @Kappy's advice, I have cleared the preferences for loginwindow and windowserver, and various caches. However the mentioned "Extensions.kextcache" was not actually there to rm.


I've run resetpassword and done that for my account, which seemed to go through, but when I did that for the root user, it exclaimed "Password not saved". I was enabling root to follow this advice, and the "Other User" section at the login screen popped up, but I was unable to log in with root / *password*, and so I couldn't do anything beyond that.


Everything I need has been backed up, through Time Machine and through Dropbox. There seems, however, to be something deeply wrong with my system that's pervaded each installation — should I try the old "Archive and Install" to start fresh, and just copy the files I need? That would be a lot of work, since I'd have to not only restore all my files, but my entire development environment, including Xcode, everything I have through homebrew and RubyGems, and of course all my settings... but I'm willing to do that if it's the only way to make my Mac cease to be a brick.


Thanks in advance for reading this wall of text and for your consideration of my problem.

MacBook, Mac OS X (10.7.1), Bricked my computer
  • Linc Davis Level 10 Level 10 (107,800 points)
    Currently Being Moderated
    Sep 22, 2011 7:56 PM (in response to cormacfrelf)

    Boot in safe mode. Same problems?


    Mac OS X: Starting up in Safe Mode

  • Linc Davis Level 10 Level 10 (107,800 points)
    Currently Being Moderated
    Sep 22, 2011 8:15 PM (in response to cormacfrelf)

    Have you booted from your recovery partition and reinstalled Lion?

  • Linc Davis Level 10 Level 10 (107,800 points)
    Currently Being Moderated
    Sep 22, 2011 8:37 PM (in response to cormacfrelf)

    Back up with TM, boot from the recovery partition, erase the main boot volume, reinstall Lion, then restore your data from TM in Setup Assistant. If that doesn't work, you have to consider a hardware fault.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.