Skip navigation

Pages produces PDFs that don't display consistently

1106 Views 30 Replies Latest reply: Oct 6, 2011 11:07 AM by Whitecity RSS
  • Rasuul Level 1 Level 1 (0 points)

    Hi Whitecity -

     

    Sorry for the delay: I'm on the road at the moment & have a bit of a statelite office going at the moment: not always able to make it online.

     

    I couldn't find your email in your profile. If you've setup the DB account by now, you can send me the file & I'll have a look.

     

    Sincere apologies for the delay.

     

    Rax

  • PeterBreis0807 Level 7 Level 7 (27,270 points)
    Currently Being Moderated
    Sep 21, 2011 11:02 AM (in response to Whitecity)

    Printed your file to pdf and pdf-x:

     

    Opens fine in Preview.

     

    Opens fine in Acrobat X on Mac.

     

    Looks fine when dragged into TextEdit.

     

    In Illustrator CS5 the mask appears to be inverted. The framed area is knocked out of the map as a compound shape. It indicates that there are 2 levels of Clipping masks on the knocked out frame and the Alpha mask itself, but I am unable to actually get it to show the clipping path itself. It is always just the bitmap image outside the frame with inside the frame showing as transparent.

     

    As usual there is an extra white postscript object behind the objects.

     

    In Photoshop CS5 I see the high res map with the low res frame mask. If I let it open combined, it chooses the color space of the grey scale mask and the map is opened as greyscale.

     

    In Indesign CS5 it displays correctly when placed.

     

    Peter

  • PeterBreis0807 Level 7 Level 7 (27,270 points)

    There has always been a problem with pdfs in Acrobat for Windows, which is probably what you are reporting.

     

    There also have been problems with embedded fonts, which explains why PC users are less enthusiastic about .pdfs than Mac users.

     

    When you hit these problems all you can do is test variations of possible output. You may be attributing the problem to Pages but Pages uses the OSX core graphics to create its pdfs and I suspect that this applies to all OSX pdfs.

     

    So try a range of applications clearly labelling each test in both the file name and in the file itself.

     

    Try installing Adobe Acrobat and then "Adobe PDF" should appear as a printer option in OS X that you can use to create the PDF.

    See if you can isolate the PC users who are having the problem and what is different in their apps or set-up. Unfortunately PC users have some of the worst set-ups possible and it is often dificult to get them to fix them or even think about what could be going wrong. It usually is all too hard and they only want to avoid the issue, blaming Apple usually does the trick, although to be fair, sometimes it is Apple's fault.

     

    Peter

  • Barry Level 7 Level 7 (29,095 points)

    The posted shot of a menu doesn't look like any menu I've seen in Pages '09. Are you perhaps using Pages for iOS?

     

    If so, your question may get a more helpful response in the iWork for iOS community. The link will take you there.

     

    Regards,

    Barry

  • PeterBreis0807 Level 7 Level 7 (27,270 points)

    Ah we are getting closer to your real problem.

     

    OSX uses a ColorSync filter to produce pdfs.

     

    Like all DTP processes the complex interaction of vector objects, bitmaps and transparency is handled by rendering all the interacting (overlapping) objects as bitmaps, with the exception of flat colored vector objects on top.

     

    The default rendering resolution has been set by Apple to 72dpi, which is too coarse for anything except screen rendering. This is a major problem for everything else.

     

    Apple has had ample, detailed feedback on this over a very long time, and judging by their non response to all of the feedback, it would seem they prefer that their customers discover the problem, at their own considerable expense, at the commercial printer of their choice.

     

    This is to rid their customers of the delusion that OSX is meant for anybody but amateurs blissfully unaware of what is going on, and thus naïvely susceptible to whatever marketing ploy Apple may be exercising at the time of purchase of Apple's "solutions".

     

    Peter

  • PeterBreis0807 Level 7 Level 7 (27,270 points)

    I can't make it work for you when it won't.

     

    There are problems on both OSX and on Windows.

     

    I showed you in the tests that I did, even the different Adobe CS5 applications don't read pdfs the same way.

     

    There are better ways of distilling the pdfs on OSX using filters from Abracadabra in France, but whether that will fix the inconsistencies in rendering and viewing I don't know. I don't have access to your PC contacts or their computers.

     

    Like many issues similar to this, some operations work within their set environment and not outside. On Windows the failure to embed fonts correctly is often not noticed because the missing fonts are fonts installed by default on most PCs. Similarly faults in colorspaces are not noticed because of the poor quality of most PC displays and nearly all of them using the same low end sRGB space.

     

    If you have ever run pre-press you would know what a tottering tower of cards this whole area can be.

     

    I did not suggest to you to test every single job going out. I suggested to you that you test the variables on your Mac and the results/variables on the target PCs to pin down what the differences/causes are. There are limits to what can be achieved by mere discussion in a forum, with not much to go on.

     

    Peter

  • PeterBreis0807 Level 7 Level 7 (27,270 points)
    Currently Being Moderated
    Sep 26, 2011 12:41 PM (in response to Whitecity)

    I've worked in pre-press.

     

    We used to sacrifice a virgin and throw salt over our shoulders before we sent a large job off to plate.

     

    Believe me, when odd things happen you just have to sit down and grind the problem down variable by variable.

     

    Try as many different ways as you can using alternative work flows and both label the file name and in the document as well so you can see what caused what.

     

    My gut feeling here is that Apple has done something cunning with the masking and it is just not reading conventially.

     

    peter

  • Rasuul Level 1 Level 1 (0 points)

    @Whitecity

     

    I faded to the background on this one because Peter's knowledge /drowns/ mine. But, seeing as it sounds as though you haven't sorted the issue, I was curious to know if you tried the PDF > JPEG > PDF workaround I suggested?

     

    I had a look at the document you posted, but I don't have access to a PC, so can't verify the issues you're having or try to find a work around. However, I have found that playing format-"catch" can often sort such issues: I would try taking the functional PDF you have, exporting as a JPEG - see if the JPEG renders correctly for your PC friends (I suspect it would), then try exporting the JPEG as PDF, rinse & repeat.

     

    I don't have the technical knowledge others on this thread do, but I've had success working around issues like this, in a pinch. It seems to me that the information content of one format gets 'compressed' or 'reduced' into (what I think of as) 1 dimension: the net information is how the object appears, not the various processes used to create it.

     

    I could be completely wrong, but if it worked, it would be a realtively simple solution, easily automated.

     

    Sorry I can't be of more help: so far I've only sorted out my own issues on this forum & had hoped I might be able to repay the kindness by helping another.

     

    Best of luck!

     

    Rax

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.