10 Replies Latest reply: Feb 16, 2013 5:27 AM by gmarinov
gmarinov Level 1 Level 1 (30 points)

hi guys

 

I need some expert help on this. Using a Dell E178 WFP external display on my 2010 Macbook Pro via mini-DVI-to-VGA adapter. This display has no EDID it seems so I use SwitchResX to create the necessary resolution override (1440x900). SwitchResX has nothing such as daemons or helpers installed on top, so this boils down to graphics drivers.

 

My problem: When I reboot the machine, the display has the necessary brightness, contrast, and colour balance. If I unplug the display, wait a sec, then plug it back in, the image comes up very bright and washed out, and I can't get a "true" black out of the display.

 

What this isn't: I have a ColorSync profile, and make sure it is successfullly loaded, i.e. I go through the trouble of opening up system preferences>displays>color to make sure it reloads. This is not a ColorSync problem. It is not the 2.2 vs 1.8 gamma problem either. Ctrl+shift+eject does not fix it. Creating a new colour profile does not fix it either. The usual SMC, permissions, safe boot, etc tricks don't work either.

 

Apple engineers have sent me a copy of TimingSnoop but were baffled by the display having a "fake" EDID (when run without SwitchResX TS detects no EDID at all). Since I refused to roll back my entire system to 10.6.4 or uninstall SwitchResX (it does not interfere??) they closed the bug stating "insufficient information".

 

10.6.4 did not have this problem, and my hardware is perfectly fine.

Rolling back the graphics to 10.6.4 fixes this issue (but creates other issues)

 

I'm looking for information on this. Has anyone had the same happen? Is it confined to sans-EDID displays?

Have googled a lot but I'm running out of search terms... Anything could be of help?

 

Thanks in advance.


macbook pro intel, Mac OS X (10.6.8), i5, 8gb ram, hr ag
  • 1. Re: disconnect+reconnect external display = washed out image
    X423424X Level 6 Level 6 (14,190 points)

    What happens if you click Detect Displays in the displays preferences?

  • 2. Re: disconnect+reconnect external display = washed out image
    gmarinov Level 1 Level 1 (30 points)

    absolutely nothing.

  • 3. Re: disconnect+reconnect external display = washed out image
    gmarinov Level 1 Level 1 (30 points)

    *bump* :/

  • 4. Re: disconnect+reconnect external display = washed out image
    chillmaster_D Level 1 Level 1 (0 points)

    got the exact same thing, i have to reboot each time to get normal colors again, really annoying

  • 5. Re: disconnect+reconnect external display = washed out image
    gmarinov Level 1 Level 1 (30 points)

    hi chilldmaster_D . are you using the same display? What OS and model do you have?

    Have you tried TimingSnoop? I'm wondering if it has anything to do with the missing EDID data or is it some sort of hardware reset on the nvidia chip (more likely :/ ) that's required to get it back to normal?

     

    Have been looking on the net for ages in hope to at least find someone with the same problem.... At least this is some news.

  • 6. Re: disconnect+reconnect external display = washed out image
    chillmaster_D Level 1 Level 1 (0 points)

    Hello,

    I have a 2010 macbook pro 15" 2,4ghz i5, 4gb, with 330m 256mb nvidia gpu, running on 10.6.8 snow leopard

    I have found that a lot of people are experiencing the same problem. I am using a different display, a Samsung t240 24" with 1920x1200 resolution.

    I do not know if has something to do with EDID as that goes beyond my expertise, neither have i tried timingsnoop. it does seem likely that the nvidia chip resets.
    Alot of people say the fix is to simply go to the colors tab at the system preferences > display. But for me that does nothing, neither does Detect Display.

     

    The problem happens like this: i open my macbook from sleep mode, it awakes, i connect my external screen and then the colors on my external screen are desaturated/ washed out, the blacks are not as black etc.

    I leave it plugged in and reboot, problem "solved", the colors on my external screen are natural and saturated. If i plug out my external screen and plug it back in at this point, the colors are back to being desaturated/washed out.

  • 7. Re: disconnect+reconnect external display = washed out image
    gmarinov Level 1 Level 1 (30 points)

    Again, this is not the gamma problem that's fixed by just opening the display preferences and resetting the colour profile.

     

    This seems to be somehow related to the display's EDID and the video adapter (Nvidia) not resetting properly when first unplugged and then plugged back in. My support request with Apple is more than a year old in total now and replies have been trickling but all of them add little (if anything at all) to a fix.

     

    My particular problem is finding these "a lot of" people who are experiencing this problem. Everyone I've seen so far talks about the gamma/colours problem, never about the brightness and reboot. So yours is the first instance of someone having exactly the same problem. Hopefully we can find more people? Do you know where I should be looking?

     

    Another idea I've had is to possibly talk to the OSX86 community? If Apple are not interesting in issuing a fix for this, maybe someone else has done some work? After reviewing Apple's code (at least that part which is made public) I'm pretty convinced this is in Nvidia's territory, and that gives me very little hope..

     

    I'm interested to know if this has been fixed on Lion at all..? Ideas?

  • 8. Re: disconnect+reconnect external display = washed out image
    Darkken Level 1 Level 1 (0 points)

    I am having this same issue with my macbook pro 2010 i5 2.4 330m nvidia as well. I have tested the same exact cabling and display device with my iMac 2009 core 2 duo 3.06 radeon 4850 and my iMac's color looks perfectly fine. It is quite frustrating trying to find the cause even though it is a very specific use case that produces it.

  • 9. Re: disconnect+reconnect external display = washed out image
    gmarinov Level 1 Level 1 (30 points)

    still very interested to know if Mac OS X Lion (10.7) fixes this or not. All the research I could do points to Nvidia's graphics card not being managed optimally by the driver, but that driver doesn't seem to have been updated since 10.6.5... Apple's software is updated around it but the changes (available with the public sources for Darwin) aren't significant and/or in that area..

  • 10. Re: disconnect+reconnect external display = washed out image
    gmarinov Level 1 Level 1 (30 points)

    for the sake of "closure", Apple never fixed this.

     

    I believe from their point of view it's an old, smallish, VGA display with a generic panel, no EDID to speak of, connected though an adapter, to an all digital port. Plus it's a Dell, not their best of friends. And the problem seems to be in NVidia's garden more than Apple's.

     

    Snow Leopard 10.6.4 broke this. Mountain Lion 10.8.2 still had it. I tried everything with Apple's bug reporting system. Then I gave up. I got a 2412M with a display port interface.It worked greatt right out of the box.

     

    Shame.