Skip navigation
This discussion is archived

iPhone 4 (4.3.3) won't connect to 4th Generation Time Capsule (7.5.2)

538 Views 5 Replies Latest reply: Nov 7, 2011 9:15 AM by RACON RSS
Nathan Hammond Calculating status...
Currently Being Moderated
Jul 6, 2011 1:34 PM

I've not been able to identify why my iPhone won't connect to my Time Capsule.

 

Setup

4th Generation Time Capsule running 7.5.2

iPhone 4 running 4.3.3

MacBook 5,1 (the only Unibody MacBook) running 10.6.7

 

Situation

Time Capsule is in the default state (just ran "Restore Default Settings..." from Airport Utility).

Mac OS X Network settings have just been restored (http://stevejamesson.com/?p=212).

iPhone 4 network settings have just been reset. (Just ran Settings > General > Reset > Reset Network Settings)

 

Testing Procedure

Connect Mac to the Time Capsule wirelessly (Apple Network ######).

iPhone connects to the Time Capsule wirelessly (Apple Network ######).

 

Result

OS X connected fine. It has Internet connectivity. (PHY Mode: 802.11n; Channel: 149 (5 Ghz))

iPhone connected the first time. It was assigned an IP via DHCP. This connection provided no Internet connectivity.

iPhone did not connect the second time and assigned itself an IP address.

iPhone did not connect the third time and threw up the "Unable to join the network." error.

iPhone will now only assign itself IP addresses.

 

Further Testing Procedure

Knowing it doesn't work in the default state I proceed through the Time Capsule configuration using the "Assist Me" interface on my Mac.

  1. "I want to create a new wireless network"
  2. Assign a network name, WPA2 password.
  3. Did not enable guest network.
  4. Connect using DHCP.
  5. Skip setting up Time Machine.
  6. Apply settings. (Update)
  7. Time Capsule restarts, I get the "Setup Complete" message.
  8. OS X automatically connected to the new network.

 

Result

OS X connected fine. It has Internet connectivity. (PHY Mode: 802.11n; Channel: 149 (5 Ghz))

iPhone "Unable to join the network "_____"" on the first three times.

Subsequent attempts result in it "joining" the network but receiving a self-assigned IP.

After forgetting the network, this cycle repeats itself.

 

Further Testing Procedure

Forget network on iPhone.

Changed the password in Airport Utility, again from the "Assist Me..." menus.

"Setup Complete" message appears.

 

Result

OS X still fine.

iPhone 4 joins the network fine, but receives a self-assigned IP address.

 

Conclusion

I'm all out of testing ideas. I've reset everything numerous times and it still won't connect. Anything else I'm missing? Ideas? Hints?

Time Capsule, 4th Generation, Firmware 7.5.2
  • RACON Calculating status...

    I had the same problem for ages, and after going slightly mad, I found a simple answer. In the TC I changed the Channel from 'AUTOMATIC' setting, and input channels 7 and 44 (selected randomly). Iphone 4 connected immediately, and everything works fine.

  • chuck abrams Level 1 Level 1 (0 points)

    That worked fo rme too, thanks for the tip. This has been very frustrating. Are there any drawbacks to not having the Airport Extreme on Automatic?

  • RACON Level 1 Level 1 (0 points)

    I've now had the system configured like this for 2 months, and absolutely no problems. I recently added another 2 Airport Express', and no problems again.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.