Skip navigation

OS X Lion - Can't login as root after disabling then reenabling

21289 Views 28 Replies Latest reply: Jul 21, 2012 9:48 AM by MindlessPotato RSS
1 2 Previous Next
Crazy Skull Guy Level 1 Level 1 (0 points)
Currently Being Moderated
Sep 1, 2011 7:11 AM



I'm having a problem logging into the root account of my macbook pro running Lion 10.7.1.  I enabled the root account and everything was fine.  I logged into it a few times and made some changes unrelated to passwords etc.  Once I was done I disabled the root account.  I then had to use it again and enabled it.  Now I can't login.  I tried resetting the password using the Directory Utility and terminal but neither work. Directory Utility appears to work but doesn't and no error message is given.  Terminal gives me the following error using the sudo passwd root command:



Changing password for root.

New password:

Retype new password:

passwd: Could not verify credentials because directory server does not support the requested authentication method.




Any help would be greatly appreciated.  I need to get this password reset and Apple support wasn't any help.  Thanks.

MacBook Pro, Mac OS X (10.7.1)
1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (6)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.