Skip navigation

Why is coreaudiod keeping my MBP awake?

4934 Views 14 Replies Latest reply: Mar 17, 2014 8:09 PM by csunsweet RSS
Jon Baumgartner Level 2 Level 2 (205 points)
Currently Being Moderated
Sep 27, 2011 6:24 AM

Idle sleep is not working on my MBP. I went so far as to install PleaseSleep, and that won't work. I finally decided to dig into this, and looked at the assertions log with pmset:

 

pmset -g assertionslog

 

Logging all assertion changes.

9/27/11 9:15:51 AM EDT 

Assertion status system-wide:

   ChargeInhibit                           0

   PreventUserIdleDisplaySleep             0

   PreventUserIdleSystemSleep              1

   NoRealPowerSources_debug                0

   CPUBoundAssertion                       0

   EnableIdleSleep                         1

   PreventSystemSleep                      0

   DisableInflow                           0

   DisableLowPowerBatteryWarnings          0

   ExternalMedia                           0

 

Listed by owning process:

  pid 210: [0x0000012c000000d2] PreventUserIdleSystemSleep named: "com.apple.audio.'AppleHDAEngineOutput:8,0,1,1:0'.noidlesleep"

 

Kernel Assertions: None

 

pid 210 is coreaudiod. I can't for the life of me figure out why core audio would be preventing the Mac from sleeping. Any thoughts? I don't have any USB devices connected.

 

Thanks.

MacBook Pro, Mac OS X (10.7.1), iPhone 4 16 GB
  • Marek Stepanek Level 2 Level 2 (290 points)
    Currently Being Moderated
    Sep 27, 2011 6:50 AM (in response to Jon Baumgartner)

    Please try by opening Preferences > Energy Saver > Restore Defaults, for both Battery and Power Adapter. I think PreventUserIdleSystemSleep should be set to 0.

     

    What is console saying, when closing the lid? I mean which error messages you get, when opening the lid again?

     

    Could you restart with SHIFT key to see whether the problem persists.

     

     

    marek

  • eww Level 9 Level 9 (52,975 points)
    Currently Being Moderated
    Sep 27, 2011 9:38 AM (in response to Jon Baumgartner)

    Someone else recently reported the same problem and the same solution. Evidently the Spotify people have some cleanup work to do on their software.

  • dennisaO Calculating status...
    Currently Being Moderated
    Jan 10, 2012 2:32 AM (in response to Jon Baumgartner)

    I had this problem for the past few days and its been killing me.  Come to find out, it was Safari using the Coreaudiod which was stopping my Mac from going to sleep.  I killed Safari and the issue is resolved. Go Figure!

  • Conflicttheory Calculating status...
    Currently Being Moderated
    Jan 16, 2012 4:03 PM (in response to Jon Baumgartner)

    I  too am having this problem, however, I do not use Spoofy or Safari. Here is my assertions log:

     

    localhost:~ conflicttheory$ pmset -g assertions

    12-01-13 19:01:59  EST 

    Assertion status system-wide:

       ChargeInhibit                           0

       PreventUserIdleDisplaySleep             0

       PreventUserIdleSystemSleep              1

       NoRealPowerSources_debug                0

       CPUBoundAssertion                       0

       EnableIdleSleep                         1

       PreventSystemSleep                      0

       DisableInflow                           0

       DisableLowPowerBatteryWarnings          0

       ExternalMedia                           0

     

    Listed by owning process:

      pid 655: [0x0000012c0000028f] PreventUserIdleSystemSleep named: "com.apple.audio.'AppleHDAEngineOutput:8,0,1,1:0'.noidlesleep"

     

    Any other suggestions as to why coreaudiod is keeping my MBP awake?

  • Maclovers Calculating status...
    Currently Being Moderated
    Jun 16, 2012 4:37 AM (in response to Conflicttheory)

    Hi,

     

    Same thing here. It was iTunes that was open. I just closed it and run again the terminal command and nothing is preventing the sleep now. Maybe related to SRS iWow. I have last version. Anoying that we can't leave iTunes open...

  • skeletorfw Calculating status...
    Currently Being Moderated
    Jul 6, 2012 6:33 PM (in response to Jon Baumgartner)

    Heya,

     

    Still getting this problem on my 2010 MBP 13" and have been approximately since Lion. PreventUserIdleSystemSleep is still set to 1 despite none of iTunes, Spotify of Safari being open.

     

    Anyone got other possibilities?

  • OoO_Bailey_OoO Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 9, 2012 12:17 PM (in response to Maclovers)

    I have SRS iWOW as well, but it wasn't keeping my MacBook awake, which is a nice surprise if you're familiar with this company's development history.

     

    My issue turned out to be Microsoft Remote Desktop Connection with Windows sounds playing on the Mac side. Setting it to play no sound resolved the issue.

  • jmandrewcarter Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 13, 2012 7:40 PM (in response to Jon Baumgartner)

    I had the same problem when GarageBand was left open.  It's easy to reproduce; open GarageBand and then type pmset -g assertions. PreventUserIdleSystemSleep will be set to '1'. Close GarageBand and it goes to '0' (assuming nothing else is holding it high on your laptop). I was keeping my laptop in a case and it was always hot when I opened the lid. I am worried this would have caused damage to the retina display in the long term.

     

    It's troubling that I have to close all of my applications now every time I close the lid. This is a pretty glaring flaw in supposedly the 'best' OS in the world. Putting it another way, my 2008 HP which cost $400 doesn't boil the display while I'm out at work.

  • MikeTheBike2010 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 6, 2013 11:27 AM (in response to jmandrewcarter)

    I seem to be having a similar problem - unresolved by restaring or resetting SMC and PRAM - in that my Macbook Pro runnng Snow Leopard will only sleep if I make it (clicking sleep or closing lid) and not from power saving settings.

     

    Assertions log states the following:-

    Macintosh-2:~ mikemckernan$ pmset -g assertions

    06/01/2013 19:12:00 GMT 

    Assertion status system-wide:

       PreventUserIdleDisplaySleep    0

       PreventSystemSleep             0

       PreventUserIdleSystemSleep     1

       ExternalMedia                  0

       UserIsActive                   0

       ApplePushServiceTask           0

       BackgroundTask                 1

     

     

    Listed by owning process:

      pid 161(iTunes): [0x00000001000001c8] 00:00:39 PreventUserIdleSystemSleep named: "Nameless (via IOPMAssertionCreate)"

      pid 42(mds): [0x0000000c0000012f] 00:01:11 BackgroundTask named: "com.apple.metadata.mds"

      pid 142(coreaudiod): [0x00000001000001c3] 00:00:44 NoIdleSleepAssertion named: "com.apple.audio.'AppleHDAEngineInput:1B,0,1,0:1'.noidlesleep"

      pid 225(helpd): [0x0000000c0000019d] 00:00:58 BackgroundTask named: "com.apple.helpd.sdmbuilding"

     

    Now by turning off itunes I can remove the first line but the others stubbornly remain.

     

    I am not running garage band but this prob became noticable after I had had a short play with the app?

     

    Whilst I can continue to sleep the machine manually this is very annoying.

     

    Any ideas on how I can solve the mysterious com.apple com.apple.audio and com.apple.helpd as I am very confused?

     

    Your help very much appreciated.

     

    Mike

  • skeletorfw Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 6, 2013 6:33 PM (in response to MikeTheBike2010)

    go to system preferences>sharing and turn off sharing for everything. That solved my issue

  • MikeTheBike2010 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 6, 2013 11:48 PM (in response to skeletorfw)

    Thank you for the response.

     

    In checking sharing I confirm I have no boxes ticked (they are all blank)

    If I click each one in turn they are all greyed out and confirm inactive except internet sharing which has a red dot but still confirms sharing is off.

     

    Just tried turning all on and off again but pmset -g assertions keeps coming back with prevent user idle system sleep1?

     

    Most frustrating?

  • csunsweet Calculating status...
    Currently Being Moderated
    Mar 17, 2014 8:09 PM (in response to Jon Baumgartner)

    For me it was an emulator and happens with either iOS and Android emulators.  Found this out by exiting all the apps one at a time and checking pmset -g assertions until there were no assetions left

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.