11 Replies Latest reply: Jul 29, 2013 12:05 PM by bornheimarne
lubnah Level 1 Level 1 (0 points)

In both my iPod Classic and the iPod application on my iPhone, the artists list is cluttered with collaborating artists (e.g., "M83, Big Black Delta & Daft Punk").  However, in iTunes 10.4.1, the artists list (when in grid view) is collapsed to album artists, when that field is defined.


I am trying to duplicate the behavior of iTunes from within my iPod, and am having no luck.


For clarity, here's an example list of albums:


- "Human After All", by "Daft Punk" - http://itunes.apple.com/us/album/human-after-all/id388195039

- "Tron: Legacy", by "Daft Punk" - http://itunes.apple.com/us/album/tron-legacy-original-motion/id406192538

- "Tron: Legacy Reconfigured", by "Daft Punk" (tracks are by numerous contributing artists) - http://itunes.apple.com/us/album/tron-legacy-reconfigured/id426251101


In iTunes, when in grid view sorted by artist, the entry "Daft Punk" contains all three of these albums.  However, in an iPod (both the device and iPod app) it's listed as follows:


- Daft Punk

- Daft Punk & Avicii

- Daft Punk & Boys Noize

- Daft Punk & Com Truise

- Daft Punk & Kaskade

- Daft Punk & Ki:Theory

- Daft Punk & Moby

- Daft Punk & Paul Oakenfold

- Daft Punk & Photek

- Daft Punk & Pretty Lights

- Daft Punk & Sander Kleinenberg

- Daft Punk & Teddybears

- Daft Punk & The Crystal Method

- Daft Punk & The Glitch Mob

- Daft Punk & The Japanese Popstars

… (much further down)

- M83, Big Black Delta & Daft Punk


The albums "Human After All" and "Tron: Legacy" are both listed under "Daft Punk", whereas the album "Tron: Legacy Reconfigured" is split up, as every single track is by a different collaboration of artists.


Let me preemptively state that, yes, I have marked "Tron: Legacy Reconfigured" as a compilation, and have tried using "Album Artist", "Grouping", "Sort Artist", and "Sort Album Artist".  Using those fields did fix the misplacement of the track by M83, Big Black Delta & Daft Punk, but it did not collapse the artist listing into just "Daft Punk", as I wanted.


Is there a solution to my problem here, short of changing the artist field for the collaboration tracks?


(sorry for the long post, I had trouble phrasing my problem clearly)

iPhone 4, iOS 4.3.3
  • 1. Re: artists list ignores album artist field
    lubnah Level 1 Level 1 (0 points)



    Anyone have any ideas?

  • 2. Re: artists list ignores album artist field
    tee mac Level 1 Level 1 (0 points)

    This is something that has annoyed me also. As with several things on the iPod and iTunes you have to change the information around to force it to do what you want. The way I fixed this was to change all of the Artist fields to the album artist and append the contributing artist onto the track Title field in brackets. I no longer use the Album Artist field at all. 


    For example on the Andrea Bocelli album Sogno the tracks were listed as:

    Title: Canto Della Terra, Artist: Andrea Bocelli, Album Artist: Andrea Bocelli

    Title: The Prayer, Artist: Andrea Bocelli and Celine Dion, Album Artist: Andrea Bocelli

    Title: O Mare E Tu, Artist: Andrea Bocelli and Dulce Pontes, Album Artist: Andrea Bocelli


    This worked fine on iTunes and in the Cover Flow setting of my iPod Classic, but the Artist setting showed each seperately. I then changed the info to:


    Title: Canto Della Terra, Artist: Andrea Bocelli,      Album Artist: <blank>

    Title: The Prayer [with Celine Dion] Artist: Andrea Bocelli, Album Artist: <blank>

    Title: O Mare E Tu [with Dulce Pontes], Artist: Andrea Bocelli, Album Artist: <blank>


    This is quite tedious, and really should be unnecessary. After all, isn't that what the Album Artist field is there for? But there really aren't very many options that can be set on the iPod classic software.


    Hope this helps

  • 3. Re: artists list ignores album artist field
    Bilbo_cheshire Level 4 Level 4 (1,770 points)

    Don't need to be tedious if you want to blank out Artist Album.

    You can also

    1. select all the Artist - Andrea Bocello.

    2. Right click (Windows) or Control (Mac)  - Click on the "Get Info".

    3. Click on the Album Artist field and blank out the data.

    4. Click ok.


    Good Luck!


    This work on iTunes 8 and 9 series.

  • 4. Re: artists list ignores album artist field
    lubnah Level 1 Level 1 (0 points)

    Thanks to @tee mac and @Bilbo_cheshire for some useful work-arounds.


    If it were any other company, I wouldn't bother with my nitpicking at all.  But it's Apple, so… I'm still holding out hope that an Apple engineer addresses this with an update.


    Here's to hoping it's not an intentional design decision.

  • 5. Re: artists list ignores album artist field
    turingtest2 Level 8 Level 8 (46,525 points)

    You're looking at a feature . iOS 5 has finally addressed the Artists vs. Album Artists issues on iOS devices but I've no reason to expect any change in the behaviour of the classic line. IIRC iTunes gained an Album Artist field back with about version 7.1 in 2007 but the iPod firmware was never updated to allow Album Artist to link tracks with different guest artists. See my article on Grouping tracks into albums for tips on how to organise your library for best effect on your iPod.


    Ah, reading your orignal post again I see you have an iPhone, in which case upgrading to iOS 5 should at least sort that one out.



  • 6. Re: artists list ignores album artist field
    lubnah Level 1 Level 1 (0 points)

    Thanks @turingtest2, the section One album, too many covers from your article is exactly what I've described above, and thanks for pointing out that iOS 5 fixes it (I hadn't even noticed yet, despite having upgraded).


    Perhaps the iPod Classic hardware isn't powerful enough to implement this bugfix/feature, although if it took until iOS 5 for this to be implemented, I'm more inclined to believe that it was an oversight.


    Of course, if Apple is doing a recall on the 5yo 1G iPod Nano, perhaps they wouldn't mind digging into the past and issuing a firmware update for the classic line!  But this is perhaps too much of a reach…

  • 7. Re: artists list ignores album artist field
    turingtest2 Level 8 Level 8 (46,525 points)

    I believe the recall is for a battery issue. Chance of a firmware revision is almost non-existent. I've suggested elsewhere that, since iTunes writes out the database for the iPod, it could be fixed in iTunes without a firmware update. It would just be a matter of implementing out workaround "on the fly" as the data is written out to device without actually changing any tags. Again I doubt it will ever happen.



  • 8. Re: artists list ignores album artist field
    C Monty Burns Level 1 Level 1 (0 points)

    I was having exactly the same issues, followed tee mac and Bilbo's advice, cleared the field for "Album Artist" on the tracks that were annoying me, and voila!  The artist appears where/as it should, the album artwork is intact, and I am a happy boy (as in Beat Farmers).  BTW do this in your Music Library as well (I know, tedious, but results make you feel better), just in case Apple doesn't get this figured out.



  • 9. Re: artists list ignores album artist field
    turingtest2 Level 8 Level 8 (46,525 points)

    The "fix" is moving the guest/feature artist into the track name so that Artist can be the Album Artist. There is no need to clear the Album Artist field also. The iPod classic ignores the field, iTunes and iOS devices can use Album Artist, but fall back to Artist if Album Artist is empty.



  • 10. Re: artists list ignores album artist field
    bornheimarne Level 1 Level 1 (0 points)

    Since i just got an iPod Classic too this question bothered me a lot, too!


    After some researching i have fun a workaround that works for me really well!




    what you do is you download the free apple script this tag that tag.


    what you then want to do ist go to your itunes library go to songs ( so all your songs are shown) and sort it by album artist.


    now you select all track that have an album artist and open this tag that tag and set it to copy album artist to compser. click Proceed and then it automatically copies all the album artists to the composer field


    after this tag that tag ist finished go on with part 2


    second part: select all tracks that dont have an album artist. go to this tag that tag and select copy artist to composer



    after this you can just use the composer field on your ipod classic as the Sort by Album Artist option.


    Beware that this will overwrite all your previous composers !


    Also your complete Music library has to be resynced to your ipod!



    other downsides are that you have to manually edit it for new tracks but thats not too big of an effort or you can just repeat the process on a playlist that has your latest added songs.


    I hope i could help you !


    (of course this is only my suggestion and im not resposible in any way if this messes up your itunes Library - it worked great for me though!)



    Here is the link to THIS TAG THAT TAG:



    Message was edited by: bornheimarne

  • 11. Re: artists list ignores album artist field
    bornheimarne Level 1 Level 1 (0 points)

    Now There also exists an apple script that automates keeping your iTunes playlist up to date with my method.


    Credit for this Script goes to Doug Adams - i had the basic idea but used one of his scripts as my starting point and then he helped me get it working - Thanks Doug! http://dougscripts.com/itunes/


    How to use this script:


    Create a smart playlist in iTunes that has all tracks of the past 7 days in it.

    Paste the name of the playlist in the "name of playlist" field in the apple script

    Put the whole script in Apple Script Editor and save it.

    Now create a calendar event that is repeated every week. In the field alarm you can choose " open file" and select your apple script in this field.



    Your calendar app now runs this script weekly and automatically edits the album artist ( and if there's no album artist the regular artist) into your composer field.



    i hope you guys find this usefull and it helps some people !


    Regards Arne



    This is the script:

    tell application "iTunes"

              set sel to every track in playlist "name of playlist"

              if sel is not {} then -- if tracks are selected...

                        set ofi to fixed indexing

                        set fixed indexing to true

                        with timeout of 300000 seconds

                                  repeat with this_track in sel


                                                      if this_track's album artist is not "" then

                                                                tell this_track to set composer to (get this_track's album artist)


                                                                tell this_track to set composer to (get this_track's artist)

                                                      end if

                                            end try

                                  end repeat

                        end timeout

                        set fixed indexing to ofi


                        display dialog "No tracks have been selected." buttons {"Cancel"} default button 1 with icon 0 giving up after 30

              end if -- no selection 

    end tell