Skip navigation

Strange external HDD related Safari behaviour.

5231 Views 26 Replies Latest reply: May 13, 2013 8:38 PM by matatdci RSS
  • Jouster Calculating status...
    Same problem here with a WD Elements drive, no third-party software loaded for it. The BBC News website in particular seems to be fond of waking up the external drive. I don't know if that's significant or just that it's one I use a lot so I just notice it more.
    27" iMac 3.0GHz Core 2 Duo, Mac OS X (10.6.7)
  • LifeSizeActionFigure Calculating status...

    I'm noticing the same behavior in Safari.  I have a early 2011 Macbook Pro 8,3 and I have Safari 5.0.5.  My external drives are in a Thermaltake BlacX dual SATA drive dock.  Both are WD10EADS drives.  I hate that if I have Safari open I always have to close it before I can eject one of these drives.  Also if they are asleep (these WD Caviar Green drives go to sleep to conserve power, even if your energy saver settings are set to not put the disks to sleep if possible) then I have to wait for them to spin up if I'm switching tabs or opening a new site in Safari.

     

    Why does Safari need to access my non-boot volumes?  I could understand if the downloads folder was directed to an external drive you might have this issue but mine is not.

  • AlexSonne81 Calculating status...

    Check the Console when it does this and see what it's looking for. Safari was "randomly" spinning up a 2TB and an 8TB drive (6 total HDD's...took a while) on certain pages.

     

    Eventually I confirmed through the web pages' CSS files and Console that it was asking for a font that wasn't in Font Book, and it polled my drives to try to access it. I have not figured out how to stop this behavior in Safari or block the font system from being able to poll/ping other drives for a font that's damaged or missing. Anyone know how?

  • scamper Level 1 Level 1 (35 points)
    Currently Being Moderated
    Aug 28, 2011 12:26 AM (in response to AlexSonne81)

    The font issue is an interesting lead. However I wish we could promote this topic out of the Safari area, since I think it's misleading. Safari is usually open on my system, but it's usually in the background, and I've had this problem show up when I'm in Photoshop, TextEdit, or taking any one of several explicit actions in the foreground. I don't know that all these actions are text-related, so it's hard to know whether font-polling is always the culprit. Definitely keeping my eye on this thread though.

  • vincent-antwerp Calculating status...

    Hi All,

     

    I also have this problem, but with Google Chrome instead of Safari. Upon loading a page I often get the beachball cursor and I hear my external USB drive spinning up. This takes about three seconds and then I can continue.

     

    I use a late 2010 Macbook Air with OSX Lion. The hard drive is a Lacie (Samsung disk according to the disk utility), which is connected to my Cinema Display using USB, which in turn acts like a docking station using an USB connector to my MBA.

     

    Since Chrome and Safari both use Webkit, this problem might be Webkit related?

  • tsutaz Calculating status...

    Hi,

     

    Just adding me as having the same problem with a WD (usb) MyBook 2TB external drive connected to 2009 iMax, OSX Lion, 8gig ram.

     

    Taz

  • macadamea Calculating status...

    Same problem. Older 10.5.8 iMac system and 250 WD external I use for back ups. Nothing but docs and family photo album are on it. I'll be taking a break from looking through pictures and read an email.  It should just remain asleep but it doesn't. Wakes up just like all statements above. When I get my TB drive plugged in I am prompted about a helvetica font search and I have to tell it no - no searching. Absolutley worthless process that wears on my backups that I want to shut off.

  • pauls73 Calculating status...

    hello,

     

    i came here because i have the same problem. however, more amazingly, i was just about to disconnect my external drive, and on ejecting it, it said "The disk couldn't be ejected because "Safari" is using it"!

     

    does anyone have any idea why safari would be using my external drive? this spin up problem has been bugging me forever, and this is the first concrete clue that something safari needs is there. total nonsense this is! any ideas??

     

    thanks!

     

    btw - using safari 6 on OSX 10.7.4 - but, has been going on for as long as i can remember. my external drive is lacie. 

  • erugalatha Level 1 Level 1 (20 points)

    This is not just happening in Safari.  This happens in Chrome for me.  Same issue as reported by the OP.  When I navigate on a page (page already loaded) or to a new page in a new tab or window Chrome spins up any hard disk that is connected but gone to sleep.  The web page will not load until the hard disk has spun up.

     

    I think this is more an OS X issue than any browser issue.  I am using OS X Mountain Lion 10.8.2

     

    The only thing I can think of that might be causing this is that I have that hard disk that spins up set to be my time machine back up drive - so it may be that stuff in the browser needs to be written into the time machine backup?

  • pauls73 Level 1 Level 1 (10 points)

    hello,

     

    just following up. for me, it was a font issue. i am a graphic designer, so i have quite a number of fonts. most of them are on my internal drive, but some project related fonts were on an external. they were "open" usually. i went through my font management program, and removed all references to fonts on my external drive. after that, this problem seems to have gone away. i have not noticed it once since then.

     

    it doesn't sound like my case is exactly the same as most cases here, but it could be similar. hope it helps someone, as it was driving me nuts.

  • petur from iceland Calculating status...

    I have the same problem... no idea what could be causing it :S

  • matatdci Calculating status...

    Count me in. I have two hard drives, non-boot has JUST my iTunes material. Safari thinks it is a good idea to spin it up when I go to a new site.

     

    This is the only reference to Safari in the area.
    13/05/13 11:21:16.609 PM Safari[2198]: CGContextClipToRect: invalid context 0x0
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.