Skip navigation

Keyboard shortcut quit working

1280 Views 16 Replies Latest reply: Feb 22, 2013 3:38 AM by zaco88 RSS
1 2 Previous Next
mjconn75 Calculating status...
Currently Being Moderated
Oct 5, 2011 6:22 AM

Anyone know why a single keyboard shortcut would quit working? My ⌘-\ shortcut for stack pick has stopped functioning. It's still listed as active in the command menu for shortcuts though. The ⌘-\ is the only keyboard shortcut that has quit working for me too.

Macbook Pro (early 2011), Mac OS X (10.7), 2.2 GHz Intel Core i7, 8gb Ram
  • Kirby Krieger Level 6 Level 6 (11,570 points)
    Currently Being Moderated
    Oct 5, 2011 7:29 AM (in response to mjconn75)

    Does the problem persist after re-booting?  Have you tried any trouble-shooting?

  • léonie Level 8 Level 8 (46,475 points)
    Currently Being Moderated
    Oct 5, 2011 8:18 AM (in response to mjconn75)

    You also may wish to have a look at the "System Preferences" -> Keyboard -> Keyboard Shortcuts -

    Sub Panel. Click on all the Applications listed in the left column and have a look if a newly installed application or Service has stolen that key-binding.

  • Frank Caggiano Level 7 Level 7 (22,785 points)
    Currently Being Moderated
    Oct 5, 2011 8:42 AM (in response to mjconn75)

    What happend when you try to use the shortcut in Aperture? Screen flash, ding sound, nothing?


    And just to be safe you have a stack open and you have an image selected when you try to use the shortcut?


    Finally if you go to Stacks->Pick and set the stack pick from the menu it works?

  • Frank Caggiano Level 7 Level 7 (22,785 points)
    Currently Being Moderated
    Oct 5, 2011 8:58 AM (in response to mjconn75)

    If you go to the command editor Aperture->Commands->Customize what is shown in the pulldown in the upper left part of the screen?


    Screen shot 2011-10-05 at 10-05 11.56.47.png

    Could you include a screen shot like this one of your system?

  • Frank Caggiano Level 7 Level 7 (22,785 points)
    Currently Being Moderated
    Oct 5, 2011 9:42 AM (in response to mjconn75)

    OK so did the problem start after you made the Custom Command set?


    If it's working in the other account I would start by moving the preference file out and see it that resolves it.


    The preference file is in your home:library:Preferences folder and is Just drag that file to the desktop (with Aperture closed) and restart Aperture.

  • léonie Level 8 Level 8 (46,475 points)
    Currently Being Moderated
    Oct 5, 2011 9:56 AM (in response to mjconn75)

    If the shortcut works from a different account, that indicates that something related to your account is to blame, either some preference settings in your user library, or less likely, your Aperture Library (that is, if you made the test from your test account with a different Aperture library).

    So I would suggest to trash the file

    /Users/your_user_name/Library/Preferences/, and if that does not help, to repair your Aperture Library. (Make sure, you have a backup of both, before you try that.

  • scooper4711 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 21, 2012 11:45 PM (in response to mjconn75)

    I had the exact same issue, however it was a different cause. Since googling for "aperture keyboard shortcut quit working" returns this page as #1, I thought I'd document what fixed it for me.

    I had installed 1password. An otherwise excellent program, but it registers its keyboard shortcut in a way that it doesn't show up in Keyboard Preferences, but it is active absoluetely everywhere.


    Here's how I found out about it for others to troubleshoot: I opened console. Every time I pressed command-\, I got the message: Failed to send 'activate' to '', client not connected. The logging program was called "1PasswordAgent", so it was simple to figure out from there. Add this to your box of tricks when things aren't working - look in Console.


    Anyhow - after I got rid of that keyboard shortcut in 1password and logged out/back in, my Aperture keyboard shortcut started working again.


    Hope that this helps someone else in the future. If so, please reply to this post to keep it the #1 search result in google.

1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.