Skip navigation

2011 Macbook Pro not detecting external display after new Thunderbolt firmware update

8119 Views 18 Replies Latest reply: Mar 12, 2013 4:37 PM by booc0mtaco RSS
1 2 Previous Next
oscar68 Level 1 Level 1 (0 points)
Currently Being Moderated
Sep 27, 2011 2:31 PM

I have a 2011 13'' Macbook Pro, which I used to connect to a HP LP2465 monitor with a thunderbolt to dvi adapter without any problems. After the new Thunderbolt update (september 2011), thunderbolt does not detect the monitor, and nothing happens when I connect the monitor.

 

Anyone else having similar problems? Any ideas?

MacBook Pro, Mac OS X (10.7.1)
  • 666dax Level 1 Level 1 (0 points)

    Count me in. My internal LCD crapped out (2011 15" Macbook Pro i7 2.0GHz) so I was using the external monitor until I updated Thunderbolt. Now nothing. I took hard drive out and formatted it. Still nothing. Did all resets, still nothing. I have been fooling around with it for days. Very frustrating.

  • Roam Redway Level 1 Level 1 (40 points)

    I'm having the same problem. Only since the firmware update. "Detect Displays" has no effect whatsoever. I am able to get one of my external monitors (old NEC Accusync) to show up eventually (although "Detect Displays" doesn't find it), but I can't get one I use in another location (a Samsung HP S5053). As a work around, I set my NEC to the resolution/frequency that the Samsung needs, then plug the Samsung in and it works. But I can't make any resolution/frequency adjustments to the Samsung. And the NEC normally uses a different resolution, so I have to manually do this every time I switch.  Hassle.  Talked with Applecare twice. They're reluctant to believe that it's a firmware update problem. But I've done all the resets they recommend and "dectect displays" still doesn't work for me.

  • Grant Bennet-Alder Level 8 Level 8 (48,110 points)

    oscar86-

     

    What adapter are you using?

    Beige G3, G4/867, G4/dual 1.25 MDD, MacPro'09 w cheap SSD, Mac OS 8.6 or Earlier, and 9.2, 10.5 and Server - LW IIg, LW 4/600, ATalk ImageWriter L
  • Roam Redway Level 1 Level 1 (40 points)

    I'm pretty sure that it's a "Mini Display Port to VGA Adapter."

     

    I have an early 2011 (bought in March) 13" MBP.

     

    The connection to the Samsung has always been a bit touchy, even before the firmware update. But I was able to get it to work. And every time I clicked on "Detect Displays," the MBP would go looking for the attached displays and tell me what I had. It doesn't do that any more.

     

    When I use my 2007 MBP, I have no problem connecting to the Samsung.

  • Grant Bennet-Alder Level 8 Level 8 (48,110 points)

    Roam Redway-

     

    Your adapter is just a re-wire of the VGA signals that are provided at one end of the DVI-I port on the computer.

     

    The blade is the common return, and Red, Green, Blue, and Horizontal Sync are the four pins surrounding the blade. Vertical Sync is the last pin in the top row of the grid. DDC (for communicating the device capabilities and ID) is on pins 6 and 7 next to it.

     

    If any of those pins are bent or missing, it will give you a lot of trouble. There are no active components in that adapter.

     

    Are you using the same cable for both your monitors? Maybe one cable has a failing wire or bent pin. On the DB-15 (three row) ID channel would be pins 12 and 15 on the bottom ros.

    Beige G3, G4/867, G4/dual 1.25 MDD, MacPro'09 w cheap SSD, Mac OS 8.6 or Earlier, and 9.2, 10.5 and Server - LW IIg, LW 4/600, ATalk ImageWriter L
  • Grant Bennet-Alder Level 8 Level 8 (48,110 points)

    a mini display port to DVI.

    If that is a brand X adapter, I suggest you switch to the Apple adapter or an ACTIVE adapter.

     

    If Applecare was talking to you, why did you stop? They want you to be happy. Call them back and tell them their suggestions did not work, and ask them what now? or take it to the Apple store (appointment recommended) and have them figure it out.

    Beige G3, G4/867, G4/dual 1.25 MDD, MacPro'09 w cheap SSD, Mac OS 8.6 or Earlier, and 9.2, 10.5 and Server - LW IIg, LW 4/600, ATalk ImageWriter L
  • A Furore Level 1 Level 1 (0 points)

    Bought a brand new MBP 13 i7 today, bought Apple mini port to DVI adapter while there, plugged it in- same problem.  Won't recognize monitor, detect display thinks for a few seconds the first time you try it, but does not yield a response and doesn't react to further attempts.

  • Grant Bennet-Alder Level 8 Level 8 (48,110 points)

    To get these adapters to external displays to work, there are a number of factors which must all come together.

     

    1) the right adapter, fully inserted:

     

    The Mini DisplayPort/ThunderBolt adapters must be inserted into the socket so that essentially ALL of the metal part disappears inside the socket. Push Hard!

     

    2) the Mac must detect the display.

     

    This is a required intermediate step on the way to getting a picture on the display. Even if there is no picture on the display, the Mac should acknowledge that a display has been attached and show you its make and model.

     

    About this Mac > ( More Info ) > Graphics and Displays

     

    Display Connector:

      Status:          No Display Connected

     

    The above shows that the display has not been seen, and you MUST fix this problem before proceeding.

     

    Displays:

    Cinema HD:

      Resolution:          2560 x 1600

      Pixel Depth:          32-Bit Color (ARGB8888)

      Display Serial Number:          CY8360UFXMP

      Main Display:          Yes

      Mirror:          Off

      Online:          Yes

      Rotation:          Supported

     


    This indicates that the display has been detected. Your Mac is aware of its capabilities and knows what resolutions should work. But this may still not be enough to get a picture on the display.

     

    3) reasonable resolution must be set.

     

    This is often difficult when the displays are [√[ Mirrored, because the resolution selected will be a compromise that can be handled by the built-in display. This may not result in a displayable picture on the external display. Most displays will report "no signal" when the signal presented is present, but out of range.

     

    Uncheck [√[ Mirrored in Displays prefs and you can set resolution for each display independently.

     

    4) Optimum resolution should be set for best picture quality.

     

    LCD displays show their best picture quality at maximum resolution. Other resolutions may show a picture, but be blurry.

     

    5) Understand Extended Desktop

     

    When [√[ Mirrored is unchecked, the two displays are combined along one edge to form an Extended desktop. The mouse cursor can move onto the secondary display as an extension of the Primary display, and you can drag windows around from one portion of the Extended Desktop to another, and even leave them split across displays. All will continue to work as expected -- scrolling a window split across displays scrolls both parts consistently.

     

    Mac OS X 10.7 "Full Screen" is an iPhone feature that is NOT intended for use with multiple displays. Avoid it.

    Beige G3, G4/867, G4/dual 1.25 MDD, MacPro'09 w cheap SSD, Mac OS 8.6 or Earlier, and 9.2, 10.5 and Server - LW IIg, LW 4/600, ATalk ImageWriter L
  • Roam Redway Level 1 Level 1 (40 points)

    Grant: this is a very detailed checklist and I appreciate the effort and the advice. I'll make sure I follow it.

     

    I'd posted a reply to the original posting so I thought I'd update people on where I am in all of this.

     

    I have two external monitors that I connect to my 13" early 2011 MBP. (Yes, I use an Apple adapter.) One is a small NEC; the other is a large Samsung plasma. The problems had been with the Samsung.

     

    As I have a work around that gets the large Samsung external monitor to work, I'd stopped fretting about this.

    Still, I had been convinced that there was something wrong with the Thunderbolt firmware, since the malfunction of "Detect Displays" did not occur till after the September 2011 firmware update.

     

    Since that time, clicking on "Detect Displays" (whether on the Menu Bar display, or within System Preferences itself), produced no effect. Nothing got detected. I had to use workarounds every time I swapped the external monitors.

     

    Just this past week, there was a new firmware update. I held my breath as I installed it. I'd booted up with the NEC monitor attached and "mirroring" off. Everything worked perfectly and automatically. Then Wednesday night, I unplugged the NEC and, without rebooting, plugged in the Samsung for the first time. I was "mirroring" the laptop and the external screen. Everything worked just like it used to. I was so pleased.

     

    Then, after finishing my presentation on the Samsung, I swapped out the Samsung and, without rebooting, or turning off "mirroring," I plugged in the NEC. The MBP knew there was an external monitor attached, but it could not connect at the correct resolution or frequency. Even worse--since I'd been "mirroring" on the Samsung--I was still set on "mirroring" when I plugged in the NEC. The screen on the MBP went as whacky as the screen on the NEC: both were a pale blue with no desktop, icons, etc. I had to reboot the MBP. The external monitor could not be detected. So I rebooted again, holding down two keys that AppleCare had told me to hold down to reset the powermanagement controls for the Thunderbolt port.  Once it was rebooted, I was able to plug in the NEC and it was detected just fine. Since then, I've only had the NEC plugged in so there's been no need to fiddle with any more of this. But come Wednesday, I'll need to make my weekly presentation with the Samsung, so it'll be interesting to see what happens.

     

    So, it seems to me that there's been some improvement given the recent firmware update, but it's still not perfect. Next week, when I swap in and out the 2 LCDs, I'll make sure that "mirroring" is off before I make the switch back from the Samsung to the NEC. Hopefully, with mirroring turned off, the NEC will be detected at the correct frequency and resolution and everything won't go whacky. Otherwise I don't know what to do other than restart the MBP before plugging the NEC back in. It sure would be an annoyance to have to reboot but if that's a necessary work around, well, I'll work around it.

     

    Maybe if enough other people keep having problems with this, a third firmware update will put this problem to rest.

  • Aron5109 Level 1 Level 1 (0 points)

    Everything was working fine for me... until recent thunderbolt and EFI update.

     

    But i found a sulution witch works 100% for me.

     

    i am using cheap noname adapter (mini display to DVI)and 24" samsung screen with my 13" Macbook Pro

     

     

    Here is what worked for me :

     

     

    1. Download, install and start gfxCardStatus (get it from http://codykrieger.com/gfxCardStatus)

     

    2. Here is the trick.... most people tell you to set it at Dynamic switching... but I set it at  "Intergrated Only"

    then i plug the adapter inn and BAM its on the other screen and seems like the computer switched automaticly to dynamic switching..    (if i select dynamic switching in the beginning.. its like it chokes or something and doesnt send signal over)

     

    Works with every **** monitor i test. but works only if i select "intergraded Only" before connecting into the thunderbolt port.

     

     

     

    Hope this helps.

     

     

    Extra Info about my comp :

     

    Macbook Pro 13" (early 2011)

    Processor : Intel Core i5 2.3 GHz

    System : Lion 10.7.2

    Graphics Card : Intel HD Graphics 3000 384 MB graphics

    Boot ROM : MBP81.0047.B24

    SMC Version : 1.68f96

     

    Thunderbolt :

    Firmware Version:          22.1

    Port Micro Firmware Version:          2.0.7

  • SanctionOne Level 1 Level 1 (0 points)
  • robertfrombay village Level 1 Level 1 (0 points)

    I cannot believe that Apple scks so much that its customers are tied in knots trying to get something so simple with Windows and Linux machines to work. Come on, really?  I have never had trouble with a variety of non-Apple notebooks and netbooks and desktops when I connect to external displays, either vga or hdmi.  Ridiculous.  This is why as much as I love some of the things about Macs, I will never use their slave-made products exclusively.

  • vincentlpratte Level 1 Level 1 (0 points)

    I've got a very similar situation, and I've tried anything again and again for the past days (weeks) without much success.

     

    I'd been using a Samsung B2030 LCD monitor for over a year and a half (using a Dynex Mini-display-to-dvi adapter) with my MBP 13" (late-2011) without any problems before. I cannot say for sure what caused the change, but it started to get unstable somewhere this fall.

     

    At first, the MBP would not detect the monitor half the time (when it had been unplugged and plugged-in again, or after puting the laptop to sleep or rebooting it). I had found a strange workaround, which involved changing the resolution to the MPB to anything lower than the original value (with the monitor not plugged-in) and launching Color-Sync (by selecting "Open profile" from the Color tab). It worked without a glitch for a few days, before becoming useless.

     

    Now I can spend hours trying to get the MBP to detect the external display, but it won't do any good. I sometimes connect my Samsung HDTV to my laptop using a mini-display-to-hdmi adapter, and this works like a charm. I tried every I could find on these forums and on others, but nothing does it. It might be that the adapter or the dvi cable I'm using that is failing, but I haven't been able to test any of that. But I'd be kind of annoyed having to buy a replacement without knowing for sure that it's the source of my problem. And with so many people having similar issues (although some did find solutions) that I have a hard time believing that everyone has had cable/adapter failures.

     

    Anyway, I don't have anything knew to bring in terms of solutions. I just thought I would share my experience and hopefully someone will come up with a bright new idea...

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.