Skip navigation

"Do not proceed" on filevaulted system after 10.7.2

20176 Views 62 Replies Latest reply: Dec 5, 2013 7:15 PM by rr100 RSS
  • Jim Knopf Calculating status...

    Excellent way to solve the problem - thanx a lot to everyone and JofArnold for the "easy" way.

     

    Only one little note for those not so apt in Terminal but with the same problem. These are the two lines you have to call in Terminal to move the two culprits to your desktop:

     

    mv /Volumes/[YOUR LION-DISK]/System/Library/Extensions/PGPwde.kext /Volumes/[YOUR LION-DISK]/Users/[YOUR USER-SHORTNAME]/Desktop

     

    mv /Volumes/[YOUR LION-DISK]/Library/PriviledgedHelperTools/com.pgp.framework.PGPwde /Volumes/[YOUR LION-DISK]/Users/[YOUR USER-SHORTNAME]/Desktop

     

    Regards

    Jim Knopf

  • cypher123 Calculating status...

    i ditched PGP long time ago due to the constant problems when i updated the system.

     

    BUT

     

    right now i have exact same problem you guys are having on a mid 2011 macbook air that has NEVER had PGP installed. it has apples own Filevault 2 turned ON....anyone else having this problem?

     

    i can start in recovery mode and i have even re-installed lion via recovery mode already without any luck.

     

    when it boot after re-installing lion it prompt me for the apple filevault pass..i type it and then i get the same gray screen with circle and slash over and its hanging there forever

     

    any ideas on what to try next?

     

     

    Øyvind

  • JofArnold Calculating status...

    I ditched PGP Whole Disk Encryption, BUT there's still some PGP software on there.

     

    To see for yourself if that's the case on startup, do cmd+V for the visual boot mode (loads of commands scroll past on a black screen - it's used for debugging) and wait for it to freeze. Then scan through last few lines - ther's a pretty good chance it will have "PGP" somewhere. If so, follow the advice above. If not, I can't help you - really hope you find a solution!

     

    BTW the reason it happened to me is that Time Machine transferred PGP from another machine. So even though I use FileVault2, the PGP app was still there.

  • JofArnold Level 1 Level 1 (5 points)

    UPDATE: PGP's gui uninstaller doesn't work for me (see ik8sqi2's wiki link above for more info) So for now I'm just keeping those files in their new out-of-the-way position until I find the time to go through and remove everything. Symantec have certainly made themselves no new friends today...

  • AppleStar Level 1 Level 1 (45 points)

    Well,I would say you start in all usual places, where bad coded software products left their tracks:

     

    Kernel Extensions in

     

    /Library/Extensions/

    /System/Library/Extensions/

     

    mayby even

    /Library/LaunchAgents

    /Library/LaundDaemons

     

    Compare the content to a fully functional 10.7.2 system - since it's becomming harder to understand which ones are from Apple and which ones are not.

     

    In general I recommend a great tool for checking on extras within the Library folder : http://khiltd.com/software/consultants_canary

  • hejish Level 1 Level 1 (0 points)

    I did this but the PGP cleanup gui tools had already been deleted... So I manually found all the items in the list provided above and deleted them, rebooted, and I think I'm all good.  Thank you very much.

  • cypher123 Level 1 Level 1 (0 points)

    oki... found the problem.

    i overlooked that i had to cd to /Volumes/hardrivename as the / files are the files in the recovery volume...hehe

    so i found :

      1. /Volumes/HD/System/Library/Extensions/PGPwde.kext
      2. /Volumes/HD/Library/PriviledgedHelperTools/com.pgp.framework.PGPwde

    and deleted them. how they ended up there is a mystery but it must have been via timemachine (that i dont use any more) or maybe even .me syncs? or i might have moved some folders from my desktop compter in past that i dont remember.  ...pgp desktop app was not installed on the computer at all and i will never get close to that again now that i hopefully have gotten it all removed once and for all.

     

    anyway...now everything works fine again! thanks a lot for the help!

     

    Øyvind

  • billfinch Calculating status...

    @Christopher Graham5:

     

    I had the same issues and went through all of these files one by one and removed them, then was able to boot normally.

     

    Thanks for the info and suggestions from all!

  • MacgyverOne Calculating status...

    Ugh, these PGP conflict/errors are getting old.  Following the discussions above did the trick, the following two files seemed key to my recovery from the boot error.

     

    /System/Library/Extensions/PGPwde.kext

    /Library/PriviledgedHelperTools/com.pgp.framework.PGPwde

     

    Thanks for all the help from everyone! 

  • dmojavensis Calculating status...
    Currently Being Moderated
    Oct 13, 2011 5:35 PM (in response to ik8sqi2)

    ik8sqi2, thank you so much for the solution. It worked for me. Phew! Just like you, I thought I've gotten rid of all those bloody PGP files a while ago, but it seems like one can't quite fully get rid of it .

     

    For those less familiar with Lion (like I was just an hour ago), you can mount your root partition using Disk Utility (even if it's encrypted with Filevault)  once you boot off of a recovery partition (hold Cmd-r when powering on your Mac). This is obvious once you know about it, but it took me a little while to figure out.

  • kbata Calculating status...

    I didn't even realize that I had PGP installed.  Just went thru removing all the peices using all the instructions on this thread.

    My problem now is that after I got everything working again, before finding this thread,  with a fresh install and then pulling my data in from a backup drive I tried to use Filevault again.  This time instead of going thru the whole install, then pull the data in process I used disk utility to turn encription off on my boot drive.  As a side effect of that process my backup drive is no longer mountable.

    Invalid Volume Header @ 0: incorrect block type

    Invalid Volume Header @ 1999736188416: I/O error

    disk2 is not a CoreStorage volume

     

    Any sugestions for fixing the backup drive without wiping it?

  • murray1784 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 13, 2011 6:28 PM (in response to kbata)

    You left a step out when you erased your disk.  You needed to setup the disk with a GUID partition.  As far as I know the only way to fix it is to go back and erase the disk and do another restore.

     

    If it's any consolation, I made the same mistake even though I knew the correct procedure.

  • kbata Level 1 Level 1 (0 points)

    And I thought I was done with all this.  At least after removing all that PGP stuff and rebooting my backup drive is working again.  Sounds like a fun project for this weekend.  This time I think I'll save the important things in icloud so I don't have to sweat it out durring that long coundown when restoring.

  • Shock Doc Calculating status...

    Wow! This is scary stuff.  So I had better be REAL careful before upgrading to Lion.  Uninstalling PGP 10.2.0 even after decrpting everything using the uninstaller BEFORE upgrading to Lion may not even work. 

     

    Thanks for the warning and Fix.  I will make sure I have the necessary time, food and alcoholic beverages before attempting!  Or just chicken out all together!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.