Skip navigation

Iphone 4 - Not connecting to wifi (incorrect password)

227270 Views 85 Replies Latest reply: Jan 28, 2014 11:41 AM by iH85CH001 RSS
  • DrMoog Level 1 Level 1 (0 points)

    I have been having the same issues.  Bought a new time capsule to see if that would help and no luck. Had tried everything else suggested here.  Sometimes iPhone would connect other times no luck.

     

    Checked settings on the router by typing in its address like SaLmAn described.  Noticed under advanced settings, LAN IP,

    that the starting ip ended with 10 and the finishing ip ended with 19. We have 12 wireless devices so there were not enough unique iPs for everything.  Changed ending ip to 25 and whala everything connect seamlessly.

  • johnnyb69er Level 1 Level 1 (0 points)

    it happenned to me a while ago. go to the wifi ur trying to connect to and then click the arrow to the right of the name and FORGET NETWORK.. then try and log into it again.

  • airmanoo Level 1 Level 1 (0 points)

    I disconnected my TC from its power source and powered it back on. That seemed to work!

  • Jim O\'Hare Level 1 Level 1 (0 points)

    We had the same problem.  My wife's iPhone 4 would connect to every wireless network except our home network.

     

    We seem to have solved the problem.  When the phone requested the password we put in the network's WEP encryption key (instead of the router password.)  The phone immediately connected to our home network. 

     

    Just to confirm, we then went to the router page (using one of our computers) and checked the DHCP client table.  Sure enough, the phone is now there.

     

    Hard to believe it could be this simple, but maybe this is the answer for at least some of the connection problems.

  • famousartguy Level 1 Level 1 (0 points)

    I found a solution for mine. I am currently using UVerse and I logged into my IP address settings/admin panel. Once there I reset my WPA/WPA2 setting to one or the other and it worked fine. Connected right away. Maybe this will help someone else?

  • israelfromhouston Level 1 Level 1 (0 points)

    Iam having the same problem. My Iphone 4 is connecting to my router and works fine. I checked with ATT and my router is connecting at router 254..... however my wifes phones dectects router 251 even though both have the same wireless router name selected. Any suggestions?

  • jumpymostly Level 1 Level 1 (0 points)

    I had this same problem.  My iphone 4 connected to my home network just fine, until one day it said that the password was wrong, even though all the other devices continued to connect normally.  I tried Jim's suggestion of entering the WEP key instead of the password when asked for the password, and it worked!

  • Paragorn Level 1 Level 1 (0 points)

    Check to make sure the DHCP pool isn't full in your router, just had the exact same symptoms here and turned out that all DHCP leases were in use, so not able to get an IP address.

     

    Cheers,

     

    Paul

  • sec004 Level 1 Level 1 (0 points)

    tried everything -----wow this has been a pain but i think i got it now... i (finally- and simply) "reset all settings" on the iphone and then reset the airport on the laptpo (turned the phone off while resetting the airtport). when i turned the phone back on it was connected...but it renamed the airport... done ...keep trying there doesnt seem to be one quick fix

  • Friar8 Level 1 Level 1 (0 points)

    Jim is right. Have to put in the WEP Security Key. I have a D-Link Router and the generated "security key" it gave me when I installed the router is a 10 digit code.

  • i_man Level 1 Level 1 (0 points)

    hy lazer,

    after having same problem as you and the reading you statements,i think i have found how to solve this issue for you and me both,here goes....

    go to you router settings and change password so all deviced in your home are disconnect from your router,then change the router password,and reset network settings on phone,when phone is back on after resetting net settings and changing password,tring to connect to the router will not work(well from my experience),please just do as i typed ,then all you do is change the password again to original password you had in first place,and KBOOM it will work god willing,it did for me     :-D

  • debdan Level 1 Level 1 (0 points)

    I am having the same problem with my new i phone; very frustrating. Will not accept my password and join my home network... yet the password is the same one I used for all my home wireless devices. The phone works well in public wi-fi locations.

  • kwford Level 1 Level 1 (0 points)

    Having the same issue with my iPhone 4, my wife's iPhone 4 and all other devices are connecting without issues. The problem started this morning and nothing has been changed on the network or the iPhone. Also just discovered I can't connect to the wifi at work. Tried "forget network" and "renew lease" to no avail. Any ideas?

  • kwford Level 1 Level 1 (0 points)

    EDIT: Reset network settings worked for the office wifi.

  • REHASHER Level 1 Level 1 (0 points)

    I am now also having the same problem with my brand new 4s! My Virgin Superhub reset itself yesterday & caused me not to be able to connect to my own wifi! Before the Superhub reset everything was absoultley fine! I have tried everything to fix it but no luck! I even got a new Superhub sent out today & guess what? same problem 'incorrect password!''. My sister can connect to the network fine with the same password as I try & enter! i have now narrowed this down to an iPhone error! Iphones honestly drive me mad!!!! Please can someone give me a solution or I'm back to the Apple Store!

     

    Thanks

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.