Skip navigation

Sync iCal with iCloud Calendar

41613 Views 28 Replies Latest reply: May 5, 2012 3:34 PM by rossfromuniversity place RSS
1 2 Previous Next
jr378 Calculating status...
Currently Being Moderated
Oct 13, 2011 7:17 PM

None of my appointments in iCal show up in my iCloud Calendar. In fact my iCloud Calendar has no appointments in it. I am sure I screwed something up in the coversion and trying to remove all the duplicate entries. In any event, how do I go about syncing forcing the appointments in iCal to show up in iCloud Calendar.

  • jcram13 Calculating status...
    Currently Being Moderated
    Oct 13, 2011 7:26 PM (in response to jr378)

    Same issue here.  I transferred from mobile me to the cloud and everything is still in iCal on my computer, but there is nothing in the iCloud ical.

  • MaxGuru Level 1 Level 1 (35 points)
    Currently Being Moderated
    Oct 13, 2011 8:54 PM (in response to jr378)

    I had this issue on my iMac and fixed it by:

    1. Import my calendars into iCal from my backup .ics files

    2. Go to System Preferences>iCloud and deleted my iCloud account

    3. Added my iCloud account back in the iCloud Prefs pane

    4. Select Merge when asked what to do with calendars

    5. Calendars will now be back on iCal and in the iCloud

  • MichaelTree Calculating status...
    Currently Being Moderated
    Oct 13, 2011 11:45 PM (in response to MaxGuru)

    You say Go to System Preferences>iCloud and deleted my iCloud account? Do you find this when ICal is open? I went to SP and could not find an I-Cloud Icon, only the old Mobile Me icon?

  • MaxGuru Level 1 Level 1 (35 points)
    Currently Being Moderated
    Oct 14, 2011 4:13 AM (in response to MichaelTree)

    You probably need to run Software Update under the Apple menu. Upgrade to 10.7.2 and you will get the iCloud control panel. Once you go to iCloud you will see that most of the MobileMe options will have been transferred to iCloud.

     

    I hope you backed up your iCal calendars using the iCal Export feature before deleting anything.

  • thanos206 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 19, 2011 3:53 PM (in response to jr378)

    I had the same problem and this is how i got through: I just connected my i Phone to my mac and sync the calendar... (my iphone's calendar was left blank after the ios5 update...). Then I just turned icloud syncing off and on again from iPhones preferences panel. After that all the events showed up in my iCloud's calendar and now it syncs great in every apple device!

     

    thantas

  • MaxGuru Level 1 Level 1 (35 points)
    Currently Being Moderated
    Oct 19, 2011 4:04 PM (in response to jr378)

    Sorry, I used the wrong phrase there. I should have said Sign Out of iCloud.

     

    The other thing you can do after signing out is go to iCal>Preferences>Accounts and delete the iCloud account there.

     

    Doing both the sign out of the iCloud account and the deletion from iCal seems to cause a "reboot" of iCloud when you sign back in and check Calendars on the iCloud pref pane. Just be sure you have a backup of all your calendars BEFORE doing any of this.

  • travellingrvt Calculating status...
    Currently Being Moderated
    Oct 19, 2011 7:27 PM (in response to jr378)

    My problem was duplicate items in iCal on my Mac but iPhone was fine.

     

    To fix:

     

    System preferences>>>iCloud>>>unchecked Calendars>>>rechecked the Calendars box>>>pop up asking if I wanted to merge calendars>>>clicked yes and voila, no more duplicates :-)

  • marcia s Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 20, 2011 9:23 PM (in response to jr378)

    I got mine to work...I did not have duplicates, but creating duplicates allowed my fix.

     

    Try this:

     

    1. System preferences>>>iCloud>>>unchecked Calendars>>>rechecked the Calendars box>>>pop up asking if I want to merge calendars>>>clicked yes   You will then have duplicate entries BUT the new set is from iCloud!

     

    2. iCal>>>Preferences>>>Accounts>>>deselect (ie uncheck the enable this account box) the NON-iCloud CalDAV account>>>you now have the iCloud info on your MacBookPro iCal screen!

     

    :)

  • svejk1969 Calculating status...
    Currently Being Moderated
    Oct 24, 2011 2:42 PM (in response to jr378)

    First of all I did what was recommended above and deleted and then added back my iCloud account.

     

    I exported the calendars I didn't want, then imported them into my iCloud calendar when prompted.

     

    That seems to have done the trick thankfully - possibly not the most elegant way though...

  • da remix Calculating status...
    Currently Being Moderated
    Oct 25, 2011 7:47 AM (in response to jr378)

    The simplest way is to go to System Preferences > Mail, Contacts>Calendars >> icloud - untick calendars (prompt that there will be changes) - the tick the calendar box (merge info) and voila!

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (10)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.