Skip navigation

Strange Powerbook Slowdowns.. Help?

609 Views 8 Replies Latest reply: Oct 14, 2011 2:23 PM by BGreg RSS
ccJames Calculating status...
Currently Being Moderated
Oct 13, 2011 5:36 PM

I have a 15" Aluminum PowerBooks G4 @ 1.67 GHz, with 2 GB of RAM. Here's the issue:

 

When I bought it, the machine had been fully wiped with a new installation of OSX Tiger put on it. I then upgraded it to Leopard. Each of the OSX versions seemed pretty sluggish, but most other PowerBooks can still keep up with Leopard. It's hard enough for mine to run Safari ALONE. And this is the last graphically updated version before the PowerBooks reached the end of the line.

 

My question is this: How could my Powerbook be running SO slowly? There is barely any data on it at all. I think that it is the battery. The battery is so old it only lasts around ten minutes. I remember reading an article that stated Apple laptops decreased 30% in performance when running only on AC power. Could that be the case?

 

This PowerBook is beautiful and I don't want to get rid of it. There should be no reason why it's so drained in performance. I've tried cleaning the machine out (software-wise, like using Onyx) but it didn't seem to work. Therefore, I turned to the Apple community to hopefully find an answer to my problem.

 

Any reply is appreciated! Thanks!

  • BGreg Level 6 Level 6 (17,500 points)
    Currently Being Moderated
    Oct 13, 2011 7:44 PM (in response to ccJames)

    One of the issue that can cause problems going from Tiger to Leopard is incompatible programs. Do you have any login items that need to be updated to work with Leopard?  To see if you have a login item issue, go to System Preferences, accounts, and create a new account with no login items. Reboot the system and log into that ID. If it works normally, there's a login program issue.

     

    I have a PowerBook 1.67Ghz, which runs Leopard fine, on battery and/or electricity.  I've never heard it said, or read, that a Powerbook under AC power is 30% slower. 

     

    One issue with older Powerbooks is the PRAM batteries are starting to die. Yours is dead if you pull the battery and disconnect AC power, then reconnect and put the battery in, then restart and you get a message that the system date was set back to 1969 or some other old date.  While not typically terminal, odd system problems can crop up that seem to only be solved by replacing the battery.  It's internal to the system, on a small circuit board.  If yours is dead, you might check with ifixit.com or macsales.com to see if they have a replacement.

    If your good with circuitry and soldering, you can buy a replacement cell battery and solder it in. 

  • old comm guy Level 4 Level 4 (2,230 points)
    Currently Being Moderated
    Oct 13, 2011 10:28 PM (in response to ccJames)

    Some random thoughts.

     

    Check your Energy Saver settings in System Preferences, especially anything to do with processor performance.

     

    Use Activity Monitor (in your /Applications/Utilities folder) to see if some one or more processes are hogging CPU cycles.  Enable the full-time CPU Usage monitor and see if your CPU usage is running away for no apparent reason.  If so, then look in the activity monitor and sort on CPU usage to find the cycle hogs.

     

    Check to see if Spotlight is gumming up the works by dragging your hard drive to the Privacy listing in Spotlight preference pane to see if the indexing is hogging CPU.  This could be a bigger problem with laptops that are not "running" as much as a desktop usually would be.

     

    More PRAM battery information in this thread. One sure-fire way to test the backup battery is to put the laptop to sleep, remove AC power, remove the main battery for five to ten seconds, then put the main battery back in and reconnect the AC.  If the laptop has shut itself down as a result of this routine, then the PRAM battery is toast.

    TiBook G4 1GHz/ G5 2 GHz DP GF Ultra 6800, Mac OS X (10.4.11)
  • Texas Mac Man Level 8 Level 8 (44,220 points)
    Currently Being Moderated
    Oct 14, 2011 6:23 AM (in response to ccJames)

    Boot in Safe Mode. See What is Safe Boot, Safe Mode? (Mac OS X) http://docs.info.apple.com/article.html?artnum=107392

    Safe mode turns off startup apps & disables other files. It may take a while to run, but it usually "fixes" other problems. Have you repaired permissions & run Disk Utility from your OS X install DVD?

     

     Cheers, Tom

  • BGreg Level 6 Level 6 (17,500 points)
    Currently Being Moderated
    Oct 14, 2011 7:51 AM (in response to ccJames)

    Did you say whether you see the same issue with Firefox or Opera, as alternate browsers?

  • Allan Jones Level 7 Level 7 (29,575 points)
    Currently Being Moderated
    Oct 14, 2011 12:27 PM (in response to ccJames)

    See if "About this Mac" is reporting all your RAM.

     

    There was a known issue with 15" PowerBooks with 1.5G and 1.67G processors having one RAM slot fail. If that happened, Safari, which likes RAM, might go walkabout.

  • BGreg Level 6 Level 6 (17,500 points)
    Currently Being Moderated
    Oct 14, 2011 2:23 PM (in response to ccJames)

    I know that Firefox and Opera can import bookmarks from Safari, should you decide to go that route.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.