Skip navigation

hdmi sound problem began after 10.7.2 update

6406 Views 28 Replies Latest reply: Aug 1, 2013 12:39 PM by alanfortune RSS
1 2 Previous Next
mwahlman Calculating status...
Currently Being Moderated
Oct 12, 2011 8:50 PM

Since I've applied the latest update, I am no longer able to switch my audio output from headphones to HDMI. I change between the two on a near daily basis. I hadn't previously encountered this problem with any 10.6 or the previous 2 releases of Lion. I have a Panasonic TV. Whenever I click to change the output from headphones to hdmi from either the top bar sound icon or through settings/sound it reverts right back to headphones...

Mac mini
  • oxmox11 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 13, 2011 2:52 AM (in response to mwahlman)

    same here no audio after update for my Mac Mini to 10.7.2 neither via HDMI nor headphone jack

  • RewAU Calculating status...
    Currently Being Moderated
    Oct 13, 2011 8:45 AM (in response to mwahlman)

    I can confirm the same behaviour, however I am able to route audio to the HDMI interface using an application which allows you to specify the audio destination (Airfoil Speakers).

     

    I'll log this issue with Apple and let you know if I get a resolution.

  • alissonaguiar Calculating status...
    Currently Being Moderated
    Oct 13, 2011 9:05 PM (in response to mwahlman)

    Same thing here: after 10.7.2, I`m unable to switch from Headphones to HDMI audio. I`m unable to use audio anymore !!!!

  • TheSmokeMonster Level 4 Level 4 (3,240 points)
    Currently Being Moderated
    Oct 13, 2011 9:11 PM (in response to alissonaguiar)

    have you tried fooling around with Audio MIDI setup? hit cmd space, type audio midi hit enter, then try to see if changing your setting around will work. is this issue happening all the time or after playing a video with digital out?

  • jzaun Calculating status...
    Currently Being Moderated
    Oct 13, 2011 11:05 PM (in response to TheSmokeMonster)

    This ia happening to me as well. I've tried messing with the MIDO settings but nothing works. When I try to select the Samsung TV (HDMI) audio out it just reverts back to my Headphones. This happened after the 10.7.2 update and was working before that just fine.

     

    This happens for all audio, there is no way to select HDMI output anylonger, it just reverts to Headphones.

  • RewAU Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 13, 2011 11:53 PM (in response to jzaun)

    Jzaun,

     

    Is there anything plugged into your headphone / audio-out port ?

     

    The behaviour I am seeing is that if there is anything connectd to the headphone / audio-out port, it is impossible to select HDMI in System Preferences -> Audio, however applications which are able to select an audio destination are abe to send audio to HDMI.

     

    If anything is plugged into you headphone / audio-out port, unplug it and let us know if HDMI then becomes selectable ?  This information might help Apple track down the issue in a more timely fashion.

  • RewAU Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 14, 2011 1:39 AM (in response to TheSmokeMonster)

    SmokeMonster,

     

    I've not had any success in getting default audio route to the HDMI port via the Audio MIDI utility. The behaviour isn't changed before or after launching QuickTime or XMBC to play media files.

     

    Unfortunately, I don't have any optical devices handy to verify behaviour when using digital output.

  • woodmeister50 Level 4 Level 4 (3,690 points)
    Currently Being Moderated
    Oct 14, 2011 3:04 AM (in response to mwahlman)

    Those with no audio at all, do you have 2010 or 2011

    Minis or something else?  Reason I am asking, is that

    I have updated my 2010 to 10.7.2 (hoping it fixed iTunes

    movie issues, didn't) and have had no change in my

    audio performance.   My configuration is:

    Mini->Yamaha Receiver->Samsung TV.

     

    I know in the past, trying to debug some other issues,

    having the HDMI and optical connected at the same time

    defaulted to optical out and could not get HDMI audio.

    It seems that deep in the Hardware/Fimware/LowLevelDriver

    there is some link between the two and probably the original

    designer is gone and the people working on it now are

    clueless as to how it works.

  • jzaun Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 14, 2011 5:06 AM (in response to RewAU)

    I just double checked and I did have a wire (not connected to anything on the other end) plugged into the headphone jack. Once I removed the wire I was able to select the HDMI output device.

  • u2194739 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 14, 2011 9:28 AM (in response to mwahlman)

    If I remember it correctly, Lion 10.7.1 fixed the HDMI audio issue (based on the update info), but how did it start to go faulty again?  Unless i unplug the audio jack, otherwise, the HDMI just will not work.

  • PeteHawk Calculating status...
    Currently Being Moderated
    Oct 14, 2011 9:43 AM (in response to mwahlman)

    Not sure if this is re4lated but it does sound like there are audio issues    (i've posted this in iTunes discussion)

     

    Prior to the latest upgrade of iTunes I was happily streaming audio from my MacPro to my Apple TV and then over my sitting room speakers.  Now if I pause the audio in iTunes for any lecgth if time (when i take a phone call for example) and then start it up again, do audio is heard.  iTunes is playing, the Apple Tv is still on.  I have to switch back to computer speakers and then back to AppleTV again to reactivate it.

     

    Is this me, iTunes 10.5 or Apple TV iOS5?

     

    Pete

  • woodmeister50 Level 4 Level 4 (3,690 points)
    Currently Being Moderated
    Oct 14, 2011 10:21 AM (in response to mwahlman)

    As far as I know, 10.7.1 fixed the audio issue that was

    the same in 10.6.8 where stereo output was disabled

    whenever a Dolby or DTS audio was played.

  • Arthurian Legend Calculating status...
    Currently Being Moderated
    Oct 14, 2011 12:13 PM (in response to mwahlman)

    Same problem here on my 2010 Mac Mini with 10.7.2. Extremely annoying. I hope we don't have to wait until 10.7.3 until this is fixed.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.