1 2 3 Previous Next 198 Replies Latest reply: Jul 9, 2014 12:27 PM by Mac.Dee
epfenn29 Level 1 Level 1 (0 points)

I'm having similar problems with my iMessage update under iOS 5.  When I send text messages to other iPhone users, it appears as iMessage and from my email address rather than my phone number.  I went into Settings > Messages > Receive At, but there's no option to add my phone number.  It keeps showing my Apple Account, which I registered under for iMessage and iCloud with my email address.  It only allows me to add another email address.  From what I can tell, non-iPhone users are still receiving my text messages from my number like regular.  If I turn iMessage OFF, I'm sending regular text messages to all users.  Anyone have a fix yet?  I'm wondering if this was an Apple goof that won't be resolved until the next iPhone update. 


iPhone 4, iOS 5
1 2 3 Previous Next