Skip navigation

OS X Lion freezes at login screen + App Store is slow

261079 Views 1,019 Replies Latest reply: Oct 6, 2012 1:06 AM by n748 RSS Branched to a new discussion.
  • jwsell Calculating status...

    Hi Folks,

    Had the same problem on my wife's 2010 MBAir after installing Lion over Snow Leopard: hangs on startup with spinning beachball or no desktop icons, etc; after 3 forced restarts, it would function okay until she shutdows and the process would start again.  My SOLUTION which has now worked for three weeks with no further issues was to remove all items from the ~/Library/Preferences folder saving them to a separate folder on the desktop.  The restart went fine and some of the preferences were recreated. I simply reestablished some preferences and occasionally added back a preference for a specific application, but left most of them on the desktop.  Do be careful about the com.apple.security.plist and the com.apple.security.systemidentities.plist preferences.  System Preferences behaved strangely until I put them back.  Otherwise enjoying Lion now, even after the 10.7.2 update. hope this helps someone, but use at your own risk, of course.

  • Lord2013 Calculating status...

    @2good2btrue and everybody else who got a replacement. Could you post or PM your case ID, as I'm trying to solve this issue now with 3 different senior support guys at apple and did not get a working solution so far, I'm going for a replacement now, too.

     

    thx


  • Terry Mahoney Level 1 Level 1 (35 points)
    Currently Being Moderated
    Oct 16, 2011 9:04 AM (in response to jwsell)

    @jwsell: Very interesting. Would you please verify that your MBAir is one of the late 2010 ones that have the NVIDIA GeForce 320M (not 330M) in it? And - if it is a 320M - what is "Revision ID" for that GPU?

     

    It would be nice if this bug really can be fixed with a software update. But we need to rule out a hardware glitch, too.

  • damien7579 Calculating status...

    From reading this long thread, most users suffering the reported symptoms are MBP with certain GFX hardware, however, there are some users who suffer the same random freezes/beachball hangs on the login screen on Lion hardware.

     

    This is happening to me on a new 2011 Mac Mini Server 2.0ghz I7 (Intel HD3000 gfx card). There appears to be no reported fixes that work on this combo and it's driving me mad as I have 3 users who login into the box so it happens at least once a day. I plan on calling Apple support this week and will post back but please any other 2011 Lion hardware users having the same issue please chime in! So far my experience with Lion has not been a positive one but sadily I've no choice but to use it on this hardware as it does not support SL.

  • Lincoln Adams Level 1 Level 1 (0 points)

    Hey Terry, good to see I'm not the only one. 

     

    I know the OP and mikeev have unsubscribed but I still took issue with their complaints.  mikeev said it's as simple as a free phone call and replacing the logic board (also for free), but we've already seen that at least with one person I think, replacing the logic board didn't work, and with at least one other they refused to provide that kind of repair replacement for free.

     

    But we can't complain?  If Apple won't officially acknowledge the issue, won't fix it, won't do anything, and instead all comes down to the luck of getting a sympathetic support rep to either replace the MBP or logic board or whatnot, what other recourse is there? 

     

    You know what would have helped instead of calling us all whiners?  Actually giving us the NAME of the support rep that replaced the logic board for you, because he knows about the issue already, and if we call Apple support we can ask for him specifically and get someone already familiar with this problem and the aid we need.

  • Lincoln Adams Level 1 Level 1 (0 points)

    Terry, man that ***** that the fix didn't work but I suspected it to be the case.  The issue is not the login itself, it's something to do with the nVidia card and the method of switching back and forth between onboard video and the nVidia card itself, otherwise disabling automatic graphic switching wouldn't have worked.  That's why my macbook still freezes when I'm watching Hulu on occasion, lots of switching around there in regards to the graphics.

     

    BTW, here's my stats:

     

    Also using MBP 6,2

     

      Chipset Model: NVIDIA GeForce GT 330M

      Type: GPU

      Bus: PCIe

      PCIe Lane Width: x16

      VRAM (Total): 512 MB

      Vendor: NVIDIA (0x10de)

      Device ID: 0x0a29

      Revision ID: 0x00a2

      ROM Revision: 3560

      gMux Version: 1.9.21

     

     

    It really does appear that we all have the same revision card.  I bet we all ordered the mid 2010 MBP as SOON as it came out too didn't we. 

     

    BTW, I'm taking my MBP to the Apple Store tomorrow.  I've never used a Genius bar before but hopefully I'll get someone friendly.

  • Terry Mahoney Level 1 Level 1 (35 points)

    Hi Lincoln. I have sympathies for all sides. But I admit that, since I have another Mac, still happily purring with SL, this issue is not super critical for me. And obviously it is SuperCrit for a few other forum followers.

     

    Apple's engineers are probably also tearing their hair, trying to get a handle on these (multiple) problems - so I feel for them. And I honestly think that we REALLY don't know, yet, whether the problem is tied to specific hardware. But the recent post by damien7579 makes me think it is not specific to any hardware component. It's probably a timing-bug - that crops up when system threads or processes don't synchronize properly - and the OS goes into a kernel-panic, or into a "ready-wait" state - when it shouldn't be in that state - or into an infinite loop (SBBoD). BTW - I have also experienced one Lion kernel-panic - results mailed to Apple on restart, of course.

     

    This type of bug can be devilishly hard to reproduce - let alone diagnose!

  • Terry Mahoney Level 1 Level 1 (35 points)

    @Lincoln: Good to know we have the same NVIDIA stats. But I also think your guess that the SBBoD is related to automatic switching, between on-chip graphics and the 3rd-party GPU, is a very likely cause. It might also tie-in to power-management issues. I suspect that lots of process-synchronization bugs are possible - no matter what combinations of hardware are involved.

  • Lincoln Adams Level 1 Level 1 (0 points)

    I know what would fix it though:  Ripping out the nVidia GT330 soldered on to the board and smashing it to bits with my hammer.  And here I thought ATI video cards would be the death of me.

     

    But before I do that I'll bring it to the Genius Bar.  I'm taking my iPad with me so I can show them this thread, plus I still get Lion support because it hasn't been 90 days yet since my purchase, so that might be my "in."

     

    I wish mikeev has indicated who the support rep was or the case ID at least as it would help bolster my case in getting a logic board replacement for free.

  • Terry Mahoney Level 1 Level 1 (35 points)

    @lincoln: Oh dear! Don't mash the poor 330M chip.

    And if you haven't already, notice that damien7579 is having the same problem with a new "Lion server". If the bug is also affecting currently-sold hardware with Lion installed, I doubt that Apple can guarantee a fix by simply handing out replacements. And recipients might still have the problem - which might be OK as long as you can still wipe the drive and reinstall SL - to run until the dust settles.

     

    I have a buddy in Portland who got a "pre-release, Lion-ready" MBP on sale in the weeks leading up to Lion. He asked if he should "wait for Lion"? I said "no way. It's going to be buggy for a while". I'm happy I said that. I'll bet he is too.

  • Lincoln Adams Level 1 Level 1 (0 points)

    BTW, is a Time Machine backup sufficient to retain all my data should they wipe the hard disk for repair?

  • Terry Mahoney Level 1 Level 1 (35 points)

    @Lincoln: I believe it is. If they wipe the internal HD (or if you install and format a new HD (GIUD, Extended journaled) then (after SL is reinstalled) you can use Disk Utilities "Restore" and select the TM backup drive to restore from CeCat.

     

    Here's a reference (but for Leopard) from C: https://discussions.apple.com/message/8193034?messageID=8193034#8193034?messageI D=8193034

     

    I have done this myself with SL but I forget the details.

     

    Just make sure that your TM Backup is fully up-to-date. I goofed on that one and lost a few recent emails that had not been backed-up. AND - you will need your OEM SL Install DVDs if you want to reinstall SL yourself. The "retail copy" of SL will NOT boot your machine - or at least it would not boot my own MBP.

  • Lincoln Adams Level 1 Level 1 (0 points)

    Thanks, it's a little different with Lion but more straightforward: just start up the recovery HD to use the restore option and choose a time machine backup from there.  Keeping my fingers crossed for tomorrow!

  • Terry Mahoney Level 1 Level 1 (35 points)

    @Lincoln: Thanks for sharing the Lion approach. Good to know. I plan to eventually do the same with my own MBP. I did a clean install of Lion onto a new internal HD, and put the original HD into a McAlly FW 800 enclosure, which was also useful for downloading and installing Lion. IMO, Lion is not yet stable enough to rely on for my daily use. Perhaps in 6 months? But in the meanwhile, my MBP is at my local Mac specialist retailer. I respect their Tech Support (not that I don't second-guess them occasionally ) so first I will see what they suggest - if only because Lion's AppleCare policy gives me a single-issue, Support-call, within 90-days of purchase.

  • Terry Mahoney Level 1 Level 1 (35 points)

    @damien7579: This makes it look as if this bug (SBBoD at Lion login) is definitely not (only) caused by Automatic Graphics Switching - since it looks as if your Lion Server has only a single GPU. Interesting.

     

    I am guessing now that this bug is a result of a general type of process-switch. Hard to reproduce on demand and hard to traceback when detected. But it also suggests that a software patch will eventually be found that will cover a set of cases.

1 ... 18 19 20 21 22 ... 68 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (56)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.