Skip navigation

Wifi connection issues after iOS 5 upgrade in iphone 4

2250 Views 16 Replies Latest reply: Apr 29, 2012 7:02 AM by Lepus•!! RSS
1 2 Previous Next
samdawg12 Level 1 Level 1 (0 points)
Currently Being Moderated
Oct 16, 2011 4:38 PM

Hello All,

 

After the upgrade everything seems to have been allright but for some reason, iphone 4 iOS5 has completely failed to recognize my home network. I use Airport Extreme and Express which uses dual bands. No matter how much I try to restart the router and phone the problem seems to persist.Wifi tries to recognize the network and accepts the password but it gets stuck in identifying the network forever and does not actually connect to it. It does not find the router and assigns itself some wierd ip address. However it does the outside networks like starbucks and apple store. Its just home network thats causing this issue.

 

I would greatly appreciate any help and ideas regarding this issue. Its really annoying and I have never had problem like this in the past. I have attached an image of stuck wifi window here. Let me know if you have any clue regarding this issue with ios 5 and wifi.

 

Thanks


Sam

 

photo.PNG

iPhone 4, iOS 5
  • mom22boys Calculating status...

    I am having the same problem.  I've removed my router as my home network & tried to re-connect, but that didn't work.  Hope to hear (read) help soon.

  • Andrew-Explore Fun Calculating status...

    Same problem here. Once my iPhone 4S running iOS5.0 has connected &/or iTunes is wirelessly connected to the iPhone4S, my wireless network won't allow other devices to connect to my network (running on an Airport Extreme) (ie my Sony TV and my girlfriend's iPhone4 see the network but can't connect to it. Airport Extreme is on 75200.14 firmware.

     

    Any ideas?

     

    Thanks

    -Andrew

  • iDeals Calculating status...

    I am having a similiar problem connecting also. Macs (Mac OS X Lion) are able to connect to most current version of Time Capsule, but iPhone 4 and 4S running iOS5 see the network but will not connect. I also upgraded a 3GS to iOS5, and that will see the network but not connect.

     

    I am able to connect to other WiFi networks, Starbucks, McDonalds, AT&T WiFi, etc..

     

    I agree it sounds like a problem with Airport devices and iOS5

  • iDeals Level 1 Level 1 (0 points)

    Excellent. Worked perfect. In Airport Utility, I just changed the name of the network to Test, reset the iPhones network settings, connected to temp "Test" network. Changed network back to previos name, and done.

     

    Thanks.

    Vince

  • Phonzee Calculating status...

    I am having the same problem but with the network created by my Time Capsule I still cannot get connected.

     

    See my post.

     

    https://discussions.apple.com/message/16587463#16587463

  • Phonzee Level 1 Level 1 (0 points)

    Well

     

    Yesterday I tried to do what you refer above, obviously applyingit to my Time Capsule (Gen 1) and unfortunately it did not work.

     

    I did these:

     

    1. I Restore4d my iPhone4 iOS 5 using iTunes anddid not restored my data yet as you said
    2. I load again the newest firmware for TimeCapsule which is 7.5.2. It was already installed but I installed it again
    3. Once the firmware was installed the Time Capsuleautomatically restarted, but I restarted manually again.
    4. Restarted the modem into which is connected theTime Capsule.
    5. I renamed and changed the network password.
    6. Created a WPA/WPA2 Personal

     

    In the IPhone did:

    1. Restore mybackup files using iTunes,
    2. TapSettings>General>Scroll down to Reset>Tap Reset Network Settings
    3. TapReboot
    4. Let theiPhone restart

     

    But It did not work, can you please help me? I am desperate

  • grymh Calculating status...

    I had a problem like this, my iPhone suddenly did not connect to WIFI after having my brnd new TimeCapsule installed. The Mac and other devices connected perfectly to the WIFI of the TimeCapsule.

     

    THIS IS WHAT I TRIED WHICH DID NOT WORK:

    - Restarted iPhone

    - Restarted/rebooted og re-configured Time Capsule many times, changed password many times

    - Time Capsule and Mac are both new and have the latest firmware

    - iPhone has the latest also OS 5.0.1

    - I have erased and re-configured iPhone

    - I have turned off WIFI setting on iPhone

    - I have deleted all network settings in iPhone and restarted with factory settings

    - I have changed the WPA2 password to a shorter one (8 characters) (as was suggested in one thread in this forum)

     

    It was also said that many people solved their problem by setting their router to WEP instead of WPA. But I cannot chose to try WEP instead of WPA, because my Time Capsule only let me chose WPA2.

     

    THIS WAS HOW I SOLVED MY PROBLEM:

    - I changed the radio setting in the Time Capsule to 802.11n. After that my iPhone connected itself immediately! Nothing more needed! Fantastic!

     

    Please see below a link to the thread where I found the solution. Maybe it will work for you too?

     

    https://discussions.apple.com/message/6887597#6887597

  • grymh Level 1 Level 1 (0 points)

    About my post above: I was too fast. The phone now connects right away, the wireless symbol is one, everythings shows correct connected - but still does not connect to internet! It is just connected to the WIFI!

     

    Useless!! Does anybody have tips of what to do that can take me all the way, get the internet to work on the phone as well?

  • Craonnage Calculating status...

    Hi,

     

    I am also having a problem connecting iPad and iPhone to my Airport Express.  It previously worked very well.  I think this problem sarted with iOS5.

     

    I am able to connect to other wifi networks located away from home.

     

    I tried all of SamDawg's suggesstions.  My phone finds the new network I created and prompts me to enter my password, but still no connection to the internet.

     

    I do not have Time Capsule or any other wireless devices connected to my airport.

     

    I am very desperate.  People need to use iPad's and phones on my Network and I am using up all of my 3G minutes!

  • Craonnage Level 1 Level 1 (0 points)

    Hi Sam Dawg,

     

    Yeah!  The hard reset on my Airport Extreme worked.  It was a little hard to tell  exactly which was the reset button.  It is the very small recessed button under the little arrow one. 

    Thank you!

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.