Skip navigation

iCloud deleted my keynote files

22813 Views 101 Replies Latest reply: Mar 31, 2014 1:26 PM by iamalexis RSS Branched to a new discussion.
  • slim08 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 16, 2011 10:38 AM (in response to Felix Leiter)

    Same issue here. All docs gone from Numbers, Pages and Keynote. Saw them briefly before disappearing. Really really worried.

  • Felix Leiter Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 16, 2011 12:53 PM (in response to hermeneut)

    The files should be safely store in LIbrary/Mobile Documents.delete (that's where I found them), but the point is not where they are, it's why do they get deleted. This is obviously a synchronization issue with one of the devices (or the Mac) telling iCloud to erase upon sync: but which sync process?

  • Stephen Kelly2 Calculating status...
    Currently Being Moderated
    Oct 16, 2011 1:16 PM (in response to Felix Leiter)

    Interesting, Felix!  But I can't see a Mobile Documents.delete folder.  Is it hidden?  If so, how do I show it?

  • NickFro Level 2 Level 2 (295 points)
    Currently Being Moderated
    Oct 16, 2011 6:45 PM (in response to hermeneut)

    I may have found a fix. Delete the iCloud account at both the main level of Settings (i.e., by selecting iCloud) AND by deleting the account in the Mail, Calenders, and Contacts section of Settings. Have it remove everything from your device (careful, this is scary and ymmv). Once it's done. Go to the main level, select iCloud, and re-enable your account there and set all settings there for sync. Let the sync happen.

     

    Since doing this on both my iPad and iPhone, iCloud has been stable with iWork documents. I had noticed that my PhotoStream was different on the two devices and so I am thinking that, somehow, iCloud got 'confused' w/r/t state and was alternating between a state WITH iWork documents uploaded and WITHOUT, in which case it deleted them.

     

    I've had stable documents that survive device restarts for about 4 hours now...so we shall see.

  • alan68 Calculating status...
    Currently Being Moderated
    Oct 16, 2011 7:17 PM (in response to NickFro)

    Thanks for the suggestion but I didn't work for me. I deleted the account in iCloud and selected to have it remove everything from the iPhone. When I went to delete the mail account it was gone. Then I redid the account under iCloud. iWork files are still being erased on restart however.

  • Ward Level 2 Level 2 (195 points)
    Currently Being Moderated
    Oct 16, 2011 11:42 PM (in response to Felix Leiter)

    Great tip on the ~/Library/Mobile Documents.delete folder—I found what appears to be my file there. However, it shows up as a directory with the ".numbers-tef" extension, and I can't seem to find a way to actually open the file in numbers or get it back onto my iOS devices (tried changing the file extension to ".numbers" and loading it on the device by several means, moving the contents of the "Mobile Documents.delete" folder to the "Mobile Documents" folder, etc. I do get a file that appears in Numbers on my devices but I can't open it, export it, etc.

  • Ward Level 2 Level 2 (195 points)
    Currently Being Moderated
    Oct 17, 2011 12:28 AM (in response to Ward)

    Found a solution in another thread on this same problem to recovering documents from Mobile Documents.delete folders. See the post from "gvde" quoted below. It's convoluted but it works! At least my data is safe now.

    gvde wrote:

     

    I have managed to get my Numbers documents back:

     

    1. I have copied the documents folder in "~/Library/Mobile Documents.delete.Sat Oct 15 09:01:32 2011/com~apple~Numbers/Documents" to "~/Library/Mobile Documents/com~apple~Numbers/Documents".

    AGAIN: MAKE A COPY! Don't move the folder in case it doesn't work. Maybe even make a second copy fo the whole ".delete" folder to have a backup copy available!

     

    2. I have renamed each document folder, removing the ending "-tef", e.g. renamed "My First Document.numbers-tef" to "My First Document.numbers". This makes the document appear in iCloud shortly afterwards. You can't open it as it is considered a document created by the Mac Numbers application.

     

    3. I have renamed each document folder back, i.e. "My First Document.numbers" to "My First Document.numbers-tef"

     

    4. Now iCloud seems to sync it up again and recognizes it. It reappers on my iPad and I can open it.

     

    5. I did this for each of my 9 documents. If you have more, you may want to use a little script.

     

    6. To get the previews back I have also copied the contents of "~/Library/Mobile Documents.delete.Sat Oct 15 09:01:32 2011/com~apple~Numbers/iWorkPreviews" to "~/Library/Mobile Documents/com~apple~Numbers/iWorkPreviews"

     

    Now everything seems to be O.K. Documents are back. They show up on icloud.com, iPad and iPhone. I haven't done anything with Numbers the last two days thus at least for me: no loss.

     

  • Supra_User Calculating status...
    Currently Being Moderated
    Oct 17, 2011 2:20 AM (in response to hermeneut)

    I'm seeing at lot of posts about the same problem:

    Here is another discussion, with a temporary solution for those who have documents on their computer. I lost those I used on my iPad 1 and iPhone 3GS.

     

    iCloud deleted my documents. How do I get them back : https://discussions.apple.com/thread/3382799

  • Felix Leiter Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 17, 2011 3:42 AM (in response to hermeneut)

    I seemed to have solved this problem by deactivating iCloud on every device (including the Mac!) and then activating it again, after trashing the "Delete Mobile" folders I had found in the LIbrary. Now the IWork documents have resumed regular syncing and I haven't experienced any deletion since. Here's the steps I took exactly: (a) tun off iCloud on Mac, iPad, iPhone after backing up Calendars and Address Book, (b) deleted "Mobile Documents" folders from Library and (c) reinstated all ICloud accounts commencing with Mac. Who knows, perhaps it was just a synchronization issue.

  • davidfromshipston Calculating status...
    Currently Being Moderated
    Oct 17, 2011 3:57 AM (in response to Felix Leiter)

    I have also been looking at the issue, I seem to have found a log file for the Mac side, it is "~/Library/Ubiquity/username/ubiquity.log", everytime I upload, or do any change on any device (iPad, iPhone or Mac) I see a number of errors being reported.  I have just deleted the application support files located in  "~/Library/Application Support/Ubiquity/" and performed a restart to force the files to be recraeted.  Lets see if this helps fix the probelm.

  • davidfromshipston Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 17, 2011 4:05 AM (in response to davidfromshipston)

    Also removed the invalid certificates in my keychain related to Ubiquity.  The files are not being deleted, but time will tell.

1 2 3 4 ... 7 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (5)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.