Skip navigation

All mounted volumes erased installing Xcode 4 under Lion

414 Views 5 Replies Latest reply: Oct 23, 2011 6:05 PM by paulfromsantacruz RSS
paulfromsantacruz Calculating status...
Currently Being Moderated
Oct 17, 2011 5:04 PM

I installed Lion, then installed Xcode 4. I did this TWICE (fool that I am). The first time I lost my entire system disk. The second time I lost my entire system disk, my Time Machine backup on a Time Capsule, and a hundred Gbytes of photos and other media on my ReadyNAS raid box. I had no clue that such a bug was even possible. Today I found the same issue that occurred with Snow Leopard, occurring from last March to last June:

All mounted volumes erased when system...: Apple Support Communities


Oh, My God! I had no clue I could endanger storage in other machines on my network just by installing an app on my iMac. This is my first time here, so I haven't yet discoverred how to report bugs, but PLEASE, don't let this go by. This has cost me 10 days of work and untold heartache. Thank heaven I didn't have more volumes mounted before the install.

iMac, Mac OS X (10.7.2), Installing latest Xcode 4.2
  • baltwo Level 9 Level 9 (59,145 points)

    If you want to report this issue to Apple's engineering, send a bug report or an enhancement request via its Bug Reporter system. To do this, register as an Apple Developer—it's free and available for all Mac users and gets you a look at some development software. Since you already have an Apple username/ID, use that. Once a member, go to Apple BugReporter and file your bug report or enhancement request. You'll get a response and a follow-up number; thus, starting a dialog with engineering.

    27" i7 iMac 10.6.8 , Mac OS X (10.7.2), G4 450 MP 1.5 GB RAM w/(10.5.8/10.4.11/9.2.2)
  • woodmeister50 Level 4 Level 4 (3,690 points)

    Try booting to Recovery HD and run Disk Utility and do

    a Repair Disk on the OSX partition.  Maybe there is just some

    directory corruption that Repair Disk might fix.  Also,

    do a Repair Permissions as well.

  • jsd2 Level 5 Level 5 (6,200 points)

    FWIW, this post was marked "Correct Answer" in this Snow Leopard thread:

    Install Xcode from the App Store = Deleted System


    Apr 26, 2011 12:58 PM (in response to Frustrated Dylan)


    Been working with Apple and finally have a resolution that worked here anyway.


    They traced the problem down to my /Applications/Installers/ folder where a previous version of an early Xcode installer had migrated from an old G5 as I migrated all apps having recently purchased a new iMac.


    I deleted that and another G5 installer and Xcode installed flawlessly via the AP store.


    That said I wouldn't recommend attempting to install Xcode from the AP Store without first...

    - Verifying that you have a recent TimeMachine backup.

    - Logging off all networked drives and connected drives--even flash drives.


    Mac Mini, Mac OS X (10.6.8), dual-boot Lion OS X 10.7.2


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.