Skip navigation

iPhone 4s, echo when using apple headset during a call

157811 Views 624 Replies Latest reply: Apr 1, 2014 10:08 AM by JAW Software RSS
  • brettstan Calculating status...

    I am on my 3rd 4s. I am with ATT and have the exact same problem. The echo is bad on my phone but even worse through my headphones. I have tryed replacing the Sim card and it didnt help. I was on the phone with Apple and ATT today for a total of 3 hours. Apple is aware of the problem and is working on it. My phone seems to have a slight echo at first but then slowly gets worse.

  • samchr Calculating status...

    Like everybody else, I've since found that the speaker on-off trick clears up the problem (temporarily, at least).  I did notice one other symptom of this that I wondered if enybody else had noticed:

    The last time this happened to me, I was in my car and I had the phone sitting in my console with my headset in. I started to hear the problem, so I grabbed the phone and switched to speaker.  That worked just fine. What I noticed, however, was that the phone felt unusually hot to the touch.  After using the phone on speaker for several minutes, it cooled off to the point where I wasn't concerned.  It also seemed like my battery had drained faster during the time where the phone had gotten hot (like a short circuit somewhere).

    Has anybody else noticed the hot phone / battery issue when they've had the headset problem?

    Maybe it's just me.

     

    Thanks,

    Sam

  • ms from toronto Calculating status...

    I haven't noticed the hot phone problem at all, and I would have noticed it, as I usually have the phone in my hand, or pocket when using it. Maybe it's just you...

  • biostatdude Calculating status...

    I have the exact same problem.
    When using Apple headset and mic, i hear some weird voice and other person hears echo. It usually appears after 5-10 minutes of talk. How do we fix this ? This is so annoying ?

  • Diana Phillips Calculating status...

    same problem!!!!!!!!!

  • iwashere33 Calculating status...

    yep, i have just had my iphone 4s 64gb replaced at the apple store but it appears to be the same problem. when i am using the headset during a voice call the echo starts anywhere between 5 and 10 mins. i hit the speaker button on and off but it comes back 10 mins later.

     

    this is starting to make me doubt apple products. 

     

     

    what's worse is the guy at the apple store had never heard of it. one quick google search later and i found this thread.

  • justin180 Calculating status...

    I have exactly the same!!!!! An echo when using the head set, it happens anything from 1 minute to about 15 minutes. The description given in these posts is exactly what I am experiencing. I did a restore via itunes last night and it is too early to say yet as I have only made 1 call this morning, but I managed 30 minutes without the echo reoccuring.

  • inspectorgadjet Calculating status...

    I also have the 64GB version on o2 in the UK and I have had the same problem. I am using brand new monster beats solo earphones.

  • has2289 Level 1 Level 1 (0 points)

    I'm not surprised the store hasn't hear of this issue, I don't think it is that wide spread. My sister and I got iPhone on launch day, and noticed the issue right away, googled it all weekend, but didn't find anything until earlier this week. If a serior tech specialist doesn't know about it, then, I don't know, Apple hasn't realized it's a common enough problem to add to their data base? I've got to think it's hardware, if it was software, most people would be experiencing it.

  • cbray12 Calculating status...

    I am in the UK and have this problem immediately when making a call using the headset. I have changed up 2 headsets and am now on my second iphone and it is happening. The guys in the main flagship store in London didnt know anything about it. I have a White 4S 64GB and am on the Vodafone network..

     

     

    FIX THIS APPLE... THIS IS A £700 PHONE AND DOESNT WORK AS A PHONE!!!!!!!

  • justin180 Level 1 Level 1 (0 points)

    I had to use the temporary fix of pressing the speaker phone every 5 or so minutes but since restoring the phone using itunes i have managed 1 hour and 9 minutes of calls without it happening once. Has anyone else tried a restore via itunes? ( Not saying I am confident it is cured but hopeful)

  • Fischi Calculating status...

    Same here. As far as I'm concerned, this only happens in the phone app. Using the headset with FaceTime or Voice Memos works fine and without putting any sound the mic captures on the headphones. So I'm not sure if it's hardware related or a software bug of the phone app. But since I've asked several friends to test this on their iPhone 4, it seems this is not an uncommon problem. I'm also hearing the clicking of the volume buttons on the remote and crackling sounds when touching the mic. Just as if all sound the mic captures is put straight to the headphones. I'm not sure if I should replace the phone for it seems that chances are high to receive yet another "broken" one.

  • CToddy Calculating status...

    Make that me too. Same echo issue.

1 2 3 4 ... 42 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (28)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.