Skip navigation

iTunes 10.5: Permission issue with the iTunes Library file...

10891 Views 51 Replies Latest reply: Oct 1, 2013 1:07 AM by mills70 RSS
1 2 3 4 Previous Next
Bob Grove Level 2 Level 2 (200 points)
Currently Being Moderated
Oct 16, 2011 9:26 PM

Ok all, I have a strange and potentially problematic issue. 

 

Background: Recently upgraded to thee latest 10.5 iTunes along with OSX 10.7.2 and iOS 5 on my iPhone.  My iTunes library is large - almost 300,000 songs, but have not had any issues until after the upgrade - except for the sluggishness of the progam (which apprears to be normal once you reach a certain point) as well as limitations with Genuis which I've not been able to resolve in any version.  I also have a fairly elaborate Playlist setup which I've refined over the past couple of years.  My iTunes library resides lookly in the default location under Music and the Media Folder sits on 3TB external.  Note that everything has worked fine up until now...

 

Anyway, this is just a quick background - and also to set the stage for any suggestions that might involve a 'random' rebuild of the iTunes library as it would involve a massive effort.

 

Problem:  Very intermittantly while playing music I will get an error pop up "Itunes library cannot be saved. A folder was specified instead of a file".  Otherwise everything appears working - playcounts are updated and reflected in my SmartPlaylist while I pay, lyrics seem to be added as I play (via TuneText), etc - and all syncs fine with the iPhone. 

 

Now if I shut down iTunes when this happens and try and reopen, I will get the error "The iTunes Application cannot be opened, an unknown error occured (13014)."  Now if I look at the permissions of the iTunes Library database it shows "You have unknown access".   Note the permissions of all other files are ok.

 

In the past to correct this I've pulled back an earlier version of the Library from my Time Machine which of course is not ideal. I've also set up a parallel library about a year ago which can open fine (I use this other one to stage the music before importing into my main one in that the main is too slow to edit anything major). 

 

So far I've tried Repairing Permissions and reinstalling the iTunes.app but the intermittant problem is not resolved.

MacBook Pro, Mac OS X (10.6.4)
  • whop77 Calculating status...

    Hi there,

     

    I had the exact same problem. Been trying to figure this one out for quite a while. But for me the following worked. Hope I can explain this clearly.

     

    I've created a new user account on my mac, gave it administrator permissions. Logged out from my own account and logged in with the new.

    After that I've accessed the iTunes folder of my own account. You can access this with the password of the new account.

    Then I sellected the iTunes folder, "cmd i" and gave my own and new account Read & Write access and gave "everyone" No Access. I sellected on the bottom of the information window "apply to enclosed items".

     

    Close the information window and log back in with your own account. Now you will have full access again.

    After that you can delete the new made account.

     

    Let me know if this works for you.

  • whop77 Level 1 Level 1 (10 points)

    I have no idea what Fetching permission is...

  • whop77 Level 1 Level 1 (10 points)

    Same here... No I have zipped my iTunes Music Library and stored it somewhere else. After that deleted iTunes (the programme) completely. Downloaded a new version. And installed that.

     

    Probably because I left the iTunes Library.itl file and the music in its original place, iTunes rebuild the library and made a new  iTunes Music Library.xml file. My iTunes was complete after installing it new including playcounts and playlists. While I thought this was stored in the xml file...

     

    So far everything is working fine again... but I will be carefull, lets see what happens the next few days...

     

    If this doensn't help I am going to re-install my MacBook, because there is something seriously wrong with my permissions.

  • whop77 Level 1 Level 1 (10 points)

    This is so frustrating. I've done the same. Only with 95K songs. Still a lot of work.

    Last weekend I've totally re-installed my MacBook. Only adding my music to iTunes. Without using previous iTunes library files. I know I lost all my playlists, playcounts etc. But it would be worth it if iTunes would work right after this. But no luck...

    After 7 songs or so, I got temp files and an error telling me that the iTunes file cannot me saved...

     

    I have no idea what to do next exept maybe wait for an update that will fix the problem.

    Just like you I've had this problem since my upgrade to 10.7.2

  • lemppari Calculating status...

    I have same problem. I really hope they fix this soon. I fixed this first by reinstalling iTunes. Then I discovered that just the file permissions on the itl file are somehow screwed. So I created a small shell script to run on terminal which fixes this by copying the itl file. I attach the source of the script here. It should be in the same folder as the itl file. Also cd that same folder before running the script. No guarantee, use at your own risk...

     

    #!/bin/bash

    DD=`date +%Y%m%d%H%M%S`

    FILENAME="iTunes Library.itl_"$DD

    #echo $FILENAME

    cp "iTunes Library.itl" "$FILENAME"

    if [ -f "$FILENAME" ]

      then

      rm "iTunes Library.itl"

      cp "$FILENAME" "iTunes Library.itl"

      echo "Done..."

    fi

  • whop77 Level 1 Level 1 (10 points)

    I did what you did, but after one day I had temp files again...

    Did you also get rid of the iTunes Library.itl file?

    I have put this file back after re-installing iTunes. Because this contains all of my playlists and playcounts.

    Maybe I shouldn't have done that...

     

    Is it still working for you?

  • Mitchell Group Level 1 Level 1 (5 points)

    I have the same exact problem .. A mirror image to what been going on with you... Happened after 10.7.2...

  • Mitchell Group Level 1 Level 1 (5 points)

    So I called applecare this morning and the problem is fixed... You are all correct it was permissions... First we went into terminal and

     

    bash-3.2# chflags nouchg /Volumes/UltraMax

    bash-3.2# chmod -N /Volumes/UltraMax

    bash-3.2# chmod ug+x /Volumes/UltraMax

     

    Ultramax is my external where 900gb of music is housed.

     

    Then we highlighted itunes folder -get info and made sure under sharing and permissions it said you can read and write, unlocked the folder and applied..

     

    then from finder- go to folder and type in        /Users/Shared/SC Info       take that folder and throw it in the trash

     

    restart,, all is good...

1 2 3 4 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.