Skip navigation

After installing security update 2011-006, X11 no longer starts.

4425 Views 13 Replies Latest reply: Feb 1, 2012 12:31 AM by do.simone RSS
jhowland Calculating status...
Currently Being Moderated
Oct 17, 2011 12:50 PM

The Safari 5.1.1 update was also installed:

 

X11 failure reason:

 

Dyld Error Message:

  Library not loaded: /usr/X11/lib/libfreetype.6.dylib

  Referenced from: /usr/X11/lib/libXfont.1.dylib

  Reason: Incompatible library version: libXfont.1.dylib requires version 13.0.0 or later, but libfreetype.6.dylib provides version 10.0.0

iMac, Mac OS X (10.6.8), Same problem on MacBook Pro
  • hongyan Calculating status...

    I have got exactly the same problem since a restart after the updates installed last night. Without X11, I simply can't work.

     

    A replacement XQuartz does not help me either .

     

    Anyone out there has figured out a solution? Many thanks in advance!

  • hongyan Level 1 Level 1 (0 points)

    "Problem report for X11" when trying to start X11 in detail:

     

    Process:         X11.bin [85351]

    Path:            /Applications/Utilities/X11.app/Contents/MacOS/X11

    Identifier:      org.x.X11

    Version:         ??? (???)

    Build Info:      X11server-850300~2

    Code Type:       X86-64 (Native)

    Parent Process:  launchd [115]

     

    Date/Time:       2011-10-18 17:00:04.889 +0200

    OS Version:      Mac OS X 10.6.8 (10K549)

    Report Version:  6

     

    Interval Since Last Report:          25470 sec

    Crashes Since Last Report:           182

    Per-App Crashes Since Last Report:   164

    Anonymous UUID:                      9BC10A64-1F58-4B85-9A9C-46BE0C17698E

     

    Exception Type:  EXC_BREAKPOINT (SIGTRAP)

    Exception Codes: 0x0000000000000002, 0x0000000000000000

    Crashed Thread:  0

     

    Dyld Error Message:

      Library not loaded: /usr/X11/lib/libfreetype.6.dylib

      Referenced from: /usr/X11/lib/libXfont.1.dylib

      Reason: Incompatible library version: libXfont.1.dylib requires version 13.0.0 or later, but libfreetype.6.dylib provides version 10.0.0

     

    Binary Images:

        0x7fff5fc00000 -     0x7fff5fc3bdef  dyld 132.1 (???) <472D950D-70F8-B810-A959-9184C2AA6C74> /usr/lib/dyld

     

    Model: MacBookPro7,1, BootROM MBP71.0039.B0B, 2 processors, Intel Core 2 Duo, 2.66 GHz, 4 GB, SMC 1.62f6

    Graphics: NVIDIA GeForce 320M, NVIDIA GeForce 320M, PCI, 256 MB

    Memory Module: global_name

    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8D), Broadcom BCM43xx 1.0 (5.10.131.42.4)

    Bluetooth: Version 2.4.5f3, 2 service, 12 devices, 1 incoming serial ports

    Network Service: Ethernet, Ethernet, en0

    ....

     

    thanks for any hints to this problem...

  • natchaug Calculating status...

    Until this is fixed upstream, as a temporary workaround is to use the freetype.6.dylib Universal Binary from Macports. It seems to work as a drop-in replacement, but no guarantees!

     

    1. Install Macports http://www.macports.org/install.php

    2. Add the option "+universal" at the end of /opt/local/etc/macports/variants.conf

         echo '+universal' >> /opt/local/etc/macports/variants.conf

    3. Use macports to install the latest freetype into /opt/local/lib with:

         sudo /opt/local/bin/port install freetype

    4. Save the old freetype version and drop in the new one:

         sudo mv /usr/X11/lib/libfreetype.6.dylib{,.save}

         sudo ln {/opt/local/lib,/usr/X11/lib}/libfreetype.6.dylib

     

    p.s. sorry about the Bash brace expansions, it's an annoying tic that I have to avoid typos.

  • hongyan Level 1 Level 1 (0 points)

    thanks a lot natchaug! It works for me with this fix.

     

    Cheers,

    Hongyan

  • danielsn Calculating status...

    Worked for me too.  I did it without doing the universal varient, and it still seems to work.  Is there any reason I would need the universal varient on 10.6?

     

    Daniel

  • natchaug Level 1 Level 1 (0 points)

    I think not, if you picked the right architecture. I was just playing it safe; the first version of freetype I tried (from Fink) was i386 not 64-bit, and failed. I presume X11 is the latter, which seems reasonable. Since the shipped version of the library was Universal, it seemed less of a headache to ask Macports to compile the same.

    Glad to know it works for you. Cheers, N.

  • davefromupnorth Calculating status...

    I had the same problem this morning.  Running the 10.6.8 Update Combo v1.1 (http://support.apple.com/kb/DL1399) forced the X11 library update on my machine.  Your mileage may vary.  

  • stackahumanoid Calculating status...

    Worked a treat! nice one, thanks for posting.

  • plmegalo Level 1 Level 1 (0 points)

    Reinstalling X11 from the DVD made it too. Check on you MacOs X install DVD, in System/Installation/Packages folder and just double click on the X11User.pkg file, then follow what's on screen.

    Hope it helps...

  • barninga Calculating status...

    i run into the same problem today.

     

    i solved reinstalling the previous version of /usr/X11/lib/libXfont.1.dylib i had on my system (easy task if you regularly backup your system a] with time machine, or b] with CCC configured to archive the files it updates on the backup disk).

     

    alternatively, replacing /usr/X11/lib/libfreetype.6.dylib with the previous version on the system worked for me. my system backed up libfreetype.6.dylib on jul, 29 2011 last time (and apparently it was not modified by the recent update which is causing the problem).

     

    i run an i5 imac; the weird thing is that on my other mac (an old i3) the problem did not appear. both machines run snow leopard and i updated them both a few days ago.

  • konstan Calculating status...

    natchaug you are the man! your hack saved my life

  • do.simone Calculating status...

    hi natchaug, very good fix! Nonetheless, after doing this, when I open some PDFs in Photoshop (JUST those I needed!!), the software exits with this error:

     

    Process:     Adobe Photoshop CS3 [689]
    Path:        /Applications/Adobe Photoshop CS3/Adobe Photoshop CS3.app/Contents/MacOS/Adobe Photoshop CS3
    Identifier:  com.adobe.Photoshop
    Version:     10.0.1 (10.0.1x20071012 [20071012.r.1644 2007/10/12:09:30:00 cutoff; r branch]) (10.0.1)
    Code Type:   X86 (Native)

    Parent Process:  launchd [304]

     

    Date/Time:   2012-02-01 09:14:15.272 +0100
    OS Version:  Mac OS X 10.6.8 (10K549)

    Report Version:  6

     

    Interval Since Last Report:      660190 sec
    Crashes Since Last Report:       3055

    Per-App Interval Since Last Report:  392339 sec

    Per-App Crashes Since Last Report:   7

    Anonymous UUID:                  EB416FBD-E369-41D5-AEBD-06C0F673DD8E

     

    Exception Type:  EXC_BAD_ACCESS (SIGSEGV)

    Exception Codes: KERN_PROTECTION_FAILURE at 0x00000000bf7ffffc

    Crashed Thread:  0  Dispatch queue: com.apple.main-thread

     

    Thread 0 Crashed:  Dispatch queue: com.apple.main-thread

    0   libSystem.B.dylib         0x910cab66 malloc_zone_malloc + 15
    1   libSystem.B.dylib         0x910c8c78 malloc + 50
    2   libstdc++.6.dylib         0x90cdc617 operator new(unsigned long) + 36
    3   com.adobe.PDFL            0x2ad2ea81 0x2a981000 + 3857025
    4   com.adobe.PDFL            0x2ad2eb1c 0x2a981000 + 3857180

     

     

    ... and so on. I think that having a working X11 is better than one single PDF opened in Photoshop (I could open with other programs), but I'd like to know how to restore the previous configuration.

     

    Thanks!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.