12 Replies Latest reply: Dec 11, 2011 2:25 AM by rnbehl
MacMan'95 Level 1 Level 1 (30 points)

My friend and my sister are running on iOS5, but instead of sending an iMessage, it sends a SMS? whats the problem


iPhone 4, iOS 4.3.3, iOS 5
  • 1. Re: iMessage not working properly
    MacMan'95 Level 1 Level 1 (30 points)

    ISSUE RESOLVED

  • 2. Re: iMessage not working properly
    cornographer Level 1 Level 1 (0 points)

    "ISSUE RESOLVED" doesn't help other people looking for a solution to the same problem

  • 3. Re: iMessage not working properly
    cgconnell Level 1 Level 1 (0 points)

    How did you resolve this issue? I'm having the same problem. As well as with other features such as the camera on the home/lock screen

  • 4. Re: iMessage not working properly
    j.minar Level 1 Level 1 (0 points)

    To get the camera button on the lock screen you have to press the home button twice while on the lock screen!

  • 5. Re: iMessage not working properly
    172kate Level 1 Level 1 (0 points)

    so what was the resolution?

  • 6. Re: iMessage not working properly
    naner19 Level 1 Level 1 (0 points)

    can you let us know how you resoloved this problem?

  • 7. Re: iMessage not working properly
    gmardre Level 1 Level 1 (5 points)

    How'd you fix it?.

  • 8. Re: iMessage not working properly
    anthonyfromstaines Level 1 Level 1 (10 points)

    I HAVE THE SOLUTION - It's worth shouting about!

    Upgraded 3 devices to IOS5. iphone 4, iPad 2 and iTouch (4th Gen). iMessage activates but during sending message it get stuck at 90%, Facetime stopped working on all 3 devices! All connected through a home network  No luck with any of the suggestions on the internet as to the cause of the problems.

    Took iphone and iTouch to work, connected on the open Wi-Fi there and hey presto both iMessage and Facetime started working!  What the ****?  Brought the devices home and they continued to work on my home network.  Still no luck with the iPad 2 sending to either of the other devices or connecting on Facetime.

    It struck me that there appeared to be an issue with the activation process ( even though it said activation successful at home).  The most likely cause is the DNS server not passing the data through correctly.

    I checked my DNS setting on my router and they were set to Open DNS (208.67.222.220), maybe using Google Public DNS would work?  But I didn’t need to mess with the router settings, the DNS on the apple device overrides the router setting. I set the Pad DNS (in Wi-Fi settings) to the Google DNS and straight away a mass of “stuck” test messages came through and I could also send iMessages.  Facetime also started working! Yippee! Success!  I reset the DNS back to its original value after I finished and it still works ok ( this is optional as Google DNS is good to use as default).

    So here’s the fix.... it’s so simple!!

    Settings > WiFi > find the active wifi network ( the one with the tick)

    Click the blue arrow> find the DNS entry ( 4th item down), note it’s value.

    In the DNS field – type in 8.8.8.8

    Click the “home button” and then try iMessage and Facetime.

    (it’s up to you if .want to set the DNS back to it’s old value)

  • 9. Re: iMessage not working properly
    chatton Level 1 Level 1 (0 points)

    Thank you, I have been wondering why the camera did not pop up.

  • 10. Re: iMessage not working properly
    terryfromprahran Level 1 Level 1 (0 points)

    I have reset all devices to the google dns and nothing. It does not work full stop end of question. Crappie needs to fix the product or withdraw it from the market. This is the software equivalent of the ford pinto.

  • 11. Re: iMessage not working properly
    maxtoro75 Level 1 Level 1 (0 points)

    Thanks Anthony now i've got my imessage and facetime working! Your advice has been resolutive!

  • 12. Re: iMessage not working properly
    rnbehl Level 1 Level 1 (0 points)

    Man... same problem as you had... with the message going through 90% and all... but the solution didnt work... i'll try a public wifi sometime today and see if that helps