Skip navigation

iPhone 4s, echo when using apple headset during a call

157935 Views 624 Replies Latest reply: Apr 1, 2014 10:08 AM by JAW Software RSS
  • richthebeard Calculating status...

    I have the same problem (iPhone 4s 32Gb on Vodafone in the UK). I've tried an old headset from my iPhone 3GS but it's giving me the same problem. Very annoying.

  • Johnt817 Calculating status...

    Same issue here with my 4s..cannot use any headphones when talking on the phone. I tried the speaker on/off trick and it did not work for me...granted I only tried it once.  I am adding to this thread in hopes that Apple will address it within a reasonable timeframe.

  • pseudomatic Calculating status...

    I have the same problem too. Temporary fix works for me, but we need a permanent solution to this - I'm driving when this happens, so performing the temporary fix could be dangerous.


    How do we find out if Apple have taken note of this and are working on a fix?


    Edit: iPhone 4S 32GB on O2 UK, just in case that matters...

  • r-oxo Calculating status...

    I have a 32gb 4S and am having this problem... The temp fix works, but isn't a great long term solution.


    My question is same as pseudomatic, how can we find out is Apple have registered this as a valid software problem and not a hardware issue?  I'm trying to avoid having my handset replaced as I can't be bothered with the hassle, however if it's a hardware issue then I have no choice.


    I'm sure Apple will typically take their time before committing to a yay or nay !!

  • has2289 Calculating status...

    How many of you have called Apple? In my case (and my sister's), it's been confirmed that it is a carrier issue, and something that they have to address (Rogers, in Toronto, ON). Apparently it only happens in specific pockets, and may or may not be what is happening to you. In my case, Apple engineers spent a number of hours yesterday diagnosing the issue, and have been (or will be) in contact with Rogers for them to resolve the issue. If you have had your iPhone 4S replaced, and are still experiencing the issue, it could well be what you are experiencing as well. Call Apple support, ask for a senior tech specialist.

  • D_4s Calculating status...

    Everyone I know who has a 4S is experiencing this extremely annoying issue you describe (AT&T).  No one other than the new Iphone 4S users are having this problem on the AT&T network.  I find it hard to believe that it is a network issue when people with the original IPhone 4 have no issues.  Has to be hardware!  Hoping Apple comes up with a fix or I will returning.  Not good for Apple stock but great for class action lawyers I fear.

  • vandergrift1968 Calculating status...

    I too am having the same problem. I have an iPhone 4s on AT&T. Today was the first day that I used the earbuds for hands free calling and that is when the echoing began. As others have stated, it didn't start echoing until 5 to 10 minutes into the conversation... then it was unbelievably annoying. I too do not believe that it is a carrier issue (since it seems to be happening on multiple carriers)... here's to hoping that it is simply a software issue.

  • oconstantine Calculating status...

    does the speakerphone fix work when using the earphones? i hope so. will try it on the next call i make/take.


    Same problem has been happening to me on every call I've made since getting the phone Sometimes the buzzy echo starts a minute in to a call, sometimes after 5 or 10 minutes.


    Loud underwater echo-ey noise and the person i'm calling complains that they can hear their own voice being echoed back to them but with a bit of a satellite delay which throws them off their speech.


    I'm on O2, iPhone 4S 64GB. Glad I found this thread, i couldn't work out what was happening but it's obviously a phone issue as it's affecting users across network from what i've read. hopefully there'll be a software fix for this asap, i wonder if it's the noise-cancelling widget that isn't programmed right?


    Please apple, fix it. A phone i can't make calls from isn't going to prove much use.

  • partycaptain Calculating status...

    Same problem here.  I got the 4S on Friday and the echo problem has happened ever since.  I have tried the 4S headset as well as my old iPhone 4 headset and some Skull Candy ones. 


    Apple swapped out my phone on Wednesday and it did not change anything. 

    Went back in today and they said it was a carrier issue (AT&T).  I even pointed out this thread. 


    When I called AT&T, i made sure to use the headset so they can see this bug in action.  AT&T official response is just deal with it (I'm actually quoting here). 


    Not sure if the phone is a dog or AT&T is, but I'm pretty fed-up wtih it

  • 12thredman Calculating status...

    Same here guys, hoping this will get fixed ASAP. On Vodafone UK with a 64GB 4s.


    Haven't tried the speaker resolution yet, removing the headset seems to work but is very annoying.


    I've also experienced an issue when dialing out with the headset connected, the phone switches to speaker and the other person can't hear me. Tried removing the headset, muting, turning speaker on/off nothing. Have to end the call and reboot the phone because if I make another call I get the same issue regardless then if the headset is connected or not. I've seen others complain about this also so I'm thinking they might be related. In both cases the carrier signal drops dramatically.


    Please solve this APPLE....

  • Diana Phillips Level 1 Level 1 (100 points)

    Forgot to mention....just for the record, I am on ATT in Northern California.

    bought 2 phones and occurs on both.....seems to be worse on one of the phones

  • Simon UK Level 1 Level 1 (0 points)

    +1 We need a fix apple.

  • rickyufv Level 1 Level 1 (0 points)

    Same here. It exactly initiates after 5-7 minutes, the other person will hear his/her own voice(me on headset). This is annoying. Any soloution yet? I will try the temperory fix, toggle the speakerphone for sure, but I guess I will wait untill there is an official announcement for the issue?


    Fido, Black 32GB iPhon4S

  • ThomasP72 Calculating status...

    Same Problem! Got a new iPhone 4s via AppleCare. The new one have the same problem!!!

    @Apple: please fix it !!!

  • SMUzta Calculating status...

    So, Apple seems to thing this is a carrier problem.  From these posts, we already know that this happens on the AT&T network.  Anywone posting on here using a different network?  If so, please post that so Apple will realize it's NOT the network!!!

1 2 3 4 5 ... 42 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (28)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.