6 Replies Latest reply: Oct 24, 2011 6:27 AM by Nameless68
hjones Level 1 Level 1 (0 points)

I have been trying to use FCPX for a couple of weeks now, but haven't been able to. I constantly get green frames/artifacts and dropped frames during playback AND export regardless of using optimixed or proxy media. I am importing mp4 quicktime files, in case that is important.

 

I am using:

 

MBP (mid 2009)

OSX 10.6.8

Intel Core 2 Duo @ 2.26 ghz

2 gb ram

Nvdidia GeForce 9400M w/256 vram

 

I know that it is reccommended I have 4 gb ram, but I meet the minimum requirements and cannot even use the program! Would upgrading to 4-8gb ram resolve this issue? Or is my processor the culprit?

 

Any help is greatly appreciated.


Final Cut Pro X, Mac OS X (10.6.8)
  • 1. Re: FCPX green frames/artifacts and dropped frames
    still_learning Level 3 Level 3 (785 points)

    You DEFINITELY need to upgrade your memory to 8GB, etc.  Otherwise you will not likely be able to get much real work done at all ... but ... that is likely not exactly the problem you are experiencing now .  Since you are talking about bringing in MP4 files, I am thinking you did not get them from a tape-based camcorder.  If you did, then they were converted to MP4 afterwards somewhere.  Can you play the MP4 files in Quicktime and not see any green screens?  If so then have you tried using the FCP X File/Import ... Files command to bring them into FCP X?  I have used this with MP4 files without a problem.  If Quicktime can play them okay without green frames, and FCP X cannot then the problem does seem to be in FCP X.  Are your preferences set to use optimized media? If so then FCP X will convert the files to ProRes and the timeline playback should be okay.  There are other "green frames" discussions here that you could also reference.  These are just some thoughts. 

  • 2. Re: FCPX green frames/artifacts and dropped frames
    hafken Level 4 Level 4 (1,225 points)

    All your specs are the definition of the minimum, so you can't expect anything but less than average performance.

     

    If you are getting green frames even with proxy media (and you remembered to use the proxy media by setting the preference in playback preferences), then I would try transcoding your original media outside of FCPX (to prores or prores LT) and then ingest that as your starting point.

  • 3. Re: FCPX green frames/artifacts and dropped frames
    hjones Level 1 Level 1 (0 points)

    @still learning I have a hauppauge hd pvr that I use to capture gameplay from my xbox using Eye TV. When exporting from Eye TV I choose the native h.264/mp4. I have no issues playing these files in Quicktime prior to importing into FCPX. I have toggeled with my preferneces and tested both optimized and proxy media to both transcoding on import or importing and then transcoding, neither process seemed to make a difference. I've checked out the other green frame discussion but have yet to find any one with a situation similar to mine.

     

    @hafken what would you reccomend for transcoding prior to import? MPEG Streamclip?

  • 4. Re: FCPX green frames/artifacts and dropped frames
    hafken Level 4 Level 4 (1,225 points)

    MPEG Streamclip should work fine. I'd definitely give that a try.

     

    After transcoding confirm you can play without problems in quicktime before import to FCPX.

  • 5. Re: FCPX green frames/artifacts and dropped frames
    hjones Level 1 Level 1 (0 points)

    While I hear MPEG Streamclip can do some great stuff, it turned my 450 mb mp4 into an 8 gb prores lt. Obviously that isn't going to help.

     

    I did go back to my EyeTv export settings and decided to give the Quicktime movie H.264 export a try. It worked like a charm, no green artifacts and no frame dropping. I suppose the H.264 native file I was importing was just giving FCPX troubles because it wasn't encoded to its liking.

     

    Thanks for all the help.

  • 6. Re: FCPX green frames/artifacts and dropped frames
    Nameless68 Level 1 Level 1 (10 points)

    I had the same problem as well. What I firgured out doing was using toast 10 to make a blueray disc with out a menu. Just drop the M2TS files in toast, it should not re-encode the files and just make the disc. You can save the disc as a file and just mount the disc. I found also the disc type at the botton should be set to DVD or else Final Cut does not seem to see it. Then just import into FCPX. You can then make the proxy files for editing and then make the final version with the orignals. I do not get the green frames anymore when I do it this way.

     

    Just set the HDPVR Capture not to repackage the files if you try this way because you need the .M2TS files.