Skip navigation

iCloud and my 3G phone

186937 Views 199 Replies Latest reply: Mar 2, 2014 9:57 AM by rosafrombel RSS
  • Éamonn Ó Catháin Calculating status...
    Currently Being Moderated
    Oct 24, 2011 8:21 AM (in response to t0xicdin0saur)

    Except that is not the model under discussion.

  • mystrangeworld Calculating status...
    Currently Being Moderated
    Oct 25, 2011 1:54 AM (in response to Éamonn Ó Catháin)

    thank you

     

    got it working with my calendar as caldav

     

    but the contacts do not sync i.e. in the preferences, the cardav gets the servers but does not appear in my contacts

     

    best,

  • annac1 Calculating status...
    Currently Being Moderated
    Oct 25, 2011 10:21 AM (in response to David J. Downs)

    Hi,

     

     

    I've been trying to follow the instructions on this thread. I managed to get Mail and the Calendars to sync fine on my 3G,  but I've got a problem with the Contacts. This seems like the same problem you had, so I was wondering if you'd managed to solve it?

     

     

    I've enabled the iCloud account in the Address book on my Mac. Also iCloud is set as the default account. The contacts are all there on my Mac and on the iCloud. They sync fine between my Mac and my iCloud.

     

     

    But I  have no contacts at all on my phone! I can't even import them by syncing from iTunes. Nothing appears when I sync the phone.

     

     

    I configured the CardDAV account as follows

    Server : p02-caldav.icloud.com

    User Name : MM address

    Password : MM password

    Description : anything

     

     

    I found what I think is the full server address in Library/Application Support/AddressBook/Sourses/.…./Configuration.plist on my Mac..

     

     

    Its something like - https://"myusername"%40me.com@p02-contacts.icloud.com:"3numbers"/"8numbers"/carddavhome/card/"8letters&numbers"-"4letters&numbers"-"4 letters"-"4letters&numbers"-"12letters&numbers".vcf

     

     

    The bits between the quotations marks I've changed.

     

     

    But I can't find any way to put this html address into the configuration settings on the iPhone - as the advanced settings for the CarDav account don't have that option.

     

     

    Do you or anyone else have any suggestions? Thanks...

  • okenter Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 25, 2011 10:29 AM (in response to annac1)

    The server for your contacts is "carddav.icloud.com" not "caldav". If the server accepts your login, it will add the "p02" or "p01" or what ever.

    You can also enter the full server address in this field.

  • annac1 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 25, 2011 10:53 AM (in response to okenter)

    Thanks for the quick reply.

     

    I tried "carddav.icloud.com" a few times, but the server kept refusing me.

     

    Also I've been trying "contacts.icloud.com" For this, the server accepts me, then changes to "p02-contacts.icloud.com" but I still have no contacts at all on the iPhone...

     

    My advanced settings for the CardDAV account configuration have only two options - Use SSL, which is switched on.. and the port, which  is 443.

  • okenter Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 25, 2011 11:11 AM (in response to annac1)

    Go to your advanced setting for your calendar. Copy the long address from there and then go to the contacts settings and paste the long calendar server address into the server box in the contacts settings. Locate the part in the long address that says "caldav" and change it to "contacts". That should do it. Also, in your address book, back out to the groups page and make sure you have "icloud contacts" sellected.

  • annac1 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 25, 2011 11:30 AM (in response to okenter)

    I tried that, but no luck unfortunately. I cut and past the address from the caldav account advanced settings. I changed the first part to "contacts.icloud.com". Again it accepts me and the whole address changes to p02-contacts.icloud.com.

     

    Also, I made sure that "All Contacts" under "iCloud" in the Address Book on my Mac were highlighted blue.

     

     

    But there are still no contacts on the iPhone. And also there is no way to add contacts. When I first open Contacts on the iPhone there is a plus sign in the top right corner, but I can't press it. Then Contacts refreshes, the plus sign vanishes and all that's left is "All Contacts" in the gray bar at the top, then "No contacts" in the blank space on the main page.

  • okenter Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 25, 2011 11:44 AM (in response to annac1)

    Did you copy the long address from the advanced settings screen in the calendar settings, or the short address on the first screen?

    If you haven't already, you should copy the long address, http://...... on the 2nd page in the calendar settings and paste it to the server box on the first page of the contacts settings. Then change caldav to contacts as mentioned above.

  • annac1 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 25, 2011 11:56 AM (in response to okenter)

    I'm copying the long address from advanced settings of the caldav account. But when I press "Done" in the carddav account, the address changes very quickly to "p02-contacts.icloud.com", even before it is verified... so I don't know if its even registering as being the longer address.

  • okenter Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 25, 2011 12:04 PM (in response to annac1)

    Hmm... and still no contacts are showing up in your address book? I wish I knew something more to tell you but anything else would just be guessing on my part. Sorry it didn't work.

  • annac1 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 25, 2011 12:21 PM (in response to okenter)

    Thanks anyway.. I'll keep searching... I have now managed to add a few contacts manually to the iPhone, so that's a slight improvement..

  • annac1 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 25, 2011 1:06 PM (in response to okenter)

    Ok so its working now - Yay.... Thanks for the help.

     

    I think my problem was that I wasn't deleting each CardDav account as I tried different addresses. I was just cutting and pasting the long address into an existing configuration.

     

    So just now I deleted my previous CardDav Account, restarted the phone, copied the long address out of the CalDav Account Advanced Settings, pasted the long address into Notes, edited it to make it "contacts" not "caldav", then pasted it into the CardDav account  - success!! Thanks alot!!

  • mattek Calculating status...
    Currently Being Moderated
    Oct 26, 2011 4:56 AM (in response to annac1)

    You guys rock! Had exactly same problem with lack of Contacts syncing. Now it works

  • Éamonn Ó Catháin Level 1 Level 1 (75 points)
    Currently Being Moderated
    Oct 26, 2011 7:55 AM (in response to anto111ka)

    Finally got this to work (partially) today thanks to the information here:

     

    http://pwnmyi.com/how-to-setup-icloud-email-contacts-calendar-in-your-own-client /

     

    None of the methods above worked for me, perhaps because I had not set iCloud Mail up as an IMAP account (there was no problem getting it working as a simple mail account). I followed the above settings and got Mail working as IMAP and then used the servers as described above. While it logged in, it did not work. I changed P03 to 04 in Contacts and bingo! -all my contacts came in.

     

    At time of writing, I cannot get Calenders to work but this is far less important to me than an empty address book. I have tried p04 but it reverts to p01 each time and no sync occurs.

     

    Incidentally I removed MobileMe "Find My iPhone" first, I have no idea if that impacts upon it in any way. I shall re-instate it now.

  • sebofromamsterdam Calculating status...
    Currently Being Moderated
    Oct 28, 2011 2:52 AM (in response to anto111ka)

    I can tell you I have been busy for while, but finally I succeeded. Use the caldav for calendar and contacts for adressbook. Then be sure that with advanced settings SSL is switched on. I tried first with p01, p02 etc. and it kept on saying not possible, but I think I choose to switch off SSL somewhere. Hope this will help you all.

1 ... 4 5 6 7 8 ... 14 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (21)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.