Skip navigation

My iMessage still says "Waiting for activation..."

967394 Views 518 Replies Latest reply: Mar 19, 2014 9:23 AM by iscast RSS Branched to a new discussion.
  • jaszenjames Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 20, 2011 2:19 AM (in response to mrlee121)

    I just resolved my issue in activation of FaceTime and iMessage. Please follow the steps:

    1. Turn off the iMessage and FaceTime.

    2. If your tel # are not yet addeded to your contact list please do so. Make sure that you select iPhone not mobile.

    3. Change your My Info(Settings>Mail,Contacts,Calendar>My Info) by selecting your created contact.

    4. Go to Settings>Phone. Check if your number is reflected in My Number. Then turn on your Show My Caller ID and also the International Assist.

    5. Make sure that your apple ID are login in Store under Settings.

    6. Once your done, close all apps using the double tapping of home button.

    7. Hard reset your iPhone.

    8. After your iPhone boot up. Check if you have Internet(wifi) connection

    9. Then turn on your FaceTime then iMessage. Activate by logging in your apple ID. Wait a few seconds.

    10. Done and enjoy the features of IOS5.

     

    Hope it will help you.

  • janno1120 Calculating status...

    Your steps worked! Thanks!

  • yehia Level 1 Level 1 (5 points)

    Not with me.. Still the same problem

  • rcvelasquez Calculating status...
    Currently Being Moderated
    Oct 20, 2011 5:29 PM (in response to mattcabb)

    mattcabb!

     

    regarding the imessage "waiting for activation thing", I tried all the advises but nothing works, my imessage setting "Receive at" email only no contact number. How can I set my contact number in the imessage setting? when I check my phone setting "my contact" its there but how come it does not appear in my imessage setting?

    Next problem which i thing is related to this is, when i send a message to my friends it has a separate message trail with that using a network and that using imessage. Compared to them, their sms whether send thru imessage or via network its integrated in just one message trail meaning its not separated. PLEASE HELP!!!!!!

  • rcvelasquez Level 1 Level 1 (0 points)

    DID NOT WORK FOR ME! ANY OTHER ADVISE? THANKS

  • christapor Calculating status...

    same problem here waiting for activation both the imessage and facetime

    but the problem is that i took my friends sim from other carrier it works whithin a min

    my network is MTN

    and my friend's is Syriatel

  • rcvelasquez Level 1 Level 1 (0 points)

    any news from apple on how to fix our problem with imessage????

  • adnanfarooqui Level 1 Level 1 (0 points)

    I stumbled upon a website through Google and they have mentioned methods that worked for me and a couple of my friends. Fix my FaceTime waiting for activation message on iPhone 4S in a jiffy. this is the link.

  • Philippe d\'Al Level 1 Level 1 (0 points)

    Guys! I found the solution, well, I didn't, Christophe Lemaire found it and posted this in another thread I was following for this, but I'll past it here

     

    To solve the problem go to Settings -> General -> Restrictions, and make sure you "allow changes" to accounts and also enable the FaceTime app to work.

    Return to Settings -> FaceTime, and set it to 0 and back to 1.

    That should do the trick.

     

    This is what he said to do, worked almost instantly for my iMessage, my facetime took a little bit longer but activated too!

     

    I turned of restrictions again afterwards.. iMessage still works fine with my number now ( and thus is fully activated ) !

  • bakir Calculating status...

    Yes! and that was easy :) thank you very much, it instantly worked out for imessage on my 3GS..

  • jpatrickn Level 1 Level 1 (5 points)

    Still not working for me!!!!!! Frustrating!!

  • Philippe d\'Al Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 25, 2011 8:47 AM (in response to jpatrickn)

    try a hard reset after making the changes

  • jpatrickn Level 1 Level 1 (5 points)

    Yes, I already tried it with a hard reset after making the changes.

     

    Still nothing,...

  • Roberto Avanzi Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 26, 2011 1:17 AM (in response to chakkochi)

    Please do not do this to yourself. It is just annoying - and you cannot do that on the fly!

  • soulfan Calculating status...

    I have been having this problem myself, but have since corrected it. Here’s what I did in detailed explanation...

     

    BACKGROUND ON MY SITUATION:

     

    Phone: iPhone 3GS

    Software: iOS 5 (upgraded from iOS 4 on October 26, 2011)

    Facetime: N/A -- I still have the 3GS and it does not have Facetime

    Misc: Still using MobileMe and not iCloud

     

    I got the “Waiting for Activation” message under my iMessage settings. As a result, I could send/receive iMessages under my Apple ID email addresses (I have two Apple IDs), but not under my phone number. I could also *send* regular SMS texts. I could not, however, *receive* SMS texts.

     

    The only way I could get the SMS texts I was missing was to power the phone off/on and they would populate as soon as the phone was back on. After that if I tried to send more SMS messages, I got a box saying my SMS mailbox was full and texts needed to be deleted.

     

    So, my friends had three message threads from me this morning -- one from the old SMS texts in my phone (pre-iOS 5), another from Apple ID #1, and a third from Apple ID #2. Very confusing for them!

     

    ----

     

    HERE’S THE PROBLEM:

     

    The iPhone has too many options to communicate with other Apple products in iMessage. I had to limit the options in order to solve the problem.

     

    In my case, my iPhone could choose between two Apple ID email addresses to send iMessages. However, it wouldn’t let me enter my phone number as a possible contact point. THIS IS THE PROBLEM. Because iMessage would not recognize my phone number, it would not allow me to send/receive SMS messages freely. It only allowed email-based iMessages because they don’t require a phone number.

     

    I would use email addresses only if you’re using a Mac or iPad on iMessage. Email is not needed for an iPhone unless you specifically want to give out your email address.

     

    ----

     

    HERE ARE THE SOLUTIONS THAT WHEN **USED TOGETHER** WORKED FOR ME:

     

    #1 -- Clean out your SMS mailbox. Your phone may give you a prompt telling you to do this. Other times it won’t. But, clear your text inbox down to a reasonable level. Doesn’t have to be empty at all, but definitely pitch old messages that you know you don’t need. I think the iOS 5 platform is taking up more room, hence the need to make sure your SMS inbox is at a reasonable level. This is not a mandatory step, unless you’re a heavy texter like me.

     

    #2 -- Go to http://appleid.apple.com if you have an already-established Apple ID. Login to your account. On the left side bar go to Phone Numbers. Clear out any and all info under Daytime and Evening Phone Numbers. (This may be part of the iMessage problem, especially if you don’t have a mobile number entered already). Enter your current mobile number for the iPhone you will use for iMessage. Click Save Changes and sign out. Repeat step #2 for every separate Apple ID account you have.

     

    #3 -- Power your phone completely off by holding the small rectangular button on top until the red slider appears. Slide the red slider to the right to power off. Wait 10 or so seconds once it is powered off and turn it back on.

     

    #4 -- Go to Settings > Messages > Receive At. At this point, you should see your phone number and/or email addresses listed under Receive At. Turn OFF the Apple ID so that no email addresses are visible and iMessage will not be able to use them. (I don’t remember exactly how this part looks as my screen is different now because it’s working). Your phone number should now be the only contact under Receive At.

     

    #5 -- Test it yourself. If you’re able to send/receive an iMessage to yourself using your phone number (not email address), you’re on the right track. Have a non-iPhone user text you to make sure your SMS is working. Send iMessages to an outside contact or two. They should be able to see your messages under whatever name they have saved for you in their phones. They should be receiving your iMessages as if they were normal SMS texts with the exception of the now-blue dialog boxes.

     

    ----

     

    Hope this works for you!

1 ... 3 4 5 6 7 ... 35 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (13)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.