Skip navigation

Iphoto 09 8.1.2 stopped showing photos in full screen

897 Views 14 Replies Latest reply: Oct 28, 2011 10:27 AM by jgoerke RSS
severinodujour Calculating status...
Currently Being Moderated
Jun 26, 2011 9:58 AM

I have the above-mentioned version on both my MAC and my MACBookPro.  I have never had a problem with either.  Suddenly, the version on my MACBookPro (which is using OS X 10.6.8) stopped showing my pics in the full screen mode.  All I get, when double clicking a thumbnail, all of which show up great, is a black screen.  I can see the thumbnails above the black screen, and I can even play the pics in a slide-show.

 

I have tried everything from rebuilding the library to creating a new library, to completely deleting both IPhoto Application and Library, going to my MAC, copying that version of IPhoto and it's library onto a disc and loading that onto my Pro.  NOTHING WORKS!  I have tried everything I've seen on the web, You-Tube, and of course the Apple Support, which is usually the worst of the lot in terms of supplying information.  I have searched Google to no avail.  Apple seems to all but have foresaken this version, in favor of it's new ILife program, IPhoto 11, which I see is also having major difficulties. 

 

Is there no one out there who has the slightest idea why this program, only on my Pro, is doing this?  I just looked at my pics again on my MAC and that sucker is working like a charm.  I don't even see a good IPhoto alternative out there to download.

 

HELP!

iPhoto '08, Mac OS X (10.6.7), Using iPhoto '09 v8.1.2 &OS 10.6.8
  • Terence Devlin Level 10 Level 10 (121,630 points)

    There are several possible causes for the Black Screen issue

     

    1. Permissions in the Library: Back Up and try rebuild the library: hold down the command and option (or alt) keys while launching iPhoto. Use the resulting dialogue to rebuild. Include the option to check and repair permissions.

     

    2. Minor Database corruption: Back Up and try rebuild the library: hold down the command and option (or alt) keys while launching iPhoto. Use the resulting dialogue to rebuild.

     

    3. A Damaged Photo: Select one of the affected photos in the iPhoto Window and right click on it. From the resulting menu select 'Show File (or 'Show Original File' if that's available). Will the file open in Preview? If not then the file is damaged. Time to restore from your back up.

     

    4. A corrupted iPhoto Cache: Trash the com.apple.iPhoto folder from HD/Users/Your Name/Library/ Caches...

     

    5. A corrupted preference file: Trash the com.apple.iPhoto.plist file from the HD/Users/ Your Name / library / preferences folder. (Remember you'll need to reset your User options afterwards. These include minor settings like the window colour and so on. Note: If you've moved your library you'll need to point iPhoto at it again.)

     

    If none of these help:

     

    As a Test:

     

    Hold down the option (or alt) key key and launch iPhoto. From the resulting menu select 'Create Library'

     

    Import a few pics into this new, blank library. Is the Problem repeated there?

  • Terence Devlin Level 10 Level 10 (121,630 points)

    Ignore the content of that Data folder. It does not contain your photos, only the thumbnails that you see in the iPhoto Window.

     

    In the iPhoto Window:

     

    Select one of the affected photos in the iPhoto Window and right click on it. From the resulting menu select 'Show File (or 'Show Original File' if that's available). A Finder Window +should+ open with the file selected. Does it?

     

    If it does, can you view that photo with Preview?

     

    Regards

     

     

    TD

  • Terence Devlin Level 10 Level 10 (121,630 points)

    Another test:

     

    Create a new account (systempreferences -> accounts) and see if the problem is repeated there. If it is, then a re-install of the app might be indicated. If it's not, then it's likely the app is okay and the problem is something in the main account.

     

     

    Regards

     

     

    TD

  • Terence Devlin Level 10 Level 10 (121,630 points)

    To re-install iPhoto

     

    1. Put the iPhoto.app in the trash (Drag it from your Applications Folder to the trash)

     

    2a: On 10.5:  Go to HD/Library/Receipts and remove any pkg file there with iPhoto in the name.

     

    2b: On 10.6: Those receipts may be found as follows:  In the Finder use the Go menu and select Go To Folder. In the resulting window type

     

    /var/db/receipts/

     

    A Finder Window will open at that location and you can remove the iPhoto pkg files.

     

    3. Re-install.

     

    If you purchased an iLife Disk, then iPhoto is on it.

     

    If iPhoto was installed on your Mac when you go it then it’s on the System Restore disks that came with your Mac. Insert the first one and opt to ‘Install Bundled Applications Only.

     

    In the resulting installer window, choose to do a Custom Install. That way you can just install iPhoto

     

    If you purchased it on the App Store you can find it in your Purchases List.

  • Terence Devlin Level 10 Level 10 (121,630 points)

    My guess is that there is an issue with your QuickTime installation and would suggest you re-install the OS.

     

    Regards

     

     

    TD

  • Terence Devlin Level 10 Level 10 (121,630 points)

    You're confusing Quicktime Player with QuickTime. QuickTime is the technology that drives all the media on your Mac - video, music, photos etc.

     

    http://docs.info.apple.com/article.html?path=Mac/10.6/en/8177.html

     

    Has details on re-installing the OS

     

    Regards

     

     

    TD

  • jgoerke Level 1 Level 1 (0 points)

    Did you ever get this resolved?  I think you went through a herculean effort to try all possible resolutions.  I commend you for your dilligence, but I am just not up for trying all of the steps you had to go through and still not have things fixed.

     

    I was having the same problem on a MacBook Pro, OS: 10.6.8, iPhoto 09 8.1.2.  Whenever I tried to edit a photo or have it display in fullscreen I'd see an all black screen.  This was true for all photos in my library even older ones which had previously worked fine (for a couple years). 

     

    I did the same cruise through the online forum and googled the universe to see if I could find a resolution but they all seemed to amount to: reinstall this, reinstall that, rebuild this...  But I didn't really get why it would resolve the issue, and what exactly had happened in the first place.   So, here's what ended up working for me (so far anyway):

     

    I tried to remember when this first started happening to me, it was a couple days ago.  Then I went back to look at the pictures in my library, there was one photo from a couple days ago that I'd edited that was all black. Hmmmm...  I right-clicked and chose "revert to original".  I was then able to view that photo in fullscreen mode, AND I was able to view ALL my photos in fullscreen!  Now what exactly was bad about this one picture and how it had corrupted iPhoto's ability to edit and view ANY photo in fullscreen I don't know.  But this was a MUCH easier resolution then re-installing the universe.

     

    So if you're still having the problem, see if any of your photos look completely black in their thumbnail view and try reverting to original on that photo.

     

    Good luck!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.