Skip navigation

Garageband could not be opened

2011 Views 6 Replies Latest reply: Oct 13, 2012 11:41 AM by Donna Potter1 RSS
arebutnot Calculating status...
Currently Being Moderated
Oct 29, 2011 2:44 AM

When I try to open existing files or new files, I got the message that the file could not be opened. What do I do? I need to work with old and new files...

GarageBand (Mac) '11, Mac OS X (10.7.2)
  • MattiMattMatt Level 4 Level 4 (2,420 points)
    Currently Being Moderated
    Oct 29, 2011 7:00 AM (in response to arebutnot)

    Are you opening up a new file with an older version of GB?


    GB is backwards compatible but not forwards compatibile.


    Is your GB '11 installation clean? You could always try a *complete* uninstall and reinstall to make sure.


    If all else fails, you could excavate the audio files from your GB songs (control click the file in the finder, choose, show package contents and go to the media folder, and then add those files to a new, working GB file).

  • MattiMattMatt Level 4 Level 4 (2,420 points)
    Currently Being Moderated
    Oct 30, 2011 5:58 AM (in response to arebutnot)

    arebutnot wrote:


    How do I do a *complete* uninstall.


    • trash GB receipts (at the hard drive level)

    • trash all GB preferences (at the user level)

    • trash your Caches Folder (at the user level, it will grow back)

    • trash the GB application

  • richb330 Calculating status...
    Currently Being Moderated
    Nov 8, 2011 3:43 PM (in response to arebutnot)

    I had this problem.  Check the permissions for your home directory.  Mine said 'read only', (not sure why as I seemed to be able to write to it as well).  I logged in as another admin user and checked the user directory permissions (HD/Users/[UserName]).  It showed my original user account had only read access to the directory. I changed this to 'read write', switched back to my original logon and Garageband worked straight away.


    I used migration assistant and this seems to have messed up some of the permissions on the user directory.


    Hope this helps!

  • ahobden Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 25, 2011 5:31 AM (in response to richb330)

    Boom ! Thank you Richb330, worked a treat.

  • Donna Potter1 Calculating status...
    Currently Being Moderated
    Oct 13, 2012 11:41 AM (in response to richb330)

    I used this fix and it worked for me as well.  Thanks a million for posting.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.