Skip navigation

BTServer causing high CPU utilization

23057 Views 35 Replies Latest reply: Mar 23, 2012 9:25 AM by GamePlayInc RSS
  • ipodishima Calculating status...
    Currently Being Moderated
    Oct 16, 2011 11:42 AM (in response to alexfrombrooklyn)

    Same problem here with the GM version, when waking up. Will try the final release.

    But you just have to use activity monitor and kill BTServer process. This works for me !

  • supertv Calculating status...
    Currently Being Moderated
    Oct 17, 2011 8:46 PM (in response to Ryan Homer)

    Same problem here on xcode 4.2 w/ iOS5 running on 10.6.8.

    It works if I kill the process.

    But the problem is that it keeps coming back.

     

     

    Does anyone know how to disable this annoying BTServer daemon ?

  • ruugfromsan francisco Calculating status...
    Currently Being Moderated
    Oct 19, 2011 6:32 AM (in response to Ryan Homer)

    I have been having the BTServer problem for some time now as well. It did not go away with the new XCode (4C199). I'm running OS X 10.6.8

     

    I can kill it, but it comes back right away. XCode is not even running. (When I 1st read this thread a month ago I could kill BTServer and it would not come back right away...I think it came back when I launched XCode and iPad simulator, but I'm not sure because I did not pay as much attention back then since it seemed to work and I figured the problem would go away when the new XCode came out.)

  • creativemessdev Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 25, 2011 9:09 AM (in response to Ryan Homer)

    Same problem as everyone else - running Xcode 4.2 Master. I just submitted a bug report to Apple and referenced this discussion.

  • ankhansen Calculating status...
    Currently Being Moderated
    Oct 26, 2011 11:56 PM (in response to creativemessdev)

    Hi Creative MessDev

     

    I have never submitted bugs to Apple - do they have a public interface to their bugs so we can follow the state of the bug report?

     

    I am experincing the same on a MacBook Pro with Snow Leopard and Xcode 4.2 (and MonoTouch if at all important).

     

    Everytime my Mac goes to sleep/standby and maybe sometimes in between, the Activity Monitor shows approx 200% cpu usage for BT Server - and the fans are going crazy. (Which in this case is not a good thing)

     

    Very annyoing, and problably not good for hardware to reach max temperature several times a day.

     

    So I am very keen on finding a solution to this, and thus following the state of the bug or attach myself to it to bumb it a bit in priority.

  • supertv Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 27, 2011 8:40 AM (in response to supertv)

    I finally figured out how to disable it.

    sudo edit /DevIos5//Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator5.0. sdk/System/Library/LaunchDaemons/com.apple.BTServer.plist

     

    There is a 'disabled' key set to false by default.

    Setting it true will prevent BTServer from being started.

     

    Hope it helps,

  • creativemessdev Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 27, 2011 7:40 PM (in response to Ryan Homer)

    You can submit a bug to Apple at https://bugreport.apple.com. Unfortunately there is no way to follow it publicly but I will post an update as soon as I hear something.

     

    Thanks for the tip - I'll give it a try.

  • kozholio Calculating status...
    Currently Being Moderated
    Oct 28, 2011 4:15 AM (in response to Ryan Homer)

    Yes. Here too. Just had this start happening today. (I got around to updating XCode 4.2 + iOS 5 to full release last night)

     

    System Profiler showed BTServer hogging over 250% (?) CPU. Fans whirring like ****.

     

    I'd usually blame Flash for this sort of thing, but I had quit all browsers.

     

    The System Profiler revealed that the iPhone simulator was using it, even though it was not running at all.

     

    When I manually launched the simulator to see what might be going on, the BTServer terminated and the fans went off. Something must have gotten 'stuck'.

     

    Something from the XCode 4.2 / iOS5 stuff is definitely causing this, since I upgraded last night.

     

    OS X 10.6.8 - Macbook Pro 2.8 GHz i7 w/ 4GB RAM

  • ankhansen Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 28, 2011 4:32 AM (in response to supertv)

    Thanx supertv.

     

    That did the trick - now I just need to remember this, once I might need the BTServer in the simulator.

     

    Found another interesting thing in the simulator having the Activity Monitor present all time.

     

    Once the keyboard shows up, it uses 40% cpu - just by showing the keyboard.

     

    Is this just me and my MacBook or is this as common as the BT Server?

  • creativemessdev Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 29, 2011 1:26 PM (in response to creativemessdev)

    Just received a reply from Apple - they had previously logged this issue under Bug # 10060466. Like I said before I don't think there is a way to follow specific bugs publicly but I can't verify as I'm getting a login error right now. I will post again if I get another update.

  • supertv Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 30, 2011 10:32 PM (in response to ankhansen)

    BTServer stands for Bluetooth server. I don't think we need Bluetooth in simulator !

    You can safely disable it.

  • bogdanudrescu Calculating status...
    Currently Being Moderated
    Nov 3, 2011 1:00 PM (in response to joconor)

    Same for me. On Snow Leopard and XCode 4.2. It seems that it stared also with the iOS Simulator.

  • supertv Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 5, 2011 3:13 PM (in response to supertv)

    Hi guys,

    Just want to let everyone know that I have been disabling BTServer service for more than a week;

    and the solution is working for me without any side effect.

    ankhansen did confirm this as well.

     

    Before this, it was a pain to kill BTServer every 5 min or so.

     

    Hope it helps,

    T.V.

    supertv wrote:

     

    I finally figured out how to disable it.

    sudo edit /DevIos5//Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator5.0. sdk/System/Library/LaunchDaemons/com.apple.BTServer.plist

     

    There is a 'disabled' key set to false by default.

    Setting it true will prevent BTServer from being started.

     

    Hope it helps,

  • Blender Boy Calculating status...
    Currently Being Moderated
    Nov 15, 2011 6:30 AM (in response to iwacemaker)

    Running Xcode 4.2 on OSX 10.6.8

     

    I had closed Sim whiel using XCode, simply reopening and running Sim Cooled me Down.

  • bogdanudrescu Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 10, 2012 12:43 AM (in response to supertv)

    Worked for me as well. Just edit this file using XCode and set the Disabled property to YES.

     

    /Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator5.0. sdk/System/Library/LaunchDaemons/com.apple.BTServer.plist

     

    I had to set the Write permission to the file and to all its parent folders up to the top one, otherwise the file didn't save.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.