Skip navigation

iPhone 4S dropping network and data at random

218118 Views 1,020 Replies Latest reply: Jan 21, 2014 11:02 AM by atreceno RSS
  • jonathanfromleeds Calculating status...

    So, i got my replacment phone from the apple store.... Same problem! Why have apple not aknowledged this problem yet? Not much of smart phone without 3g! I may as well have 2 plastic cups and a piece of string!

  • Robbo71 Calculating status...

    Same issue here in Ireland on the Meteor network. Got the 4S yesterday and noticed even with 4-5 bars, there were times my SMS msg could not be sent. Progress bar would hang at the end and eventually report a sending failure. Could not en make or recive calls. Phone would then drop coverage to No Service for a while, then begon searching and the coverage would come back and would work. Would repeat this then a while later.

     

    I've tried it in several locations around the city, same issue. Thought it may ave been my Network, but it clearly isn't. It's reading full coverage all the time, when it's working it works fine, calls are crystal clear. Glad I found this thread as it's clearly a firmware issue, with the baseband and should be easy to fix if Apple can get the update out to us! Have unlocked the sim so will see how that goes today.

  • panzert4 Calculating status...
    Currently Being Moderated
    Nov 5, 2011 5:15 AM (in response to Robbo71)

    i just hope they fix it, can wait a week or so, but cant have a phone that doesnt work for months, and just hope they will not say : its not our fault or its the users fault. i am seriously considering canceling my deal with tele2 and trade my iphone for a competitor phone if it takes longer then 1-2 weeks.

     

    how long do they usually take from past experiences untill they fix such problems?

  • Nwo Calculating status...
    Currently Being Moderated
    Nov 5, 2011 4:21 PM (in response to Robbo71)

    In the same boat as Robbo - on Meteor in Ireland - Have already tried unlocking the SIM but it does not resolve the issue. The only thing that seems to work (temporarily) is a hard restart.

  • Robbo71 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 6, 2011 5:27 AM (in response to Nwo)

    Did you try a full restore yet? I haven't, can't see that resolving the issue as I already tried a full Reset of all settings and then a reset Network settings. The phone is new, brand new sim put in etc so I can't see a full restore working. It seems to be a software/firmware issue, maybe the Meteor network is at fault as well, my old number from O2 was ported over...

  • Nwo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 6, 2011 8:50 AM (in response to Robbo71)

    My number was ported from O2 as well. I cannot see how a full restore would help really.

    I have switched the carrier setting from Automatic to Manual and this seems to be working at the minute but is a temporary solution at best.

    I have emailed Apple and hope to receive some response from them over the not few days.

    Will post their reply as I get it....

    I imagine they will release a software patch soon...

     

    Didn't have any such problems with my iPhone 3G...:(

  • mbolo01 Calculating status...
    Currently Being Moderated
    Nov 7, 2011 4:18 AM (in response to Nwo)

    Update from my side:

    • iPhone purchased on Thursday 3rd and activated in the following couple of hours with a temp micro-sim borrowed to someone.
    • iPhone setup and apps installed using WiFi on Thursday 3rd from scratch, no restore from previous phone.
    • Added new Orange.fr micro-sim on Friday morning the 4th (movingout my regular SIM used on my 3GS), nigthmare starting, networkconnection loss, signal bars present but no comms in/out, sim carderror messages, numerous restart and/or network configuration reset,all without results.
    • Moved to GSM only (WiFi disabled) on Sat 5th noon and connection issue started to disappear
    • Sunday 6th, no connection issues to report anymore, WiFi activated back in the afternoon.
    • Monday 7th, no connection issues to report yet

     

    Fyi: PIN still disabled, not sure it is a fix, just a quick way to recover, I'll try back with the PIN back today or tomorrow.

    Also, I'm not sure I have seen people reporting the issuelasting over days, usually it is between immediate and 1 or 2 days,maybe the time for the device or the network to agree togeteher :-)

     

    More to come if out of interest.

  • scr33n Calculating status...
    Currently Being Moderated
    Nov 7, 2011 5:30 AM (in response to mbolo01)

    Same problem on 02 in Ireland, SIM Pin did the trick but this needs to be fixed asap

  • mtg138 Calculating status...

    Phone was bought in canada and using it in india on Idea. Sim Pin was already off. And title is No Service on top..

    C3 serial number factory unlocked..

     

    Any help??

  • xpriens Calculating status...
    Currently Being Moderated
    Nov 7, 2011 8:02 PM (in response to mtg138)

    Dude, I am also on the same boat. Bought a factory unlocked in Canada, and now in India, it shows "No Service". There is something weird about it, as the same SIM was working back in Canada on their network .

     

    Serial number: C3

    Production week: 43 (October)

    Factory: C3 (China)

  • Fazo46 Calculating status...

    i have the same problem with my 4s, i sent it back to vodafone to get a new one and now i'm waiting and i hope with the new phone the prob is gone because turning off the sim pin didnt help so we will see and i will keep you posted.

  • arnaud220 Calculating status...

    Same problem with SFR un France ... Please Apple don't Forget ... A phone is first used to ... Phone

  • albertqui Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 8, 2011 12:58 PM (in response to arnaud220)

    I agree. Phones are made to make calls.

     

    It seems like Apple doesn't care about this problem right now.

    I called Tele2 and they are just saying that they are waiting on an answer from Apple about this issue.

  • [UT]_Maverick Calculating status...
    Currently Being Moderated
    Nov 8, 2011 1:58 PM (in response to albertqui)

    Hello from Spain, i have the same problem, Iphone 4S Unlock 64 GB, I'm using Orange Spain...

  • scienceandmore Calculating status...

    Hello from Norway!

    Same problem as with our swedish neighbours. Tele2 Norway.

     

    Got a screenshot of the error-message if anyone might find interest in it.

    This happend after I tried sending a sms.

    When I try calling my phone goes nuts. Makes some insane static noise and the only way to make it stop is to force restart.

     

    IMG_0029.PNG

    edit: It says I have a connection, but I don't. MAAAAAD!

1 ... 4 5 6 7 8 ... 69 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (33)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.