2 Replies Latest reply: Nov 9, 2011 1:29 AM by foolphat
foolphat Level 1 Level 1 (0 points)

I’ve got a really annoying issue with my iMac and I waswondering if anyone would know how I could sort it out.

 

I was running Logic Pro 8.2 on OS X Snow Leopard and Ithought it would be a good idea to upgrade to OS X Lion.  But it turns out that Logic Pro 8.2 doesn’twork with Lion.  So instead of paying£160 for an upgrade a friend of mine gave me a full copy of LP 9.0 on a HardDrive.  I tried to install it but when I wentto open Logic it stated that I now have Logic 9.0 and I should open that version.

 

I’ve looked on forums and they’ve said I should delete allremnants of the program in my Library and other folders as well as runningcommands in Console to remove every part of it. I have down that now but I’m still going the same problem.  Maybe I haven’t done this properly?

 

I will be more than happy to pay for an upgrade now but I’mnot sure if I can reinstall Logic 8 whilst running OS X Lion.

 

If anyone knows and can tell me how I can either completelyremove all parts of the Logic versions half installed on my machine or knowshow I can get Logic 8 reinstalled to the point where I can purchase an upgradeI will be very grateful.

 

Thanks, Joe

  • 1. Re: How can I uninstall Logic 8 and install Logic 9???
    John the Miracle Level 2 Level 2 (265 points)

    if you actually BUY logic studio it's absolutely no problem to install version 9 over your existing logic studio 8 installation. that's what the installer has been made for (get the upgrade, it's just 199 afaik). it shouldn't be a problem to install the upgrade over your current setup as long as you didn't delete major parts of the installation. hth.

  • 2. Re: How can I uninstall Logic 8 and install Logic 9???
    foolphat Level 1 Level 1 (0 points)

    I managed to delete all parts of Logic 8 and installed Logic 9 ok.  The reason it still wouldn't open is because Logic 9.0 isn't compatable to OS X Lion so i downloaded the free upgrade to Logic to v9.1.5 (i think) and now it works. 

     

    Although i see that Logic 9 has changed all the good shortcuts like '*' for record and '00' to take the marker back the start of the arrangment. 

     

    Thanks for you help