4 Replies Latest reply: Nov 10, 2011 1:30 PM by Javajoe
TDThompson Level 1 Level 1 (0 points)

After seeing many other threads, I am hesistant to start my own. However, I thought it worthwhile to share how I fixed this problem on my iPad 1.

 

SYMPTOM: iTunes sync doesn't complete, with the message "Waiting for items to copy" displayed. There are no error messages, and it appears that all content is valid and synced. It is possible to cancel the sync from the iPad (Settings -> General -> iTunes Wi-Fi Sync) or by exiting iTunes.

 

RESOLUTION: Select the iPad in iTunes, and in each category (Info, Apps, Music, Movies, TV Shows, Podcasts, iTunes U, Books, Photos) make one modification, just so the Apply button appears. Click Apply. The sync will restart, even if it's already stuck at "Waiting for items to copy".

 

On my iPad, I noted that if I de-selected the option to sync Books, one book keep re-checking itself after I clicked Apply: The iPad User Guide for iOS 5. I had downloaded this one via the iBooks app in the iPad. I right-clicked the iPad and picked "Transfer Purchases", but it appeared to do very little.

 

From the iTunes Library under Books, I deleted the local copy of the iPad User Guide for iOS 5, then synced again.

 

It worked! Briefly, there were extra messages about transferring the iOS 5 user guide again, but the Books category now worked correctly.

 

SO... it appears that the bug may be related to having items on the device which didn't get transferred fully during the "Transferring purchases" part of the sync.

 

SUMMARY: If you purchased some items then notice that sync doesn't work right, try deleting the local iTunes copies of the recent purchases and sync again.

 

Good luck!


iPad