Skip navigation

OS X Lion postfix smtpd problems

9978 Views 3 Replies Latest reply: Nov 10, 2011 5:21 PM by CedricBelin RSS
seekoei Calculating status...
Currently Being Moderated
Aug 8, 2011 7:30 AM

For the life of me I couldn't get smtpd running correctly on my iMac (brand new SL iMac upgraded to Lion).

 

Looking at the syslog, I kept getting:

 

postfix/smtpd[1001]: fatal: open /etc/postfix/submit.cred: No such file or directory

postfix/master[971]: warning: process /usr/libexec/postfix/smtpd pid 1001 exit status 1

postfix/master[971]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling

 

Upon checking, that /etc/postfix/submit.cred file was missing. Created a blank one. Syslog then showed:

 

postfix/smtpd[1041]: fatal: unsafe ownership or permissions on /etc/postfix/submit.cred: uid/gid/mode are 0/0/644 should be 0/0/0600

postfix/master[1035]: warning: process /usr/libexec/postfix/smtpd pid 1041 exit status 1

postfix/master[1035]: warning: /usr/libexec/postfix/smtpd: bad command startup -- throttling

 

Did the chmod 0600 on it.

 

FINALLY smtpd started accepting connections!

 

Syslog still showed a warning:

 

postfix/smtpd[1420]: warning: no valid hostport|username|password entries in /etc/postfix/submit.cred

 

So I just commented it out of /etc/postfix/main.cf:

 

# (APPLE) Credentials for using URLAUTH with IMAP servers.

#imap_submit_cred_file = /etc/postfix/submit.cred

 

And now all looks good.

 

Seems this is a new (broken?) option Apple have added to postfix.

 

Hope this helps someone else avoid the frustration I've been having!!  :-)

iMac, Mac OS X (10.7)
  • Filippo.migliorati Calculating status...
    Currently Being Moderated
    Aug 30, 2011 1:18 AM (in response to seekoei)

    Hi, the submit.cred file is NOT a new (broken) Apple option. It has been introduced, instead, with the new versions of PostFix, so you could find it also on Linux or BSD installatios running the latest version of it.

    It has been introduced to match the MTA with the RFC4468 (http://tools.ietf.org/html/rfc4468) which describes an extension of the IMAP protocol.

    In order to fix the problem your console is displaying, you should:

    1. Create a submit.cred file in /etc/postfix directory (sudo touch /etc/postfix/submit.cred will do).
    2. Create a header for that file: sudo echo "submitcred version 1" >> /etc/postfix/submit.cred
    3. Add as many lines as the number of users you want to enable to submit mail, in the form hostname|user|passwd sudo echo''hostname|username|password" >> /etc/postfix/submit.cred
    4. Give the file the appropriate permissions: sudo chmod 600 /etc/postfix/submit.cred

     

    Once you've done this you could restart postfix and everything sould run smoothly. You should also fine-tune your postfix configuration in order to prevent it to deliver spam or provide security breaches.

    Enjoy.

  • sunnysider Calculating status...
    Currently Being Moderated
    Nov 10, 2011 8:15 AM (in response to Filippo.migliorati)

    Ah. Thanks for that - worked perfectly!

  • CedricBelin Calculating status...
    Currently Being Moderated
    Nov 10, 2011 5:21 PM (in response to sunnysider)

    Same thing for me
    Now, Postfix works like a charm !

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.