Skip navigation

Video freeze with Fast User Switching

1127 Views 9 Replies Latest reply: Jul 9, 2012 5:11 PM by mswest RSS
Darren Raymond Calculating status...
Currently Being Moderated
Mar 21, 2011 10:03 AM
I can't seem to find anything on this specific topic in the forums, but it's plagued me pretty much since I got the i7 iMac a year ago. The problem is this: when I have more than one account logged in via Fast User Switching, the video will freeze on me. Details:

* by video I mean not the display as a whole, but any video content that is playing -- YouTube, iChat video, etc.

* only the video freezes. Audio keeps playing.

* if I close the other user account, video will resume its normal functioning.

* if I constantly move the window in which the video is playing, it will keep playing.

* if I switch away from the window and return, the video will play again for a brief second.

Those last 2 I find especially puzzling, and they lead me to believe that somehow the computer or the video card somehow is "forgetting" that it needs to redraw the video.

I brought this issue up to a very friendly and helpful Apple rep who suggested zapping the PRAM, which did help for a couple of days but even a restart will do the trick for a while.

Anybody else seen this issue? Any solutions?
iMac 2.8 GHz i7, Mac OS X (10.6.6), RAM - 16 MB
  • Kieron Edwards Calculating status...
    Currently Being Moderated
    Apr 15, 2011 1:00 AM (in response to Darren Raymond)
    I have exactly the same issue. A 1 year old quad core iMac 27". With 4 user accounts - usually logged in at the same time. If I watch video in any browser (FF4, Safari, Chrome 10) it pauses after a period and then restarts if I use the pointer to provide focus to another window. It then freezes completely and whatever is playing the video (Chrome, Quicktime) "beachballs" for a while.

    I tried using the process manager to see if anything was suddenly flooring the CPU but nothing got above 50% usage on one core (and that was Chrome's flash plugin). Everything else remained below 10%. Memory usage wasn't particularly high either.

    I'll try rebooting, logging in myself and then re-test to see if this clears the problem. I don't remember this being so bad when I got the machine and it would have had 3 accounts on it (with 2 active at any time) then.

    It's damned annoying either way!
    iMac G5 & MacBook, Mac OS X (10.5), Video freezes, unfreezes and then stops playback.
  • SteveMoMo Calculating status...
    Currently Being Moderated
    Apr 24, 2011 7:04 PM (in response to Darren Raymond)

    Exact same issue here.  Up-to-date 10.6.7 on 3.06GHz Intel Core 2 Duo iMac 27-inch, Late 2009.

     

    However, it only happens for me when using the Guest account.

     

    I'm wondering if this is a flash issue?  Does it happen for you guys when watching video other than flash?

  • SteveMoMo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 25, 2011 9:46 AM (in response to Darren Raymond)

    Same here -- I was quick to throw that out there.  This is a mac that I don't use that often.  I did some more testing last night and realized it happens all over the place.

     

    I even get it on the animated startup of Safari.

  • callehedberg Calculating status...
    Currently Being Moderated
    Nov 3, 2011 10:01 AM (in response to Darren Raymond)

    Same problem here on my Mac mini running OS X 10.7.1. The problem appeared first under Snow Leopard, I can't really say when, however, and the only way to get around it is to log out all other users.

     

    Has anyone found a permanent solution?

  • Ernst Mulder Calculating status...
    Currently Being Moderated
    Nov 14, 2011 1:24 PM (in response to Darren Raymond)

    Same here. Not specific to 10.7.x, had it in 10.5 and 10.6 as well. The problem is made worse when also using Screen Sharing. All video is stalled (audio plays on). Sometimes the video continues when the mouse is moved. The video also continues when the system volume is changed using the keyboard.

     

    And with all video I mean really all video. Even transitions in the login screen pause until I press the volume keys.

     

    Usually there is no problem with one specific user, and the stalls can usually be fixed by logging that user out, as if that user somehow "owns" the video of the Mac.

     

    Very annoying, and I do hope someone has a solution.

     

    Any specific stuff the other me too's here have installed? I've got Flash Player, Click2Flash, Perian, SizzlingKeys, Flip4Mac for instance.

  • mswest Calculating status...
    Currently Being Moderated
    Jul 9, 2012 5:11 PM (in response to Darren Raymond)

    Resurrecting an old thread.  I have this same issue.  Has anyone seen a solution yet?

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.