Skip navigation

Iphone 4s - 3G connection disappears after using wi-fi

233932 Views 208 Replies Latest reply: Apr 2, 2014 6:05 AM by Marieul apple juice RSS Branched to a new discussion.
  • valmont74 Level 1 Level 1 (0 points)

    I got the iPhone 4S last week from Apple Online Store and use it with a Telia (Swedish network) SIM card.

     

    At home and at work I use the Wifi network and when going outside it automatically connects to the Telia network for calls, but for some reason not for data transfer. So even if the display says Telia 3G or Telia E, I cannot use it for surfing, iMessage or checking mails etc, only to make calls, and recieve SMS.

     

    I did contact Apple about this and they told me to turn off the SIM pin, swtich Flight mode on and back, but it still didn't want to reconnect to the network that allow data transfer.

     

    The only thing that seem to make things right is a reboot (menu button + standby)

     

     

    Apple has sent out a new device to me, but from reading the posts above, it's not sure it will solve the problem for me.

     

    Any work arounds or other experiences from the Apple support?

  • STA298 Level 1 Level 1 (0 points)

    Exactly the same problem here. Only happens following an extended connection to Wifi - eg leaving the house on a morning and walking to work, out of the range of my home router. Network signal fine, but no 3G.

  • RYON82 Level 1 Level 1 (0 points)

    Hello,

     

    I'm having the same problem.

    I thought that this problem would have been solved with the 5.01 update, but it didn't worked out.

     

    The only solution I could find was to put the phone in "flight mode" and than put back off.

    Or for a permanent solution was to disable the lock code from the sim card.

     

    Provider is, Proximus, Belgium

     

    Regards.

  • Maronie Level 1 Level 1 (0 points)

    Hello all,

     

    I have been having the exact same problem ever since I got my new iPhone 4S, feel kinda relieve that I am not the only one, but wonder how common it is, since other people I know don't seem to have this problem.

     

    Going to the Apple store this weekend to see what they can do! Will keep you all posted!

  • Bkoz1122 Level 1 Level 1 (0 points)

    I was having the same issue until I turned roaming to "on".  Now it's switching back and forth seamlessly from network to 3G without having to turn airplane mode on or off or any other gyrations.

    Just for the record:  it's General/Network/Data Roaming  "on"....and I have Cellular Data "on" also.    Hope this helps.

  • judge_from_Belgium Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 17, 2011 12:49 AM (in response to RYON82)

    Same problem here. I also have proximus (Belgium) as provider. I will disable the lock code from the sim card and see if it helps. Fingers crossed for tomorow.

  • valmont74 Level 1 Level 1 (0 points)

    Now I have encountered something new. I turned on wifi yesterday at home and then when I was out I noticed that it worked as it's supposed to. It worked all day both at work and at home and for a second I hoped it would go on.

     

    Unfortunately this morning it was the same thing again and when flight mode didn't work I turned off the iPhone and started it again and it worked as it should.

     

    One thing that I did different from today and yesterday though - yesterday I started by sending an iMessage. Today I started by going into the mail. That is how I've most often noticed that it's malfunctioning - the message "connecting" in the mail refuses to go away.

     

    I will try to start by sending an iMessage next time to see if it works. I know there's no logic to this theory, but just as turning off the SIM has worked for some, I thought I can give it a shot and share the experience with you.

  • judge_from_Belgium Level 1 Level 1 (0 points)

    Disabling the lock code from the sim card, dit not change anything... The only thing that seems to help is switching tot flight mode for 5 secs so the iPhone needs to reconnect to the providers network.

     

    I believe it is a software problem. To save energy while conencted to wi-fi for a longer period, the iPhone gives up the connection to te 3G network, but doesn't automaticly picks it up again when wifi is lost.

     

    Is Apple already working on a patch?

  • fatin fromshah alam Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 18, 2011 12:40 AM (in response to injust)

    Im in jordan.i cant even use th 3g even after i having meet the carrier service provier.cuz if i used the same sim card its working good on iphone4.im using 4s.anyone can help me?

  • JedWare Level 1 Level 1 (0 points)

    Having same issue on two iphone 4s phones. It is random but even the switching to airplane mode does not fix it for me. I have to reboot to get 3g back. I am suspicious that some background process is not releasing the internet hook and thus corrupting the connection.

     

    The phone will show full bars and 3G signal but nothing can download.

  • AATT Level 1 Level 1 (0 points)

    Hey I think have the same problem

    What I`ve noticed .

    Lets say everything works .. if i make a call the moment the ring starts the 3g signal disappears

    And comes back when the call ends ..

    Sometimes I have a blue circle where the 3g icon should be and no internet

    Sometimes I have the 3g icon and full signal but still no internet .. ?

    Also If i disconnect the wifi the 4s has sometimes problems going back to 3g

  • JedWare Level 1 Level 1 (0 points)

    For my situation I think I found the problem.  Both my new iphone 4s phones had the wrong IMEI number in the system. There is apparently a different data plans and settings for 4s phones compared to the iphone 4 on the ATT network.  A call to 611 can confirm what IMEI number is associated with your number.

     

    So far my phones have been working correctly going between wi-fi and 3g. Hope this helps someone else.

  • AATT Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 19, 2011 11:46 PM (in response to injust)

    whats a imei number

  • AATT Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 20, 2011 12:09 AM (in response to AATT)

    nvm i found out ill try to call vodafone for it

  • kruelspell Level 1 Level 1 (0 points)

    I am having the same problem. Tried to switch off SIM pin, airplane mode but nothing worked for me. 3G connection is going and coming randomly even without touching the phone from its location. The problem has been not solver by 5.0.1 for me.

     

    Hoep Apple fixes this soon, it's very frustrating and ruins the iPhone experience at all.

1 2 3 4 ... 14 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.