Skip navigation

Bluetooth problem after iOS5

20441 Views 79 Replies Latest reply: Sep 22, 2012 3:51 AM by bailey#70 RSS
  • iggorrie Calculating status...
    Currently Being Moderated
    Nov 4, 2011 3:32 PM (in response to Vope)

    I too have the issue with my iPhone 4 no longer being able to pair with my Clarion BT car stereo.  Deleted the pairing from both the phone and the stereo, it says that it is connected, then disconnects as soon as you try to stream music over it.

     

    My Blackberry pairs fine with the stereo and I can play music over this pairing.

     

    My iPhone was fine on the previous OS.  I think I will try rolling back.

     

    Just goes to show that Apple is not more reliable then Microsoft when it comes to bugs.

  • damhack Calculating status...
    Currently Being Moderated
    Nov 5, 2011 8:44 AM (in response to valepe)

    iOS5 unlike earlier firmware uses Bluetooth 4, which presents some issues to various other devices which use deprecated features.

     

    E.g. My Audi A6 multimedia interface worked fine with iOS4 but freaks out with iOS5.

     

    Unfortunately, the solution is to obtain the latest Bluetooth drivers from your vendor.  Apple is very unlikely to be able to do anything about this in the short term and quite frankly shouldn't as it is other vendors who aren't using the latest stable standard implementation.

     

    As an example, my Audi bluetooth was upgradable and my iPhone 4s worked fine after the upgrade. It really misbehaved before (no sound, music tracks skipping forward 2 seconds at a time, phone wouldn't end calls, etc.).

     

    It took a lot of digging to find the upgrade and Audi dealers didn't know anything about it.  So my advice is to just persevere and find the latest Bluetooth update for your currently incompatible device.

     

    BTW, if anyone's interested, the Audi upgrade was at: http://www.audi.com/com/brand/en/tools/bluetooth.html#source=http://www.audi.com /com/brand/en/tools/bluetooth/mobile_phone_preparation.html&container=layerModal

     

    DH

  • bailey#70 Calculating status...
    Currently Being Moderated
    Nov 5, 2011 9:20 AM (in response to valepe)

    So damhack, you're saying that those of us who have had phones for several years which we purchased as being compatible with Bluetooth equipment that was available on the market at the time, who own Bluetooth equipment which is stand-alone, not upgradable and out of warranty, now have to either badger the manufacturers to engineer a solution or buy something new?

  • damhack Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 5, 2011 1:40 PM (in response to bailey#70)

    I think that is probably the case, as bad of Apple as that is.

     

    Apple would probably use the same argument that they used about Flash, i.e. we are only supporting the latest standards that make our technology work well.

     

    I don't speak for Apple and I do not like what they have done, but I think it is right to let people know the reality of the situation. Apple considers itself a gatekeeper and expects other vendors to do all the hard work to keep compatible with their latest gadgets.  So you are probably wasting your breath pleading with Apple to add back in support for a technology they have deprecated.  A bit like asking for 3.5" floppy disk support to be added to the latest iMac.

     

    Your best chance is to pester the manufacturer of your device as they will be keen to maintain compatibility with Apple products or risk losing business to their customers. If the product is out of warranty, it's likely that the company has a cheaper and better solution anyway. Just sell your old device on eBay and grab the latest gizmo instead.

     

    Of course, this is all really **** for us users, but tech companies have had us by the balls for a long times now and they like it that way.

     

    DH

  • JochenKauz Calculating status...
    Currently Being Moderated
    Nov 7, 2011 9:02 AM (in response to damhack)

    Sorry, but I don't think that this is correct.

     

    It's true that Apple has updated to Bluetooth 4.0 (Standard is from 2009). Bluetooth 4.0 implements additional new features like energy saving, but it also is backward compatable to previous version.

    One example.. I have a problem with my Nokia Car kit. It implements and uses the Hands Free Profile with version 1.5. And this is exactly the current version which is also included with bluetooth 4.0. So if my car kit does not work anymore with iOS 5 and his bluetooth 4.0 implementation, it's a wrong implementation by Apple, not by Nokia. And HFP 1.5 it's not an old thing like a 3.5" floppy disk, it's more like breaking the  SATA II standard, and I think that many people were angry and disappointed if Apple would break support for SATA disks of Seagate/WD/etc. by releasing a BIOS update to their Mac's, especially without any warning notice that support is broken. By the way I would not think that Seagate or WD would make a firmware update for their disk's only because Apple make a wrong implementation of a standard protocol.

  • oscarfromgetafe Calculating status...
    Currently Being Moderated
    Nov 11, 2011 4:08 AM (in response to raywalton)

    Once I have made your proposal, the result is the same. It doesn´t work. I have removed the BT devices from car audio system and the same in my Iphone4 and starting from the scratch. Nothing new.

     

    Thanks anyway

  • bailey#70 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 11, 2011 4:17 AM (in response to valepe)

    I agree with the above post that "new" Bluetooth should be backward compatible with old devices, on that basis I'm going to have to assume after this time that Apple know about this and will fix it in 5.0.1.

     

    If not... then I should have my 4S by that time so I'll just head for the Genius Bar and let them explain why it doesn't work!

  • bailey#70 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 11, 2011 6:18 AM (in response to valepe)

    ...but then again, well done Apple for ignoring such a visible problem. I just completed the update and gave it a try but no change.

  • JochenKauz Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 13, 2011 6:13 AM (in response to bailey#70)

    Same for me... updated to 5.0.1 and.... nothing changed. But it was nothing they had announced to be fixed in 5.0.1. And unfortunately I don't think that they will fix it in a future release.

  • Vope Calculating status...
    Currently Being Moderated
    Nov 16, 2011 2:33 AM (in response to JochenKauz)

    Apple have no choice, they MUST fix it !!!!!!!!!!!!!!!!!

    It's a must for such a company, they MUST fix it !!

  • raywalton Calculating status...
    Currently Being Moderated
    Nov 16, 2011 8:16 AM (in response to Vope)

    I 100% agree with you Vope.  I am deeply disappointed and quite disgusted at absolutrley NO response from Apple as this is completely unaccpetable.  I was a big Apple fan but this has completely put me off them even though I am now not persoanally affected by this problem (see below).

     

    No good smart as**s coming on here and saying get a life and update your old BT equipment as that is also totally unacceptable and should not be neccessary and after all many of us these days have not got the spare cash to spend on what should be unnedeed upgrades just to give Apple an easy life by them not putting right their c*ck ups.  All BT upgrades are anyway always backward compatible like most such systems and indeed BT IS indeed suppose to be backward compatible to even very old versions.  So Apple have screwed up and not even had the decency to acknowledge this. TOTALLY UNACCEPTABLE !!!  So come on Apple lets be hearing from you or I and many others witll start seriously looking at Samsung to see if they have better customer relations as their hardware is now very good too it seems. 

     

    We all accept that everyone makes c*ck ups but only decent and respected organisations quickly own up to it and put it right ASAP.  I obviously wrongly thought Apple was a decent respected organisation and truly found in the past that they were indeed just that, Very sadly something has drastically changed for the worse and it seems that is no longer the case :-(   Certainly now will not change to an iPhone 4S so unless this bad attitude of Apple changes back to how it was my next smart phone could well be a Samsung rather than my planned for new generation iPhone..

     

    Personally this BT problem no longer affects me though still shocked by Apple's apparent total lack of attention and response to this serious problem critically affecting many of their users.  My iPhone 3GS and my iPad (1) now work perfectly since I deleted the old IOS4 BT profiles and set them up as new.  Also since then works to my Griffin Beacon (BT to IR TV remove control box).  Before I could not connect my iPhone or iPad to each other or my only other BT device the Griffin Beacon.  I did post about this personal fix a few weeks ago although many then said that it didn't work for them, which seems strange as I have had no problem since that fix.  But that was just with my iPhone3GS, iPad 1 and use with my Griffin Beacon as I use no other BT equipment here   Surely though this should have worked for anyone else having iPhone 3GS to iPad1 BT connection problems as we then all have the same equipment and same IOS5.  Make sure you reboot your iPhone and iPad too just to make sure the new settings are "locked in" though not sure if that is necessary but logically worth doing anyway.

     

    Downloaded the new IOS 5.0.1 update and no change here and my BT connections still work normally and okay.  Was very cross though to see again no mention of this important problem nor any fix for it in this latest IOS 5 update. Surely this to me is far more important even than the battery life problem they fixed (which I did not seem to get anyway).  But BOTH problems should have been fixed or at least a mention to say they were still looking at a fix for the highly important and far more critical BT bug and that it would be fixed very soon.

     

    Their inaction on this big issue has totally destroyed my previous respect and trust in Apple and now find I can no longer recommend their equipement to friends and contacts.  Come on Apple speak up and try to justify yourselves and earn back the respect you are now loosing before it is too late.  Samsung are seriously knocking on your door and I would rather you kept your respect and kept that door shut.

  • DanielBY Calculating status...
    Currently Being Moderated
    Nov 16, 2011 8:19 AM (in response to raywalton)

    Is there a place to log issues directly with Apple?

    I have the same issue with an un-discoverable Jawbone headset and iOS 5 (and 5.0.1).

  • bailey#70 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 16, 2011 8:34 AM (in response to DanielBY)

    The obvious place woud be to contact Applecare or go to an Apple Store... but these options are only really open to those with a device still under waranty which is why I've yet to do either. I'm awaiting a (delayed) delivery of a 4S to replace my 2 year old 3GS and as soon as that arrives I will be doing one of the above myself.

     

    I'm guessing nobody else on this thread will have done so since you probably won't be here if the phone is still under waranty.

     

    I know from past updates that things get broken and do generally get fixed, my only issue at this stage is that Apple won't acknowledge what the problems are. If somebody would just come on the forum and say "yes, we're aware there is a problem" then I'm sure that would be a massive step for many of us.

  • Jacksek Calculating status...
    Currently Being Moderated
    Nov 26, 2011 10:26 PM (in response to valepe)

    Maybe it's not a bug, but sure it's a software problem only. Clearly Apple does not care about thousands or rather millions of BT users who lost their BT functionality. If BT 4.0 is not compatible with older BT equipment Apple should acknowledge it and make it option for the user to choose which version they NEED to use (not WOULD LIKE to use but NEED to use). Using everyday iPhone, Mac Mini, Macbook, iMac - I LOVE APPLE!

    iOS5 has a lot of great features but not to be able to use hands free phone in the car? - here APPLE DISSAPPOINTS BADLY!

    I decided to buy another iPhone 4 (with iOS4) to use BT in my car. I will not update to iOS5 until it's BT software works.

  • fedepan Calculating status...
    Currently Being Moderated
    Nov 27, 2011 12:06 AM (in response to Jacksek)

    No man, should be better buy a samsung galaxy s until BT works... now i have my iphon4 but i'm using a nokia during the day... this really is bad thing

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.