Skip navigation

Lion Server Webmail not reachable via https URL

3846 Views 4 Replies Latest reply: Nov 16, 2011 5:54 AM by frank124 RSS
eldrik Level 1 Level 1 (65 points)
Currently Being Moderated
Sep 6, 2011 12:32 AM

Hi,

 

I upgraded my existing Snow Leopard Server to Lion Server.

 

In the past I could reach the Servers Webmail only via https disabling http access via Server Admin Tools.

 

If I am now using https://servername.com/webmail I get the message (translated from german) "Webmail is disabled. You can enable it via Server program".

 

If I am changing the URL to http:// webmail is working lika a charm.

 

But where can I force the system to disable http:// and instead activate the https:// URL?

 

Best regards

Eldrik

Mac mini, Mac OS X (10.7.1), mini Server 2011 with LS 10.7.1
  • Atrato Level 1 Level 1 (25 points)
    Currently Being Moderated
    Sep 15, 2011 1:08 PM (in response to eldrik)

    In the Server app configure the correct SSL certificate for the webservice.

  • LogMeCode3 Level 1 Level 1 (70 points)
    Currently Being Moderated
    Sep 16, 2011 8:29 PM (in response to eldrik)

    Since you're talking webmail, are you accessing it via the built-in Wiki website, or otherwise?  And do you have web services setup for secure usage with an SSL certificate?  Since you're able to type in http (without the 's') and it's not redirecting you automatically to https, I'm thinking that you need to configure your web servces for secure use.  In Lion, Server.app, Web Services, you would click on the '+' symbol and add a website.  It can be the same domain name as the server created default website, but the port needs to be 443 (it could also be www.servername.com, if that's how you'd like to access your website).  That should redirect all inquiries to your http site to https.  As mentioned above, you also need to make sure that your web services are configured with whatever SSL certificate you're using.  You do that in Server.app too -- choose your machine under the hardware area (left side) and then choosing 'settings' and then click the 'edit' button for SSL Certificate.  You probably need to have Wiki services turned on as well, if you don't already.

  • Mac-Fan_ Calculating status...
    Currently Being Moderated
    Sep 20, 2011 1:17 AM (in response to eldrik)

    Hello Eldrik

     

    Are you able to connect also from the "outside" world (Internet) to your webmail service ?

     

    I got this issue:

    https://discussions.apple.com/message/16168879#16168879

     

    The strange thing is, that from internal (LAN) side, it is working properly, but from Internet side, I've got the authentication page, but the Webmail frontend can not talk with the IMAP server (connection failure)....

     

    Did you tested the "outside" szenario as well ?

     

    Many thanks

    Daniel

  • frank124 Calculating status...
    Currently Being Moderated
    Nov 16, 2011 5:54 AM (in response to eldrik)

    Have a look in

     

    /usr/share/webmail/config/appleoverrides.inc.php,

    should point to your local servername instead of $h

    the original  $h will be replaced by your external fqdn which is not enabled in mail.

     

    $rcmail_config['default_host'] = 'tls://macserver.examle.com';

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.