1 30 31 32 33 34 Previous Next 496 Replies Latest reply: Aug 5, 2012 9:12 AM by RCully Go to original post
  • 480. Re: 10.6.5 and wifi issues
    gokku3 Level 1 Level 1 (0 points)

    same problem as _R_ :

    firmware version Atheros 9380 4.0.58.4-P2P (Lion 10.7.2)

     

    I followed the instructions but after reboot there was no wi-fi functionality at all: the OS wouldn't find any wi-fi card.

    So I reinstalled the backup 10.7.2 kext file, reboot and everything was back to normal (which means I'm still unable to get a stable connection).

     

    Is there a reason why replacing the 10.7.2 kext file with the 10.6.4 one doesen't work for us? It' so strange. After reboot, it's like the OS doesn't see any wifi hardware installed...

     

    Should I try using other kext file instead of the 10.6.4 one? I remember that the first time I boot my brand new imac everything was working fine. but after upgrading to a newer version of snow leopard things just kinda went south. Then Lion just made things worse...

  • 481. Re: 10.6.5 and wifi issues
    RJV Bertin Level 3 Level 3 (950 points)

    I haven't been following this thread for a while, but I can confirm that the trick with the 10.6.4 kext no longer works for me. Whether this is because I upgraded to a 2011 MBP 13" or because I'm running 10.6.8, I don't know, but indeed no WiFi hardware is detected with the older kext.

    I tend to think it's a hardware support question: in case of a software incompatibility I'd expect an error message or a crash, whereas it simply seems that the older driver doesn't support/recognise the newer hardware.

     

    Fortunately my connection is stable nowadays, except sometimes at my gf's place where there must be something that causes interference that kicks in from time to time.

  • 482. Re: 10.6.5 and wifi issues
    tmoney468 Level 1 Level 1 (0 points)

    This is frustrating...I'm on 10.7.2 and I'm not able to downgrade to the 10.6.4 version of the driver.  I've tried multiple steps, rebuilt the cache, and then re-booted, but the file never seems to get updating in the Sys Info upon reboot.  I notice that with this issue some sites become unresponsive for several minutes and then magically re-connect. 

     

    How can this still be an issue?  Originally I thought it was happening due to my new FIOS internet, but it happens everywhere now.

  • 483. Re: 10.6.5 and wifi issues
    RJV Bertin Level 3 Level 3 (950 points)

    It's just so that people like me can argue with reason that serious/"pro" machines cannot rely solely on wifi but require good ole ethernet

  • 484. Re: 10.6.5 and wifi issues
    EJW Tas Level 1 Level 1 (0 points)

    same here - "upgraded" to Lion 7.2 and no wifi to my N network (Apple Airport Extreme Base Station), installed Snow Leopard kernel extensions from 10.6.8 (which had solved my wifi connectivity problems in Lion 7.0) but failed to work in Lion 7.2. I have been dealing with Apple Support Engineer in Texas, running scripts and looking for the cause/s of this issue. Nothing yet after initial 1hr engagement.

     

    wifi is *not* rocket science, but Apple is making it look to be - I have apple computers (and iphone and ipad) all running current system OS, unable to connect by wifi to Apple wifi router - unbelieveable! [and totally unacceptable in my opinion]

     

    perhaps Lion 7.9 will finally fix this trainwreck...

  • 485. Re: 10.6.5 and wifi issues
    AtherosChipstfsckd Level 1 Level 1 (0 points)

    FYI - This thread started on Nov 11, 2010 5:53 AM

    My history, a 3 month old iMac upacked 2 weeks ago, It was on 10.5.6 migrated from a slightly older iMac (also 10.5.8, Earthquake Casualty, worked for a while with a loose bit rattling around inside, HD OK, I digress sorry)

     

    Used a Drop-in 10.6 Upgrade disk to upgrade from 10.5.8 (worked beautifullyt)

    On 10.6 Internet worked normally at this point using Airport (Noticed no unusual behavior)

    Updated to 10.6.8 (Combined Updater v1.1)

    Nek Minut... (No more internet or server in Network Diagnostics, FSCK!!)

    Found tenortim's fix,

    Extracted .kext from 10.6.4 Updater (not combined)

    Moved to System/Library/Extensions (Root, replaced old renamed .kext, ran Kext Utility)

    Still no internet or server in Network Diagnostics (or ethernet for that matter, looked at DNS, no go)

    Downloaded and used the .kext from halfway down p32 of this thread.

    Nek Minut... (Cant even boot into user, spinning beachball of death, FSCK!!)

    All this time was able to connect to same router for Google and downloads (no IP conflicts) using

    a Macbook Pro on 10.5.8 (Lion looking like a Monkey at the moment)

    Need to boot of external now and maybe try reinstalling 10.6.0 again

    Apple is alienating me over this and trying to trap me in their walled garden (appstore) as well.

    Call me UNIMPRESSED!

     

    Message was edited by: AtherosChipstfsckd (for clarity)

  • 486. Re: 10.6.5 and wifi issues
    AtherosChipstfsckd Level 1 Level 1 (0 points)

    OK rebooted in Safe Mode (holding down shift key on restart)

    Reinstated original .kext (and used Kext Utility in spite of warning that the .kext was not compatible)

    Cancelled the warning and Rebooted.

    Now back to how it was after 10.6.8v1.1 combined updater (No Ethernet or Wireless).

    This requires me to Think Differently... a computer without the internet.

    It must be time to do some real real work (debugging Apple's Kernel Extensions).

    Can't wait until Apple recognizes this problem!

  • 487. Re: 10.6.5 and wifi issues
    AtherosChipstfsckd Level 1 Level 1 (0 points)

    This is really old but what it says is that Apple leaned hard on Atheros to stay mum about some security exploits in the Atheros chipset of that time. For a whole YEAR Apple has been studiously ignoring the CURRENT PROBLEM with the Atheros chipsets and WiFi caused by the 10.6.5 and up to 10.6.8 Updaters.

    http://blog.washingtonpost.com/securityfix/2006/08/followup_to_macbook_post.html

     

    Atheros think of themselves like this:

    For a lot of people the world over, Wi-Fi® is their equivalent of oxygen; they just can’t live without it. Qualcomm Atheros is helping make these people’s lives easier, more productive, and even more fun with great connectivity. Our Wi-Fi is helping them to connect to people, consume content and even control the things in their lives, in ways that are easy and fulfilling, and from places that suit their busy and, sometimes, even leisure lifestyles.

     

    WLAN is the world’s most ubiquitous wireless networking technology, with over two billion Wi-Fi®-enabled devices deployed in consumer, enterprise and metropolitan networks and devices worldwide. Qualcomm Atheros is a premier provider of high-performance Wi-Fi solutions, serving our world-class customers that enable digital home, computing, mobile handsets, portable consumer electronics and enterprise equipment with robust and reliable wireless connectivity.

    http://www.qca.qualcomm.com/technology/technology.php?nav1=47

     

    Oh what joy to behold... a brick in the shape of a new 27" iMac.

  • 488. Re: 10.6.5 and wifi issues
    AtherosChipstfsckd Level 1 Level 1 (0 points)

    OK I'm guilty of posting for the purposes of letting my frustrations out (my bad). Some light... the new iMac on 10.6.8 formed a full connection by itself while I was away from the machine! I was ready to buy a new DSL router too! It is a Thomson TG585v7. Putting the machine to sleep and re-waking though caused it to "forget" and I needed to authenticate to the wireless again. In fact all of the computers in the house do this now but I'll withhold judgement for a few days as it may settle down.

    Sorry for all of my ranting.

  • 489. Re: 10.6.5 and wifi issues
    djSeverin Level 1 Level 1 (0 points)

    Thankyou satcomer!

     

    Your advice worked like a charm!

  • 490. Re: 10.6.5 and wifi issues
    savedave_uk Level 1 Level 1 (0 points)

    Hello

     

    I am at the end of my tether with this problem. 

     

    I am on an MBP (1,1) 2.16 using 10.6.8.  I have had no wifi for months - possibly since upgrading to 10.6.8, can't be sure. 

     

    I tried various fixes listed in this thread to no avail.  Eventually I came across the kext fix, which I did (I am not skilled in terminal but I know I got it right because System Profiler says I have the write firmware). 

     

    But STILL NO WIFI !!!

     

    To clarify, I have a slightly different airport card from most who have posted here: Atheros 5424

     

    Also, to clarify, I am certain the problem is in my mbp - I can connect fine from my android phone, I connect fine via my flatmate's ageing laptop, and my brother's pc laptop too. At work I cannot connect either, nor in any cafes with wifi etc.

     

    This is what my system profiler says:

     

      Software Versions:

      Menu Extra:    6.2.2 (622.2)

      configd plug-in:    6.2.5 (625.6)

      System Profiler:    6.0.1 (601.1)

      Network Preference:    6.2.2 (622.2)

      AirPort Utility:    5.5.3 (553.20)

      IO80211 Family:    3.1.1 (311.1)

      Interfaces:

    en1:

      Card Type:    AirPort Extreme  (0x168C, 0x86)

      Firmware Version:    Atheros 5424: 2.0.19.10

      Locale:    ETSI

      Country Code:   

      Supported PHY Modes:    802.11 a/b/g

      Supported Channels:    1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 124, 128, 132, 136, 140, 149, 153, 157, 161, 165

      Status:    Off

     

     

    Please, if anyone has any further thoughts on why this fix has not worked for me I would really appreciate it.

     

    Thanks

     

    SD

  • 491. Re: 10.6.5 and wifi issues
    nzbart Level 1 Level 1 (0 points)

    OK, I'll try to contribute rather that moan..

    This is what I would do. Do not miss any steps unless you know an easier way.

    Log into your Router and delete the wireless settings (only).

    Now re-create them (using a new Wireless network name/ID, Security type, a compatible password

    and whether to broadcast your network name/ID, (a select few prefer to use MAC Address Filtering). Write the new wireless setting's details down!

     

    Then in

    /Library/Preferences/SystemConfiguration/

    live the following files.

     

    com.apple.airport.preferences.plist

    com.apple.network.identification.plist

    com.apple.PowerManagement.plist

    com.apple.smb.server.plist

    NetworkInterfaces.plist

    preferences.plist

     

    Highlight/Select the "SystemConfiguration" folder.

    Zip up the folder using File menu > Compress "SystemConfiguration" (folder)

    You should now have a file in Preferences (folder) beside "SystemConfiguration" called "SystemConfiguration.zip" which is a copy of the originals.

    For your own peace of mind (and edification) note down the Privileges of each file, File menu > Get Info… for each and the enclosing "SystemConfiguration" folder.

     

    Now go ahead and delete all those files in the "SystemConfiguration" folder with airport or network in their name, and empty the Trash.

     

    Now restart your computer (resetting the PRAM, option command P & R if you wish).

    Now and only now re-enter ALL of your network settings (this may be problematic if your have several saved/preferred networks).

     

    If this exercise has not worked for any reason, double click your compressed .zip folder to restore the original. Of course it will not overwrite the original folder but instead rename it to "SystemConfiguration 2" delete the relevant files in the "SystemConfiguration" folder (those with airport or network in their name), and replace them with the originals from the "SystemConfiguration 2" folder.

    Leave the .zip file, it can remain as a useful back-up.

    Check the Privileges of all files and restart your computer and you ought to be back where you started!

     

    regards
    bArt.
  • 492. Re: 10.6.5 and wifi issues
    Nathan Jackson Level 1 Level 1 (5 points)

    Hi, is anyone still having this problem? I just got the logic board on my 17" MBP late 2008 (non unibody) replaced by Apple (for a different reason) and now my wifi will work after startup, but will stop working after a certain period- if I turn it off it will not turn on again, and I have to restart to get it to work again.

     

    I would try the kest fix but it seems a bit extreme seeing that I'm now on 10.7.4.

  • 493. Re: 10.6.5 and wifi issues
    noondaywitch Level 6 Level 6 (8,130 points)

    Then please post a new thread in the OS X 10.7 Lion forum.

     

    This forum is for 10.6 Snow Leopard.

     

    There seem to be a number of similar problems with Lion, so you'll get a faster response there than tagging on to an old thread.

  • 494. Re: 10.6.5 and wifi issues
    DraconPern Level 1 Level 1 (0 points)

    -- nvm, didn't work --

     

    Just want to say that tenortim of page23 solved my problem on 10.6.8 on a white macbook.  However I had to use the kext from 10.6.3 which was on my upgrade DVD.  10.6.4 kext didn't work. 

     

    This worked for me.

    Atheros 5416: 2.0.19.10