13 Replies Latest reply: May 4, 2012 8:32 PM by David7400
THaarmann Level 1 Level 1 (0 points)

Suddenly a problem occurs. In battery mode the suspend mode is working fine. I didn't change anything and for testing I disconnected any other hardware or network connections. The issue is still going on.

 

Console messages after a failed suspend:

19.11.11 11:45:18,000 kernel: Sound assertion "0 == fAudioEngineArray" failed in AppleHDADriver at line 3163 goto Exit

19.11.11 11:45:18,000 kernel: Sound assertion "0 == fAudioEngineArray" failed in AppleHDADriver at line 3163 goto Exit

19.11.11 11:45:18,000 kernel: Sound assertion "0 == fAudioEngineArray" failed in AppleHDADriver at line 3163 goto Exit

19.11.11 11:45:18,000 kernel: Sound assertion "0 == fAudioEngineArray" failed in AppleHDADriver at line 3163 goto Exit

 

This messages isn't shown when the MBP is running in battery.


MacBook Pro, Mac OS X (10.7.2)
  • 1. Re: MBP doesn't go to suspend mode when the AC-supply is connected
    sig Level 8 Level 8 (35,770 points)

    Sleep mode is what it is called. By which method are you trying to get it to sleep?

    1. select from Apple menu

    2. closing the screen

    3. energy saver setting

  • 2. Re: MBP doesn't go to suspend mode when the AC-supply is connected
    THaarmann Level 1 Level 1 (0 points)

    it's not relevant, which method I use. All three are not working properly if the power supply is on. The behavior is always the same. After activation the sleep mode, e.g. by Apple menu, the external screen is going black after 10 seconds but the harddisk or fan is still working. In additon all USB devices are plugged off. If I plug off the power supply after the screen went black, the MBP is going to sleep after some seconds normaly.

     

    I didn't change anything on the system over the last days. The only one I made before the new situation occured was the time capsule firmware update.

     

    MBP mid 2010 (6,2)

    OS X 10.7.2

  • 3. Re: MBP doesn't go to suspend mode when the AC-supply is connected
    sig Level 8 Level 8 (35,770 points)

    Everything is relevant when trouble shooting an issue. Have you tried booting into the Lion Recovery disk and running Repair Disk from Disk Utility?

  • 4. Re: MBP doesn't go to suspend mode when the AC-supply is connected
    THaarmann Level 1 Level 1 (0 points)

    Thanks. After your reply I started the disk utility program and activated the function disk ceckup. The system aborts the process with a failure message, that the system has to be booted by Lion Recovery Disk to start the Disk Repair Program. I have the Lion OS on an USB stick and hope the service will be selectable as well.

  • 5. Re: MBP doesn't go to suspend mode when the AC-supply is connected
    THaarmann Level 1 Level 1 (0 points)

    Repair is done with status "OK", but the problem is still going on. No change has been identified. Do you need any other reports or data?

  • 6. Re: MBP doesn't go to suspend mode when the AC-supply is connected
    sig Level 8 Level 8 (35,770 points)

    Run Repair Disk again.

  • 7. Re: MBP doesn't go to suspend mode when the AC-supply is connected
    THaarmann Level 1 Level 1 (0 points)

    I did it again including "access rights repair". The process brought up some messager for access parameter changes. But without any new results regarding loss of sleep mode.

     

    Konsole:

    21.11.11 15:22:57,625 UserEventAgent: ACRR: Failed to save usage store to /Users/thomashaarmann/Library/Application Support/CrashReporter/Intervals_76F49C32-BC18-5269-B5CE-9BA90D0E03A2.plist

     

    21.11.11 15:23:23,524 [0x0-0x30030].backupd-helper: Not starting Time Machine backup after wake - less than 60 minutes since last backup completed.

    21.11.11 15:23:24,000 kernel: Sound assertion "0 == fAudioEngineArray" failed in AppleHDADriver at line 3047 goto Exit

    21.11.11 15:23:24,000 kernel: Sound assertion "0 == fAudioEngineArray" failed in AppleHDADriver at line 3047 goto Exit

    21.11.11 15:23:24,000 kernel: Sound assertion "0 == fAudioEngineArray" failed in AppleHDADriver at line 3047 goto Exit

    21.11.11 15:23:24,000 kernel: Sound assertion "0 == fAudioEngineArray" failed in AppleHDADriver at line 3047 goto Exit

  • 8. Re: MBP doesn't go to suspend mode when the AC-supply is connected
    nkdeye Level 1 Level 1 (0 points)

    I am having the same problem, howeve r disk utility ststaes that the disks are fine. Have you had any luck in fixing this problem?

     

    I have a hunch it is either because of the ethernet or power port, as whenevre I unplug both the screen comes back on after a short while.

     

    Here are some of the error messages I am getting:

     

    06/12/2011 15:20:05.000 kernel: Sound assertion "0 == fAudioEngineArray" failed in AppleHDADriver at line 3163 goto Exit

    06/12/2011 15:20:05.000 kernel: Sound assertion "0 == fAudioEngineArray" failed in AppleHDADriver at line 3163 goto Exit

    06/12/2011 15:20:05.000 kernel: Sound assertion "0 == fAudioEngineArray" failed in AppleHDADriver at line 3163 goto Exit

    06/12/2011 15:20:05.000 kernel: Sound assertion "0 == fAudioEngineArray" failed in AppleHDADriver at line 3163 goto Exit

    06/12/2011 15:24:02.000 kernel: Sound assertion "0 != result" failed in AppleHDAController at line 6566 goto handler

    06/12/2011 15:24:02.000 kernel: Sound assertion "0 != result" failed in AppleHDAController at line 6566 goto handler

    06/12/2011 15:24:02.000 kernel: Sound assertion "0 != result" failed in AppleHDAController at line 6566 goto handler

  • 9. Re: MBP doesn't go to suspend mode when the AC-supply is connected
    THaarmann Level 1 Level 1 (0 points)

    Hi,

     

    I solved the problem! That's the good news. The bad one is, that everything I found on the community didn't help. I also visited the Genius at the Apple Store and they couldn't help as well. The only thing what fixed the issue was a Re-Install of Lion. I took the Recovery of Lion and after 30 minutes everything worked as I expected. With the Recovery of Lion all other applications, programs etc. haven't changed.

     

    Don't ask me where the issue was born.

     

    Thomas

  • 10. Re: MBP doesn't go to suspend mode when the AC-supply is connected
    nkdeye Level 1 Level 1 (0 points)

    Thanks Thomas. I'll give it a go.

  • 11. Re: MBP doesn't go to suspend mode when the AC-supply is connected
    ClimbrJohn Level 1 Level 1 (5 points)

    I was having the same problem.  I disabled the "Internet Sharing" service via Sharing in System Preferences and it immediately solved my problem and allowed my MBP to sleep.

     

     

    This error in the console also went away:

     

     

    kernel: Sound assertion "0 == fAudioEngineArray" failed in AppleHDADriver at line 3047 goto Exit

  • 12. Re: MBP doesn't go to suspend mode when the AC-supply is connected
    qball12 Level 1 Level 1 (0 points)

    I've got the same problem but on an iMac 27" end of 2009. When i put it to sleep it either wakes up straight away or goes black but HDD is running. Only keyboard is plugged in via USB and Magic Mouse is on bluetooth. The only suspicious console line after waking up is :

     

    05.03.2012 15:15:39,000 kernel: Sound assertion "0 == fAudioEngineArray" failed in AppleHDADriver at line 3047 goto Exit

     

    I disabled all internet sharing and WOL.

  • 13. Re: MBP doesn't go to suspend mode when the AC-supply is connected
    David7400 Level 1 Level 1 (0 points)

    I've been having issues with my imac not sleeping for ages and was getting the same messages as everyone here in the kernel log.

     

    First time it happened it was just a hard drive preventing it from sleeping. This time I have figured it to be "screen sharing", so I have set this to off now.

     

    For anyone having similar issues. Try turning off and on different sharing settings!