1 2 Previous Next 17 Replies Latest reply: Dec 1, 2011 6:20 AM by rkaufmann87
alibao Level 1 Level 1 (0 points)

My machine is having kernel panics, Its so unstable that hard to predict what went wrong. Here are few things that I have tried so far but no luck!

 

0) Cleared all the system/application cache/logs

1) Fixed the disk permissions using Disk utility

2) Repaired the system files while running the Snow Leopard installation without formatting the drive

3) Tried safe-boot

 

Its just so unsubtle that I will get kernel panic on average of 30 minutes to few hours (max 6 to 10 hours). The panic can happen even with free RAM upto 50%. I have submitted so many crash reports to apple but never heard a thing.

 

Really, don't want to do clean installation. Any thoughts?

 

regards,

ali


iMac, Mac OS X (10.6.8)
  • 2. Re: kernel panics
    alibao Level 1 Level 1 (0 points)

    Thanks Den, I actually saw that information but there is nothing relevant. It seems the last option would be to do kernel debug. Let see if someone else have any quick fix!

     

     

    I have a strong impression that its software problem not the hardware. Most likely it has to do with loadable modules (ktext).

     

    regards,

    ali

  • 3. Re: kernel panics
    rkaufmann87 Level 8 Level 8 (42,145 points)

    Please post the last KP log and we can take a look to see if there are any obivious issues. You can find it at:

     

    /Library/Logs/DiagnosticReports

  • 4. Re: kernel panics
    alibao Level 1 Level 1 (0 points)

    Here is the latest one! Jsut wonder if its worth burning calories to debug the kernel panic? I can give it a try to setup the debug environment if it can be done on single machine (which i doubt). Mostly, 2 machines are required for such a task but not sure about Darwin.

     

     

    Interval Since Last Panic Report:  129652 sec

    Panics Since Last Report:          2

    Anonymous UUID:                    2DA683D0-BCD4-4931-9A39-64A57CB78519

     

     

    Sun Nov 20 07:59:46 2011

    panic(cpu 0 caller 0x2abf6a): Kernel trap at 0x002327c4, type 14=page fault, registers:

    CR0: 0x8001003b, CR2: 0x21000000, CR3: 0x00100000, CR4: 0x00000668

    EAX: 0x030cecdc, EBX: 0x030cecd0, ECX: 0x00000000, EDX: 0x4b7cecdc

    CR2: 0x21000000, EBP: 0x52a83db8, ESI: 0x21000000, EDI: 0x099d0044

    EFL: 0x00010083, EIP: 0x002327c4, CS:  0x00000008, DS:  0xffff0010

    Error code: 0x00000000

     

     

    Backtrace (CPU 0), Frame : Return Address (4 potential args on stack)

    0x52a83b98 : 0x21b837 (0x5dd7fc 0x52a83bcc 0x223ce1 0x0)

    0x52a83be8 : 0x2abf6a (0x59e3d0 0x2327c4 0xe 0x59e59a)

    0x52a83cc8 : 0x2a1a78 (0x52a83ce0 0xffffffff 0x52a83db8 0x2327c4)

    0x52a83cd8 : 0x2327c4 (0xe 0x48 0x7f300010 0x8380010)

    0x52a83db8 : 0x232bb3 (0x0 0x64 0x52a83e10 0x202)

    0x52a83dd8 : 0x2110b3 (0x99d0044 0x0 0x0 0x0)

    0x52a83e28 : 0x2113dd (0x99d0044 0x14bcbd00 0x28434c8 0x4)

    0x52a83e88 : 0x210bc1 (0x99d0044 0x14bcbd00 0x10000 0x0)

    0x52a83ee8 : 0x21e0cb (0x14bcbd00 0x10000 0x0 0x231c92)

    0x52a83f18 : 0x222cb1 (0x52a83f30 0x30 0x0 0x0)

    0x52a83f78 : 0x230235 (0x14bcd054 0x0 0x52a83fc8 0x227cea)

    0x52a83fc8 : 0x2a179c (0x863ea0 0x0 0x10 0x0)

     

     

    BSD process name corresponding to current thread: kernel_task

     

     

    Mac OS version:

    10K549

     

     

    Kernel version:

    Darwin Kernel Version 10.8.0: Tue Jun  7 16:33:36 PDT 2011; root:xnu-1504.15.3~1/RELEASE_I386

    System model name: iMac10,1 (Mac-F2268CC8)

     

     

    System uptime in nanoseconds: 56367957386391

    unloaded kexts:

    com.apple.driver.AppleFileSystemDriver          2.0 (addr 0xfdc000, size 0x12288) - last unloaded 116156392446

    loaded kexts:

    org.virtualbox.kext.VBoxNetAdp          4.1.0 - last loaded 24107422619

    org.virtualbox.kext.VBoxNetFlt          4.1.0

    org.virtualbox.kext.VBoxUSB          4.1.0

    org.virtualbox.kext.VBoxDrv          4.1.0

    com.bresink.driver.BRESINKx86Monitoring          7.0

    com.avast.PacketForwarder          1.2

    com.avast.AvastFileShield          1.0.1

    com.apple.driver.AppleHWSensor          1.9.3d0

    com.apple.driver.AppleBluetoothMultitouch          54.3

    com.apple.filesystems.autofs          2.1.0

    com.apple.driver.AppleMikeyHIDDriver          1.2.0

    com.apple.driver.AGPM          100.12.31

    com.apple.driver.AppleHDA          2.0.5f14

    com.apple.driver.AppleMikeyDriver          2.0.5f14

    com.apple.driver.AppleUpstreamUserClient          3.5.7

    com.apple.driver.AppleMCCSControl          1.0.20

    com.apple.driver.AudioAUUC          1.57

    com.apple.driver.AirPort.Atheros21          425.14.7

    com.apple.Dont_Steal_Mac_OS_X          7.0.0

    com.apple.iokit.CHUDUtils          201

    com.apple.iokit.CHUDProf          212

    com.apple.driver.AudioIPCDriver          1.1.6

    com.apple.driver.AppleIntelPenrynProfile          17

    com.apple.driver.ACPI_SMC_PlatformPlugin          4.7.0a1

    com.apple.driver.AppleLPC          1.5.1

    com.apple.driver.AppleBacklight          170.0.46

    com.apple.GeForce          6.3.6

    com.apple.driver.AppleIRController          303.8

    com.apple.driver.AppleUSBCardReader          2.6.1

    com.apple.iokit.SCSITaskUserClient          2.6.8

    com.apple.BootCache          31.1

    com.apple.AppleFSCompression.AppleFSCompressionTypeZlib          1.0.0d1

    com.apple.iokit.IOAHCIBlockStorage          1.6.4

    com.apple.driver.AppleFWOHCI          4.7.3

    com.apple.driver.AppleAHCIPort          2.1.7

    com.apple.driver.AppleUSBHub          4.2.4

    com.apple.driver.AppleEFINVRAM          1.4.0

    com.apple.nvenet          2.0.17

    com.apple.driver.AppleRTC          1.3.1

    com.apple.driver.AppleUSBOHCI          4.2.0

    com.apple.driver.AppleUSBEHCI          4.2.4

    com.apple.driver.AppleHPET          1.5

    com.apple.driver.AppleACPIButtons          1.3.6

    com.apple.driver.AppleSMBIOS          1.7

    com.apple.driver.AppleACPIEC          1.3.6

    com.apple.driver.AppleAPIC          1.4

    com.apple.driver.AppleIntelCPUPowerManagementClient          142.6.0

    com.apple.security.sandbox          1

    com.apple.security.quarantine          0

    com.apple.nke.applicationfirewall          2.1.14

    com.apple.driver.AppleIntelCPUPowerManagement          142.6.0

    com.apple.driver.IOBluetoothHIDDriver          2.4.5f3

    com.apple.driver.AppleMultitouchDriver          207.11

    com.apple.driver.DspFuncLib          2.0.5f14

    com.apple.driver.AppleProfileReadCounterAction          17

    com.apple.driver.AppleProfileTimestampAction          10

    com.apple.driver.AppleProfileThreadInfoAction          14

    com.apple.driver.AppleProfileRegisterStateAction          10

    com.apple.driver.AppleProfileKEventAction          10

    com.apple.driver.AppleProfileCallstackAction          20

    com.apple.iokit.IO80211Family          320.1

    com.apple.driver.AppleSMBusController          1.0.10d0

    com.apple.iokit.IOFireWireIP          2.0.3

    com.apple.iokit.IOSurface          74.2

    com.apple.iokit.IOBluetoothSerialManager          2.4.5f3

    com.apple.iokit.IOSerialFamily          10.0.3

    com.apple.iokit.CHUDKernLib          203

    com.apple.iokit.IOAudioFamily          1.8.3fc2

    com.apple.kext.OSvKernDSPLib          1.3

    com.apple.driver.AppleHDAController          2.0.5f14

    com.apple.iokit.IOHDAFamily          2.0.5f14

    com.apple.iokit.AppleProfileFamily          41

    com.apple.driver.AppleSMC          3.1.0d5

    com.apple.driver.IOPlatformPluginFamily          4.7.0a1

    com.apple.driver.AppleSMBusPCI          1.0.10d0

    com.apple.driver.AppleBacklightExpert          1.0.1

    com.apple.nvidia.nv50hal          6.3.6

    com.apple.NVDAResman          6.3.6

    com.apple.iokit.IONDRVSupport          2.2.1

    com.apple.iokit.IOGraphicsFamily          2.2.1

    com.apple.driver.AppleUSBHIDKeyboard          141.5

    com.apple.driver.AppleHIDKeyboard          141.5

    com.apple.driver.BroadcomUSBBluetoothHCIController          2.4.5f3

    com.apple.driver.AppleUSBBluetoothHCIController          2.4.5f3

    com.apple.iokit.IOBluetoothFamily          2.4.5f3

    com.apple.iokit.IOUSBHIDDriver          4.2.0

    com.apple.iokit.IOSCSIBlockCommandsDevice          2.6.8

    com.apple.iokit.IOUSBMassStorageClass          2.6.7

    com.apple.driver.AppleUSBMergeNub          4.2.4

    com.apple.driver.AppleUSBComposite          3.9.0

    com.apple.iokit.IOSCSIMultimediaCommandsDevice          2.6.8

    com.apple.iokit.IOBDStorageFamily          1.6

    com.apple.iokit.IODVDStorageFamily          1.6

    com.apple.iokit.IOCDStorageFamily          1.6.1

    com.apple.iokit.IOAHCISerialATAPI          1.2.6

    com.apple.iokit.IOSCSIArchitectureModelFamily          2.6.8

    com.apple.driver.XsanFilter          402.1

    com.apple.iokit.IOFireWireFamily          4.2.6

    com.apple.iokit.IOAHCIFamily          2.0.6

    com.apple.iokit.IOUSBUserClient          4.2.4

    com.apple.iokit.IONetworkingFamily          1.10

    com.apple.driver.NVSMU          2.2.7

    com.apple.driver.AppleEFIRuntime          1.4.0

    com.apple.iokit.IOUSBFamily          4.2.4

    com.apple.iokit.IOHIDFamily          1.6.6

    com.apple.iokit.IOSMBusFamily          1.1

    com.apple.kext.AppleMatch          1.0.0d1

    com.apple.security.TMSafetyNet          6

    com.apple.driver.DiskImages          289.1

    com.apple.iokit.IOStorageFamily          1.6.3

    com.apple.driver.AppleACPIPlatform          1.3.6

    com.apple.iokit.IOPCIFamily          2.6.5

    com.apple.iokit.IOACPIFamily          1.3.0

  • 5. Re: kernel panics
    rkaufmann87 Level 8 Level 8 (42,145 points)

    Thanks for posting the KP log. Your KP happens when OS X sees org.virtualbox.kext.VBoxNetAdp  . This doesn't mean Virtual Box has to be running it only means that software is creating the KP. I would recommend uninstalling Virtual Box and either re-installing or using a commercial alternative such as Parallels or Fusion.

     

    It's also possible it could be caused by com.bresink.driver.BRESINKx86Monitoring whatever that is. And to complex matters a little more it could be com.avast.PacketForwarder whatever that is too.

     

    I would start by checking what version of Virtual Box your system has and then checking if it's the most up-to-date version. If it is then uninstall and reinstall, if it's not up-to-date then update it per Oracle's instructions.

  • 6. Re: kernel panics
    alibao Level 1 Level 1 (0 points)

    Thanks for quick response.

     

    0) I am having KP even in safe-boot. According to my understanding "only" apple related loadable modules are present during safe-boot option. 

     

    1) Here is KP again even after removing the VirtualBox and output is at the end of this post. I have used uninstaller provided by the VirtualBox package. And did the same thing to get rid of avast.

     

     

    2) Here is my current machine status:

     

     

    pnt:~ mebsh$ kextstat | grep -v apple

    Index Refs Address    Size       Wired      Name (Version) <Linked Against>

    pnt:~ mebsh$

     

     

    Any thoughts?

     

    regards,

    ali

     

    --------------------kernel_panic__________________

     

    Sun Nov 20 16:16:14 2011

    panic(cpu 0 caller 0x2abf6a): Kernel trap at 0x009c57e6, type 14=page fault, registers:

    CR0: 0x8001003b, CR2: 0x00000140, CR3: 0x00100000, CR4: 0x00000668

    EAX: 0x0000649d, EBX: 0x0947b004, ECX: 0xe400649d, EDX: 0x07200324

    CR2: 0x00000140, EBP: 0x0010be08, ESI: 0x00000000, EDI: 0x00000140

    EFL: 0x00010007, EIP: 0x009c57e6, CS:  0x00000008, DS:  0x00840010

    Error code: 0x00000002

     

     

    Backtrace (CPU 0), Frame : Return Address (4 potential args on stack)

    0x10bc28 : 0x21b837 (0x5dd7fc 0x10bc5c 0x223ce1 0x0)

    0x10bc78 : 0x2abf6a (0x59e3d0 0x9c57e6 0xe 0x59e59a)

    0x10bd58 : 0x2a1a78 (0x10bd70 0x5 0x10be08 0x9c57e6)

    0x10bd68 : 0x9c57e6 (0xe 0x48 0x10 0x11c0010)

    0x10be08 : 0x9c4774 (0x947b020 0x649d 0x6400 0x2b39af)

    0x10be28 : 0xae8856 (0x947b004 0x649d 0x10be58 0x226223)

    0x10be48 : 0xaeb905 (0x947b004 0x140 0x0 0x2b1f6a)

    0x10be88 : 0x9dca20 (0x947b004 0x140 0x0 0x0)

    0x10bea8 : 0x974fc7 (0x0 0x3f8 0xf22b34ce 0x3f8)

    0x10bec8 : 0x556636 (0x8c62800 0x920f580 0x10bf28 0x298d4a)

    0x10bef8 : 0x929053 (0x920f580 0x0 0x83b0600 0x1)

    0x10bf18 : 0xe7f213 (0x83e3800 0x0 0x0 0x92)

    0x10bf38 : 0xe8a911 (0x92 0x0 0x10bf78 0x0)

    0x10bf58 : 0x580d96 (0x8353580 0x0 0x8353680 0x92)

    0x10bf78 : 0x2ab432 (0x92 0x5938bc40 0x222 0x1)

    0x10bfd8 : 0x2a1c2e (0x5938bc40 0x2a2a00 0x0 0x2a2a5b)

    0x5938bcd8 : 0x225bba (0x84bf3c 0xf20d5ec1 0x3f8 0x84bf28)

    0x5938bd38 : 0x22698c (0x1 0xea2a3d4 0x81cdc58 0x10c2c2d)

    0x5938bda8 : 0x2275b0 (0xea2a3f0 0x3f8 0x5938be28 0x1)

    0x5938be18 : 0x227654 (0x22a88f 0x0 0x0 0x1e)

    0x5938be38 : 0x22ac50 (0x22a88f 0x0 0x80 0x2)

    0x5938be98 : 0x22ad74 (0xf26599ac 0x3f8 0x0 0x2ab22a)

    0x5938bee8 : 0x22adc9 (0x4903 0x4a03 0x0 0x584021)

    0x5938bf18 : 0x295914 (0x5938bf44 0x0 0x0 0x0)

    0x5938bfc8 : 0x2a20f8 (0xc238a60 0x1 0x10 0x122637a0)

          Kernel Extensions in backtrace (with dependencies):

             com.apple.NVDAResman(6.3.6)@0x96e000->0xc5bfff

                dependency: com.apple.iokit.IOPCIFamily(2.6.5)@0x928000

                dependency: com.apple.iokit.IONDRVSupport(2.2.1)@0x961000

                dependency: com.apple.iokit.IOGraphicsFamily(2.2.1)@0x93f000

             com.apple.driver.AppleACPIPlatform(1.3.6)@0xe7d000->0xebffff

                dependency: com.apple.iokit.IOACPIFamily(1.3.0)@0x914000

                dependency: com.apple.iokit.IOPCIFamily(2.6.5)@0x928000

             com.apple.iokit.IOPCIFamily(2.6.5)@0x928000->0x93efff

     

     

    BSD process name corresponding to current thread: GarageBand

     

     

    Mac OS version:

    10K549

     

     

    Kernel version:

    Darwin Kernel Version 10.8.0: Tue Jun  7 16:33:36 PDT 2011; root:xnu-1504.15.3~1/RELEASE_I386

    System model name: iMac10,1 (Mac-F2268CC8)

     

     

    System uptime in nanoseconds: 4367749860432

    unloaded kexts:

    com.apple.driver.AppleFileSystemDriver          2.0 (addr 0xfdc000, size 0x12288) - last unloaded 168739979272

    loaded kexts:

    com.apple.driver.AppleHWSensor          1.9.3d0 - last loaded 22737011624

    com.apple.filesystems.autofs          2.1.0

    com.apple.driver.AppleBluetoothMultitouch          54.3

    com.apple.driver.AGPM          100.12.31

    com.apple.driver.AppleMikeyHIDDriver          1.2.0

    com.apple.driver.AppleUpstreamUserClient          3.5.7

  • 7. Re: kernel panics
    rkaufmann87 Level 8 Level 8 (42,145 points)

    If you removed Virtual Box and the Avast software following the manufacturer's instructions then you should start using the links listed above to troubleshoot your KP. If you did not follow the manufacturers instructions then you need to.

     

    I suspect your issue is software related however because KP's can be tough to figure out you may need the help of a professional.

  • 8. Re: kernel panics
    alibao Level 1 Level 1 (0 points)

    Yes, VirtualBox and avast were removed with proper uninstaller from their vendors.

     

     

    The most interesting thing is that KP happening in safe-boot. Which certainly points to problems surfacing to system itself. I can only think about 2 things, maybe it has todo with this new update of 10.6.8 as i see lots of people talking about it. Secondly, I remember compiling bin utilities while ago, maybe that is causing some compatability issues.

     

    Whatever it is. I am still trying every single thing and will let you know if i have something interesting.

  • 9. Re: kernel panics
    rkaufmann87 Level 8 Level 8 (42,145 points)

    10.6.8 is pretty solid and shouldn't cause KP's on it's own, I'm pretty sure it's being caused by something else. As I mentioned KP's can be difficult to figure out. I've seen them caused by faulty peripherals connected to a computer, failing HD's, and of course software. What is causing yours I'm not sure but I feel safe saying 10.6.8 isn't the "why." You can try disconnected peripherals one by one to see if they may be the cause and as I mentioned earlier you may want to have a professional starting looking at it.

  • 10. Re: kernel panics
    alibao Level 1 Level 1 (0 points)

    Gave it another shot while writing whole system files with this http://support.apple.com/kb/DL1399  Let see how it goes.

     

    What sort of profesional would you recommend?

  • 11. Re: kernel panics
    rkaufmann87 Level 8 Level 8 (42,145 points)

    Taking it to an AASP (Apple Authorized Service Provider), btw what peripheral devices are connected and have you eliminated each one by one to see if one of them is causing the problem?

  • 12. Re: kernel panics
    alibao Level 1 Level 1 (0 points)

    Don't have much devices connected. Only printer and USB keyboard. Juut had a **** KP again even after installtion of 10.6.8 combo.

     

    I have Apple care still valid so gonna call them now.

     

    Another option I am looking at this stage is console boot, and see if i can find something there.

  • 13. Re: kernel panics
    rkaufmann87 Level 8 Level 8 (42,145 points)

    OK, got it on the peripherals. Have you tried disconnected tgw printer to see what happens? Glad you have AppleCare, give  them a ring in the morning and maybe they will have some bright ideas.

  • 14. Re: kernel panics
    alibao Level 1 Level 1 (0 points)

    Alright, I called them and performed the basic usual things like flush the RAM, SCM, verify Disk and remove everything form computer before restart. Everything went well except the AHT, the CD that came with this machine is somehow broken so couldn't perform the test. They will ship a new CD to me.

     

    I don't have much hope as I was told AHT is the first option in case there is hardware problem. If everything goes well with successful results then there is only option 2! which is clean installation.

     

    I will not do it that quick.  Hey, BTW can we boot in console and load the X server form command line? (like linux, win machines ) maybe that would give some hints.

1 2 Previous Next